From: loic pallardy <loic.pallardy@st.com>
To: Lee Jones <lee.jones@linaro.org>
Cc: bjorn.andersson@linaro.org, ohad@wizery.com,
linux-remoteproc@vger.kernel.org, linux-kernel@vger.kernel.org,
kernel@stlinux.com
Subject: Re: [PATCH v2 12/19] remoteproc: core: Add vdev support and force mode to resource amending function
Date: Thu, 8 Sep 2016 15:11:42 +0200 [thread overview]
Message-ID: <ea801184-085d-55eb-cbe5-6cb69708b52f@st.com> (raw)
In-Reply-To: <20160908110209.GQ4921@dell>
On 09/08/2016 01:02 PM, Lee Jones wrote:
> On Thu, 08 Sep 2016, loic pallardy wrote:
>
>>
>>
>> On 09/08/2016 10:48 AM, Lee Jones wrote:
>>> On Wed, 31 Aug 2016, Loic Pallardy wrote:
>>>
>>>> This patch proposes diverse updates to rproc_update_resource_table_entry
>>>> function:
>>>> - rename rproc_update_resource_table_entry to __update_rsc_tbl_entry to
>>>> have shorter function name.
>>>> - add RSC_VDEV support
>>>> - add force mode resource even if resource already fixed on firmware side.
>>>>
>>>> Signed-off-by: Loic Pallardy <loic.pallardy@st.com>
>>>> ---
>>>> drivers/remoteproc/remoteproc_core.c | 27 ++++++++++++++++++++++-----
>>>> 1 file changed, 22 insertions(+), 5 deletions(-)
>>>>
>>>> diff --git a/drivers/remoteproc/remoteproc_core.c b/drivers/remoteproc/remoteproc_core.c
>>>> index 30e9c70..aff1a00 100644
>>>> --- a/drivers/remoteproc/remoteproc_core.c
>>>> +++ b/drivers/remoteproc/remoteproc_core.c
>>>> @@ -1027,13 +1027,15 @@ static int __verify_rsc_tbl_entry(struct rproc *rproc,
>>>> return -EINVAL;
>>>> }
>>>>
>>>> -static int rproc_update_resource_table_entry(struct rproc *rproc,
>>>> +static int __update_rsc_tbl_entry(struct rproc *rproc,
>>>
>>> Unless the name is unruly, (which I don't think it is, you're still
>>> having to line wrap at the call site), I tend to go for clarity over
>>> brevity.
>> It was only to have reasonable line length. I can keept original name and
>> see impact on rest of the code.
>
> Reasonable line length is 80. This line was 65.
This line yes. Name change proposal is to reduce line where this
function is called (in rproc_apply_resource_overrides for exemple)
But OK to keep standard rproc_xxx naming
>
next prev parent reply other threads:[~2016-09-08 13:11 UTC|newest]
Thread overview: 44+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-31 20:50 [PATCH v2 00/19] remoteproc: Allow platform-specific drivers to request resources Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 01/19] remoteproc: core: New API to add new resources to the resource table Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 02/19] remoteproc: core: Add function to dump " Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 03/19] remoteproc: core: Add function to amend an existing resource table entry Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 04/19] remoteproc: core: Add function to append a new " Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 05/19] remoteproc: core: Add function to over-ride current resource table Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 06/19] remoteproc: core: Add explicit message error if cached table failed Loic Pallardy
2016-09-01 7:09 ` Lee Jones
2016-09-08 9:40 ` loic pallardy
2016-08-31 20:50 ` [PATCH v2 07/19] remoteproc: Add new resource type for resource table spare bytes Loic Pallardy
2016-09-15 17:54 ` Bjorn Andersson
2016-09-16 9:02 ` loic pallardy
2016-09-16 17:12 ` Bjorn Andersson
2016-09-19 7:50 ` loic pallardy
2016-08-31 20:50 ` [PATCH v2 08/19] remoteproc: core: Associate action to resource request Loic Pallardy
2016-09-01 7:23 ` Lee Jones
2016-09-08 9:43 ` loic pallardy
2016-09-08 11:03 ` Lee Jones
2016-08-31 20:50 ` [PATCH v2 09/19] remoteproc: core: Finalize dump resource table function Loic Pallardy
2016-09-08 8:26 ` Lee Jones
2016-09-08 9:46 ` loic pallardy
2016-08-31 20:50 ` [PATCH v2 10/19] remoteproc: core: Add function to verify an existing resource in rsc table Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 11/19] remoteproc: core: Add function to get resource table spare bytes information Loic Pallardy
2016-09-08 8:32 ` Lee Jones
2016-09-08 9:47 ` loic pallardy
2016-08-31 20:50 ` [PATCH v2 12/19] remoteproc: core: Add vdev support and force mode to resource amending function Loic Pallardy
2016-09-08 8:48 ` Lee Jones
2016-09-08 9:49 ` loic pallardy
2016-09-08 11:02 ` Lee Jones
2016-09-08 13:11 ` loic pallardy [this message]
2016-08-31 20:50 ` [PATCH v2 13/19] remoteproc: core: Append resource only if spare resource present Loic Pallardy
2016-09-08 9:33 ` Lee Jones
2016-09-08 9:54 ` loic pallardy
2016-09-08 11:00 ` Lee Jones
2016-08-31 20:50 ` [PATCH v2 14/19] remoteproc: core: Add resource request action support Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 15/19] remoteproc: core: Add function to verify resource table consistency Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 16/19] remoteproc: core: Clean-up resource table sanity checks Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 17/19] remotecore: core: Add resource table pointer argument to rproc_handle_resource Loic Pallardy
2016-08-31 20:50 ` [PATCH v2 18/19] remoteproc: core: Add function to create remoteproc local resource table Loic Pallardy
2016-09-08 10:20 ` Lee Jones
2016-09-08 13:15 ` loic pallardy
2016-09-15 18:58 ` Bjorn Andersson
2016-09-19 7:46 ` loic pallardy
2016-08-31 20:50 ` [PATCH v2 19/19] remoteproc: core: Support empty resource tables Loic Pallardy
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ea801184-085d-55eb-cbe5-6cb69708b52f@st.com \
--to=loic.pallardy@st.com \
--cc=bjorn.andersson@linaro.org \
--cc=kernel@stlinux.com \
--cc=lee.jones@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=ohad@wizery.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox