Linux Renesas SOC kernel development
 help / color / mirror / Atom feed
From: Marek Vasut <marek.vasut@gmail.com>
To: Lee Jones <lee.jones@linaro.org>
Cc: linux-kernel@vger.kernel.org,
	Marek Vasut <marek.vasut+renesas@gmail.com>,
	Geert Uytterhoeven <geert+renesas@glider.be>,
	Mark Brown <broonie@kernel.org>,
	Steve Twiss <stwiss.opensource@diasemi.com>,
	Wolfram Sang <wsa+renesas@sang-engineering.com>,
	linux-renesas-soc@vger.kernel.org
Subject: Re: [PATCH v4 08/12] mfd: da9063: Add custom regmap for DA9063L
Date: Wed, 6 Jun 2018 11:47:19 +0200	[thread overview]
Message-ID: <3e90824b-08d7-015f-9264-4fe4edd05418@gmail.com> (raw)
In-Reply-To: <20180606063936.GY21163@dell>

On 06/06/2018 08:39 AM, Lee Jones wrote:
> On Wed, 06 Jun 2018, Marek Vasut wrote:
> 
>> The DA9063L does not have an RTC. Add custom regmap for DA9063L to
>> prevent access into that register block.
>>
>> Signed-off-by: Marek Vasut <marek.vasut+renesas@gmail.com>
>> Cc: Geert Uytterhoeven <geert+renesas@glider.be>
>> Cc: Lee Jones <lee.jones@linaro.org>
>> Cc: Mark Brown <broonie@kernel.org>
>> Cc: Steve Twiss <stwiss.opensource@diasemi.com>
>> Cc: Wolfram Sang <wsa+renesas@sang-engineering.com>
>> Cc: linux-renesas-soc@vger.kernel.org
>> ---
>> V3: New patch
>> V4: Drop mention of buggy datasheet in the commit message
>> ---
>>  drivers/mfd/da9063-i2c.c | 91 ++++++++++++++++++++++++++++++++++++++++++++++++
>>  1 file changed, 91 insertions(+)
>>
>> diff --git a/drivers/mfd/da9063-i2c.c b/drivers/mfd/da9063-i2c.c
>> index 048ce55ebc5b..f0d92a37df6b 100644
>> --- a/drivers/mfd/da9063-i2c.c
>> +++ b/drivers/mfd/da9063-i2c.c
>> @@ -208,6 +208,93 @@ static const struct regmap_access_table da9063_bb_volatile_table = {
>>  	.n_yes_ranges = ARRAY_SIZE(da9063_bb_volatile_ranges),
>>  };
>>  
>> +static const struct regmap_range da9063l_bb_readable_ranges[] = {
>> +	{
>> +		.range_min = DA9063_REG_PAGE_CON,
>> +		.range_max = DA9063_REG_MON_A10_RES,
>> +	}, {
>> +		.range_min = DA9063_REG_SEQ,
>> +		.range_max = DA9063_REG_ID_32_31,
>> +	}, {
>> +		.range_min = DA9063_REG_SEQ_A,
>> +		.range_max = DA9063_REG_AUTO3_LOW,
>> +	}, {
>> +		.range_min = DA9063_REG_T_OFFSET,
>> +		.range_max = DA9063_BB_REG_GP_ID_19,
>> +	}, {
>> +		.range_min = DA9063_REG_CHIP_ID,
>> +		.range_max = DA9063_REG_CHIP_VARIANT,
>> +	},
>> +};
>> +
>> +static const struct regmap_range da9063l_bb_writeable_ranges[] = {
>> +	{
>> +		.range_min = DA9063_REG_PAGE_CON,
>> +		.range_max = DA9063_REG_PAGE_CON,
>> +	}, {
>> +		.range_min = DA9063_REG_FAULT_LOG,
>> +		.range_max = DA9063_REG_VSYS_MON,
>> +	}, {
>> +		.range_min = DA9063_REG_SEQ,
>> +		.range_max = DA9063_REG_ID_32_31,
>> +	}, {
>> +		.range_min = DA9063_REG_SEQ_A,
>> +		.range_max = DA9063_REG_AUTO3_LOW,
>> +	}, {
>> +		.range_min = DA9063_REG_CONFIG_I,
>> +		.range_max = DA9063_BB_REG_MON_REG_4,
>> +	}, {
>> +		.range_min = DA9063_BB_REG_GP_ID_0,
>> +		.range_max = DA9063_BB_REG_GP_ID_19,
>> +	},
>> +};
>> +
>> +static const struct regmap_range da9063l_bb_volatile_ranges[] = {
>> +	{
>> +		.range_min = DA9063_REG_PAGE_CON,
>> +		.range_max = DA9063_REG_EVENT_D,
>> +	}, {
>> +		.range_min = DA9063_REG_CONTROL_A,
>> +		.range_max = DA9063_REG_CONTROL_B,
>> +	}, {
>> +		.range_min = DA9063_REG_CONTROL_E,
>> +		.range_max = DA9063_REG_CONTROL_F,
>> +	}, {
>> +		.range_min = DA9063_REG_BCORE2_CONT,
>> +		.range_max = DA9063_REG_LDO11_CONT,
>> +	}, {
>> +		.range_min = DA9063_REG_DVC_1,
>> +		.range_max = DA9063_REG_ADC_MAN,
>> +	}, {
>> +		.range_min = DA9063_REG_ADC_RES_L,
>> +		.range_max = DA9063_REG_MON_A10_RES,
>> +	}, {
>> +		.range_min = DA9063_REG_SEQ,
>> +		.range_max = DA9063_REG_SEQ,
>> +	}, {
>> +		.range_min = DA9063_REG_EN_32K,
>> +		.range_max = DA9063_REG_EN_32K,
>> +	}, {
>> +		.range_min = DA9063_BB_REG_MON_REG_5,
>> +		.range_max = DA9063_BB_REG_MON_REG_6,
>> +	},
>> +};
> 
> Not sure why the regmap_reg_range() MACRO is lower case, but still,
> please make use of it to save a few lines.

Ha, OK

> Once changed, please add my:
> 
> For my own reference:
>   Acked-for-MFD-by: Lee Jones <lee.jones@linaro.org>
> 


-- 
Best regards,
Marek Vasut

  reply	other threads:[~2018-06-06  9:50 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-05 23:10 [PATCH v4 01/12] mfd: da9063: Fix failpath in core Marek Vasut
2018-06-05 23:10 ` [PATCH v4 02/12] mfd: da9063: Use REGMAP_IRQ_REG Marek Vasut
2018-06-05 23:10 ` [PATCH v4 03/12] mfd: da9063: Use PLATFORM_DEVID_NONE Marek Vasut
2018-06-06  6:25   ` Geert Uytterhoeven
2018-06-06  6:34   ` Lee Jones
2018-06-05 23:10 ` [PATCH v4 04/12] mfd: da9063: Replace DA9063_NUM_IRQ with ARRAY_SIZE Marek Vasut
2018-06-06  6:28   ` Geert Uytterhoeven
2018-06-06  6:36   ` Lee Jones
2018-06-05 23:10 ` [PATCH v4 05/12] mfd: da9063: Rename PMIC_DA9063 to PMIC_CHIP_ID_DA9063 Marek Vasut
2018-06-05 23:10 ` [PATCH v4 06/12] mfd: da9063: Replace model with type Marek Vasut
2018-06-06 14:04   ` kbuild test robot
2018-06-05 23:10 ` [PATCH v4 07/12] mfd: da9063: Add DA9063L type Marek Vasut
2018-06-05 23:10 ` [PATCH v4 08/12] mfd: da9063: Add custom regmap for DA9063L Marek Vasut
2018-06-06  6:39   ` Lee Jones
2018-06-06  9:47     ` Marek Vasut [this message]
2018-06-05 23:10 ` [PATCH v4 09/12] mfd: da9063: Add custom IRQ map " Marek Vasut
2018-06-06  6:40   ` Lee Jones
2018-06-05 23:10 ` [PATCH v4 10/12] mfd: da9063: Register RTC only on DA9063L Marek Vasut
2018-06-06  6:41   ` Lee Jones
2018-06-05 23:10 ` [PATCH v4 11/12] regulator: da9063: Handle less LDOs " Marek Vasut
2018-06-05 23:10 ` [PATCH v4 12/12] mfd: da9063: Add DA9063L support Marek Vasut
2018-06-06  6:24 ` [PATCH v4 01/12] mfd: da9063: Fix failpath in core Geert Uytterhoeven
2018-06-06  6:35 ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3e90824b-08d7-015f-9264-4fe4edd05418@gmail.com \
    --to=marek.vasut@gmail.com \
    --cc=broonie@kernel.org \
    --cc=geert+renesas@glider.be \
    --cc=lee.jones@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=marek.vasut+renesas@gmail.com \
    --cc=stwiss.opensource@diasemi.com \
    --cc=wsa+renesas@sang-engineering.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox