From: Andrzej Pietrasiewicz <andrzej.p@collabora.com>
To: linux-pm@vger.kernel.org, linux-acpi@vger.kernel.org,
netdev@vger.kernel.org, linux-wireless@vger.kernel.org,
platform-driver-x86@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-renesas-soc@vger.kernel.org,
linux-rockchip@lists.infradead.org
Cc: "Rafael J . Wysocki" <rjw@rjwysocki.net>,
Len Brown <lenb@kernel.org>, Vishal Kulkarni <vishal@chelsio.com>,
"David S . Miller" <davem@davemloft.net>,
Jiri Pirko <jiri@mellanox.com>,
Ido Schimmel <idosch@mellanox.com>,
Johannes Berg <johannes.berg@intel.com>,
Emmanuel Grumbach <emmanuel.grumbach@intel.com>,
Luca Coelho <luciano.coelho@intel.com>,
Intel Linux Wireless <linuxwifi@intel.com>,
Kalle Valo <kvalo@codeaurora.org>, Peter Kaestle <peter@piie.net>,
Darren Hart <dvhart@infradead.org>,
Andy Shevchenko <andy@infradead.org>,
Sebastian Reichel <sre@kernel.org>,
Miquel Raynal <miquel.raynal@bootlin.com>,
Daniel Lezcano <daniel.lezcano@linaro.org>,
Amit Kucheria <amit.kucheria@verdurent.com>,
Support Opensource <support.opensource@diasemi.com>
Subject: [PATCH v7 00/11] Stop monitoring disabled devices
Date: Mon, 29 Jun 2020 14:29:14 +0200 [thread overview]
Message-ID: <20200629122925.21729-1-andrzej.p@collabora.com> (raw)
A respin of v6 with these changes:
v6..v7:
- removed duplicate S-o-b line from patch 6/11
v5..v6:
- staticized thermal_zone_device_set_mode() (kbuild test robot)
v4..v5:
- EXPORT_SYMBOL -> EXPORT_SYMBOL_GPL (Daniel)
- dropped unnecessary thermal_zone_device_enable() in int3400_thermal.c
and in thermal_of.c (Bartlomiej)
Andrzej Pietrasiewicz (11):
acpi: thermal: Fix error handling in the register function
thermal: Store thermal mode in a dedicated enum
thermal: Add current mode to thermal zone device
thermal: Store device mode in struct thermal_zone_device
thermal: remove get_mode() operation of drivers
thermal: Add mode helpers
thermal: Use mode helpers in drivers
thermal: Explicitly enable non-changing thermal zone devices
thermal: core: Stop polling DISABLED thermal devices
thermal: Simplify or eliminate unnecessary set_mode() methods
thermal: Rename set_mode() to change_mode()
drivers/acpi/thermal.c | 75 +++++----------
.../ethernet/chelsio/cxgb4/cxgb4_thermal.c | 8 ++
.../ethernet/mellanox/mlxsw/core_thermal.c | 91 ++++---------------
drivers/net/wireless/intel/iwlwifi/mvm/tt.c | 9 +-
drivers/platform/x86/acerhdf.c | 33 +++----
drivers/platform/x86/intel_mid_thermal.c | 6 ++
drivers/power/supply/power_supply_core.c | 9 +-
drivers/thermal/armada_thermal.c | 6 ++
drivers/thermal/da9062-thermal.c | 16 +---
drivers/thermal/dove_thermal.c | 6 ++
drivers/thermal/hisi_thermal.c | 6 +-
drivers/thermal/imx_thermal.c | 57 ++++--------
.../intel/int340x_thermal/int3400_thermal.c | 38 ++------
.../int340x_thermal/int340x_thermal_zone.c | 5 +
drivers/thermal/intel/intel_pch_thermal.c | 5 +
.../thermal/intel/intel_quark_dts_thermal.c | 34 ++-----
drivers/thermal/intel/intel_soc_dts_iosf.c | 3 +
drivers/thermal/intel/x86_pkg_temp_thermal.c | 6 ++
drivers/thermal/kirkwood_thermal.c | 7 ++
drivers/thermal/rcar_thermal.c | 9 +-
drivers/thermal/rockchip_thermal.c | 6 +-
drivers/thermal/spear_thermal.c | 7 ++
drivers/thermal/sprd_thermal.c | 6 +-
drivers/thermal/st/st_thermal.c | 5 +
drivers/thermal/thermal_core.c | 76 ++++++++++++++--
drivers/thermal/thermal_of.c | 41 +--------
drivers/thermal/thermal_sysfs.c | 37 +-------
include/linux/thermal.h | 19 +++-
28 files changed, 275 insertions(+), 351 deletions(-)
base-commit: 9ebcfadb0610322ac537dd7aa5d9cbc2b2894c68
--
2.17.1
next reply other threads:[~2020-06-29 12:29 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-06-29 12:29 Andrzej Pietrasiewicz [this message]
2020-06-29 12:29 ` [PATCH v7 01/11] acpi: thermal: Fix error handling in the register function Andrzej Pietrasiewicz
2020-06-29 12:29 ` [PATCH v7 02/11] thermal: Store thermal mode in a dedicated enum Andrzej Pietrasiewicz
2020-06-29 12:29 ` [PATCH v7 03/11] thermal: Add current mode to thermal zone device Andrzej Pietrasiewicz
2020-06-29 12:29 ` [PATCH v7 04/11] thermal: Store device mode in struct thermal_zone_device Andrzej Pietrasiewicz
[not found] ` <20200629122925.21729-1-andrzej.p-ZGY8ohtN/8qB+jHODAdFcQ@public.gmane.org>
2020-06-29 12:29 ` [PATCH v7 05/11] thermal: remove get_mode() operation of drivers Andrzej Pietrasiewicz
2020-06-29 12:29 ` [PATCH v7 06/11] thermal: Add mode helpers Andrzej Pietrasiewicz
2020-06-29 12:29 ` [PATCH v7 07/11] thermal: Use mode helpers in drivers Andrzej Pietrasiewicz
2020-06-29 12:45 ` Amit Kucheria
2020-06-29 14:14 ` Bartlomiej Zolnierkiewicz
2020-06-29 12:29 ` [PATCH v7 08/11] thermal: Explicitly enable non-changing thermal zone devices Andrzej Pietrasiewicz
2020-06-29 14:15 ` Bartlomiej Zolnierkiewicz
2020-06-30 5:07 ` Amit Kucheria
2020-06-29 12:29 ` [PATCH v7 09/11] thermal: core: Stop polling DISABLED thermal devices Andrzej Pietrasiewicz
2020-06-29 12:46 ` Amit Kucheria
2020-06-29 12:29 ` [PATCH v7 10/11] thermal: Simplify or eliminate unnecessary set_mode() methods Andrzej Pietrasiewicz
2020-06-29 12:47 ` Amit Kucheria
2020-06-29 12:29 ` [PATCH v7 11/11] thermal: Rename set_mode() to change_mode() Andrzej Pietrasiewicz
2020-06-29 12:48 ` Amit Kucheria
2020-06-30 12:57 ` [PATCH v7 00/11] Stop monitoring disabled devices Daniel Lezcano
[not found] ` <aab40d90-3f72-657c-5e14-e53a34c4b420-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
2020-06-30 13:43 ` Andrzej Pietrasiewicz
[not found] ` <3d03d1a2-ac06-b69b-93cb-e0203be62c10-ZGY8ohtN/8qB+jHODAdFcQ@public.gmane.org>
2020-06-30 14:53 ` Daniel Lezcano
2020-06-30 15:29 ` Andrzej Pietrasiewicz
2020-06-30 15:53 ` Daniel Lezcano
2020-06-30 16:56 ` Andrzej Pietrasiewicz
2020-06-30 18:33 ` Daniel Lezcano
2020-07-01 10:23 ` Andrzej Pietrasiewicz
2020-07-01 14:25 ` Daniel Lezcano
2020-07-02 13:47 ` Daniel Lezcano
2020-07-02 13:53 ` Andrzej Pietrasiewicz
[not found] ` <5a28deb7-f307-8b03-faad-ab05cb8095d1-ZGY8ohtN/8qB+jHODAdFcQ@public.gmane.org>
2020-07-02 14:58 ` Daniel Lezcano
2020-07-02 17:01 ` Daniel Lezcano
2020-07-02 17:19 ` Andrzej Pietrasiewicz
2020-07-02 17:49 ` Daniel Lezcano
2020-07-02 17:52 ` Daniel Lezcano
2020-07-03 1:49 ` Zhang Rui
2020-07-03 6:38 ` Daniel Lezcano
2020-07-03 10:45 ` Andrzej Pietrasiewicz
2020-07-03 11:05 ` Daniel Lezcano
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200629122925.21729-1-andrzej.p@collabora.com \
--to=andrzej.p@collabora.com \
--cc=amit.kucheria@verdurent.com \
--cc=andy@infradead.org \
--cc=daniel.lezcano@linaro.org \
--cc=davem@davemloft.net \
--cc=dvhart@infradead.org \
--cc=emmanuel.grumbach@intel.com \
--cc=idosch@mellanox.com \
--cc=jiri@mellanox.com \
--cc=johannes.berg@intel.com \
--cc=kvalo@codeaurora.org \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-pm@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=linux-wireless@vger.kernel.org \
--cc=linuxwifi@intel.com \
--cc=luciano.coelho@intel.com \
--cc=miquel.raynal@bootlin.com \
--cc=netdev@vger.kernel.org \
--cc=peter@piie.net \
--cc=platform-driver-x86@vger.kernel.org \
--cc=rjw@rjwysocki.net \
--cc=sre@kernel.org \
--cc=support.opensource@diasemi.com \
--cc=vishal@chelsio.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox