From: Damon Ding <damon.ding@rock-chips.com>
To: Maxime Ripard <mripard@kernel.org>
Cc: andrzej.hajda@intel.com, neil.armstrong@linaro.org,
rfoss@kernel.org, Laurent.pinchart@ideasonboard.com,
jonas@kwiboo.se, jernej.skrabec@gmail.com,
maarten.lankhorst@linux.intel.com, tzimmermann@suse.de,
airlied@gmail.com, simona@ffwll.ch, jingoohan1@gmail.com,
inki.dae@samsung.com, sw0312.kim@samsung.com,
kyungmin.park@samsung.com, krzk@kernel.org,
alim.akhtar@samsung.com, hjc@rock-chips.com, heiko@sntech.de,
andy.yan@rock-chips.com, dmitry.baryshkov@oss.qualcomm.com,
l.stach@pengutronix.de, dianders@chromium.org,
dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-samsung-soc@vger.kernel.org,
linux-rockchip@lists.infradead.org
Subject: Re: [PATCH v3 04/14] drm/bridge: analogix_dp: Add &analogix_dp_plat_data.bridge
Date: Tue, 29 Jul 2025 16:31:27 +0800 [thread overview]
Message-ID: <7445b3d4-0e88-40e5-bcbd-8ea60c35d5bb@rock-chips.com> (raw)
In-Reply-To: <20250729-wooden-opalescent-baboon-f24fa2@houat>
Hi Maxime,
On 2025/7/29 15:30, Maxime Ripard wrote:
> Hi,
>
> On Thu, Jul 24, 2025 at 04:02:54PM +0800, Damon Ding wrote:
>> In order to move the parnel/bridge parsing and attachmenet to the
>> Analogix side, add component struct drm_bridge *bridge to platform
>> data struct analogix_dp_plat_data.
>>
>> The movemenet makes sense because the panel/bridge should logically
>> be positioned behind the Analogix bridge in the display pipeline.
>>
>> Signed-off-by: Damon Ding <damon.ding@rock-chips.com>
>> ---
>> include/drm/bridge/analogix_dp.h | 1 +
>> 1 file changed, 1 insertion(+)
>>
>> diff --git a/include/drm/bridge/analogix_dp.h b/include/drm/bridge/analogix_dp.h
>> index cf17646c1310..15cb6b706e9f 100644
>> --- a/include/drm/bridge/analogix_dp.h
>> +++ b/include/drm/bridge/analogix_dp.h
>> @@ -27,6 +27,7 @@ static inline bool is_rockchip(enum analogix_dp_devtype type)
>> struct analogix_dp_plat_data {
>> enum analogix_dp_devtype dev_type;
>> struct drm_panel *panel;
>> + struct drm_bridge *bridge;
>> struct drm_encoder *encoder;
>> struct drm_connector *connector;
>> bool skip_connector;
>
> So it's not the analogix_dp bridge, but the bridge after that if any?
>
> You should probably change it to next_bridge to avoid any confusion.
>
Yes, &analogix_dp_plat_data.bridge is intended to be the next bridge
after analogix_dp bridge.
I will rename it to &analogix_dp_plat_data.next_bridge as suggested and
update it in the next version.
Best regards,
Damon
_______________________________________________
Linux-rockchip mailing list
Linux-rockchip@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-rockchip
next prev parent reply other threads:[~2025-07-29 8:31 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-24 8:02 [PATCH v3 00/14] Apply drm_bridge_connector and panel_bridge helper for the Analogix DP driver Damon Ding
2025-07-24 8:02 ` [PATCH v3 01/14] drm/bridge: analogix_dp: Formalize the struct analogix_dp_device Damon Ding
2025-07-24 8:02 ` [PATCH v3 02/14] drm/bridge: analogix_dp: Move &drm_bridge_funcs.mode_set to &drm_bridge_funcs.atomic_enable Damon Ding
2025-07-24 8:02 ` [PATCH v3 03/14] drm/rockchip: analogix_dp: Apply drmm_encoder_init() instead of drm_simple_encoder_init() Damon Ding
2025-07-26 0:12 ` Dmitry Baryshkov
2025-07-29 3:22 ` Damon Ding
2025-07-24 8:02 ` [PATCH v3 04/14] drm/bridge: analogix_dp: Add &analogix_dp_plat_data.bridge Damon Ding
2025-07-26 0:15 ` Dmitry Baryshkov
2025-07-29 7:30 ` Maxime Ripard
2025-07-29 8:31 ` Damon Ding [this message]
2025-07-24 8:02 ` [PATCH v3 05/14] drm/exynos: exynos_dp: Remove &exynos_dp_device.ptn_bridge Damon Ding
2025-07-26 0:15 ` Dmitry Baryshkov
2025-07-24 8:02 ` [PATCH v3 06/14] drm/bridge: exynos_dp: Remove unused &exynos_dp_device.connector Damon Ding
2025-07-26 0:14 ` Dmitry Baryshkov
2025-07-24 8:02 ` [PATCH v3 07/14] drm/bridge: analogix_dp: Remove redundant &analogix_dp_plat_data.skip_connector Damon Ding
2025-07-26 0:14 ` Dmitry Baryshkov
2025-07-24 8:02 ` [PATCH v3 08/14] drm/bridge: analogix_dp: Apply drm_bridge_connector helper Damon Ding
2025-07-24 13:00 ` Heiko Stübner
2025-07-25 1:47 ` Damon Ding
2025-07-25 2:26 ` kernel test robot
2025-07-24 8:02 ` [PATCH v3 09/14] drm/bridge: analogix_dp: Add support to find panel or bridge Damon Ding
2025-07-26 12:03 ` Dmitry Baryshkov
2025-07-29 3:09 ` Damon Ding
2025-07-24 8:03 ` [PATCH v3 10/14] drm/rockchip: analogix_dp: Apply analogix_dp_find_panel_or_bridge() Damon Ding
2025-07-26 12:03 ` Dmitry Baryshkov
2025-07-24 8:03 ` [PATCH v3 11/14] drm/exynos: exynos_dp: " Damon Ding
2025-07-26 12:05 ` Dmitry Baryshkov
2025-07-24 8:03 ` [PATCH v3 12/14] drm/bridge: analogix_dp: Remove panel disabling and enabling in analogix_dp_set_bridge() Damon Ding
2025-07-24 8:03 ` [PATCH v3 13/14] drm/bridge: analogix_dp: Remove bridge disabing and panel unpreparing in analogix_dp_unbind() Damon Ding
2025-07-24 8:03 ` [PATCH v3 14/14] drm/bridge: analogix_dp: Apply panel_bridge helper Damon Ding
2025-07-24 13:08 ` Heiko Stübner
2025-07-25 1:57 ` Damon Ding
2025-07-24 13:10 ` [PATCH v3 00/14] Apply drm_bridge_connector and panel_bridge helper for the Analogix DP driver Heiko Stübner
2025-07-25 2:15 ` Damon Ding
2025-07-25 19:45 ` Heiko Stübner
2025-07-29 3:02 ` Damon Ding
2025-07-29 3:16 ` Damon Ding
2025-08-06 19:54 ` Heiko Stübner
2025-08-07 1:31 ` Damon Ding
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7445b3d4-0e88-40e5-bcbd-8ea60c35d5bb@rock-chips.com \
--to=damon.ding@rock-chips.com \
--cc=Laurent.pinchart@ideasonboard.com \
--cc=airlied@gmail.com \
--cc=alim.akhtar@samsung.com \
--cc=andrzej.hajda@intel.com \
--cc=andy.yan@rock-chips.com \
--cc=dianders@chromium.org \
--cc=dmitry.baryshkov@oss.qualcomm.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=heiko@sntech.de \
--cc=hjc@rock-chips.com \
--cc=inki.dae@samsung.com \
--cc=jernej.skrabec@gmail.com \
--cc=jingoohan1@gmail.com \
--cc=jonas@kwiboo.se \
--cc=krzk@kernel.org \
--cc=kyungmin.park@samsung.com \
--cc=l.stach@pengutronix.de \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=linux-samsung-soc@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=rfoss@kernel.org \
--cc=simona@ffwll.ch \
--cc=sw0312.kim@samsung.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox