Linux-Rockchip Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2026-07-02 11:11:59 to 2026-07-06 08:59:52 UTC [more...]

[PATCH 00/13] treewide: replace linux/gpio.h
 2026-07-06  8:59 UTC  (3+ messages)
` [PATCH 05/13] mfd: replace linux/gpio.h inclusions

[PATCH v8 00/39] Add HDMI 2.0 support to DW HDMI QP TX
 2026-07-06  8:33 UTC  (49+ messages)
` [PATCH v8 01/39] video/hdmi: Introduce HDMI version enum
` [PATCH v8 02/39] drm/connector: Add caps-based HDMI connector init helper
` [PATCH v8 03/39] drm/display: bridge_connector: Pass HDMI capabilities through caps struct
` [PATCH v8 04/39] drm/connector: Add HDMI 2.0 scrambler infrastructure
` [PATCH v8 05/39] drm/display: scdc-helper: Add macro for connector-prefixed debug messages
` [PATCH v8 06/39] drm/display: scdc-helper: Add helper to set SCDC version information
` [PATCH v8 07/39] drm/display: hdmi: Add HDMI 2.0 scrambling management helpers
` [PATCH v8 08/39] drm/display: hdmi: Advertise SCDC source version when scrambling
` [PATCH v8 09/39] drm/display: hdmi-state-helper: Add fallback TMDS rate validation
` [PATCH v8 10/39] drm/display: hdmi-state-helper: Sync SCDC state on hotplug
` [PATCH v8 11/39] drm/display: hdmi-state-helper: Set HDMI scrambling requirement
` [PATCH v8 12/39] drm/bridge: Remove redundant error check in drm_bridge_helper_reset_crtc()
` [PATCH v8 13/39] drm/bridge: Add bridge ops for source-side HDMI 2.0 scrambling
` [PATCH v8 14/39] drm/display: bridge_connector: Use cached connector status in .get_modes()
` [PATCH v8 15/39] drm/display: bridge_connector: Switch to .detect_ctx() connector helper
` [PATCH v8 16/39] drm/display: bridge_connector: Wire up HDMI 2.0 scrambler callbacks
` [PATCH v8 17/39] drm/bridge: dw-hdmi-qp: Rate limit i2c read error messages
` [PATCH v8 18/39] drm/bridge: dw-hdmi-qp: Provide .{enable|disable}_hpd() PHY ops
` [PATCH v8 19/39] drm/bridge: dw-hdmi-qp: Add HDMI 2.0 SCDC scrambling support
` [PATCH v8 20/39] drm/bridge: dw-hdmi-qp: Provide dw_hdmi_qp_hpd_notify() helper
` [PATCH v8 21/39] drm/rockchip: dw_hdmi_qp: Add missing newlines in dev_err_probe() messages
` [PATCH v8 22/39] drm/rockchip: dw_hdmi_qp: Use local dev variable consistently in bind()
` [PATCH v8 23/39] drm/rockchip: dw_hdmi_qp: Drop unnecessary #include
` [PATCH v8 24/39] drm/rockchip: dw_hdmi_qp: Defer HPD IRQ enable until after connector setup
` [PATCH v8 25/39] drm/rockchip: dw_hdmi_qp: Mask RK3576 HPD IRQ in io_init
` [PATCH v8 26/39] drm/rockchip: dw_hdmi_qp: Implement .{enable|disable}_hpd() PHY ops
` [PATCH v8 27/39] drm/rockchip: dw_hdmi_qp: Use dw_hdmi_qp_hpd_notify() for HPD reports
` [PATCH v8 28/39] drm/bridge: dw-hdmi-qp: Drop unused .setup_hpd() phy op
` [PATCH v8 29/39] drm/vc4: hdmi: Use common TMDS char rate constants
` [PATCH v8 30/39] drm/vc4: hdmi: Switch to drm_hdmi_mode_needs_scrambling()
` [PATCH v8 31/39] drm/vc4: hdmi: Convert to common SCDC scrambling infrastructure
` [PATCH v8 32/39] drm/tests: connector: Add HDMI caps-based init coverage
` [PATCH v8 33/39] drm/tests: connector: Add HDMI source-side scrambler coverage
` [PATCH v8 34/39] drm/tests: hdmi_state_helper: Use drmm_connector_hdmi_init_with_caps()
` [PATCH v8 35/39] drm/tests: hdmi_state_helper: Add max_tmds_char_rate fallback tests
` [PATCH v8 36/39] drm/tests: edid: Add 4K@60Hz EDID with 600MHz TMDS
` [PATCH v8 37/39] drm/tests: hdmi_state_helper: Cover source-side scrambling decision
` [PATCH v8 38/39] drm/tests: edid: Fix conformity for 1080p+4K YUV420 200MHz EDID
` [PATCH v8 39/39] drm/tests: edid: Fix conformity for 4K RGB/YUV 340MHz EDID

[PATCH v1 0/5] pwm: Unify arrays of various *_device_id
 2026-07-06  8:28 UTC  (6+ messages)
` [PATCH v1 4/5] pwm: Unify coding style of of_device_id arrays

[PATCH 0/9] Support 10-bit YUV422 and 8/10-bit YUV420 color format on DW HDMI QP
 2026-07-05 22:20 UTC  (9+ messages)
` [PATCH 2/9] drm/rockchip: vop2: Reset AXI and DCLK to improve robustness
` [PATCH 1/9] dt-bindings: display: vop2: Add missing reset properties

[PATCH] arm64: dts: rockchip: add HYM8563 RTC to Radxa CM5 IO board
 2026-07-05 18:19 UTC  (3+ messages)
  ` [PATCH v2] "

[PATCH 0/3] drm: remove unneeded 'fast_io' parameter in regmap_config
 2026-07-05 16:35 UTC  (2+ messages)
` [PATCH 3/3] drm/rockchip: "

[PATCH 1/2] dt-bindings: arm: rockchip: Add EmbedFire LubanCat 4 board
 2026-07-05 15:11 UTC  (5+ messages)
` [PATCH 2/2] arm64: dts: "

[PATCH 0/2] Add support for EmbedFire LubanCat 4 board
 2026-07-05 13:50 UTC 

[PATCH] crypto: rockchip: fail ahash requests on HASH idle timeout
 2026-07-05  8:41 UTC  (2+ messages)

[PATCH] arm64: dts: rockchip: fan speed control for FriendlyELEC CM3588 NAS
 2026-07-04 12:46 UTC 

[PATCH 00/12] arm64: dts: rockchip: Add NanoPi M6 board
 2026-07-04  9:54 UTC  (20+ messages)
` [PATCH 01/12] dt-bindings: arm: rockchip: add FriendlyElec NanoPi M6
` [PATCH 02/12] arm64: dts: rockchip: refactor rk3588s-nanopi* to support M6
` [PATCH 03/12] arm64: dts: rockchip: move NanoPi R6 code into common dtsi
` [PATCH 04/12] arm64: dts: rockchip: rk3588s-nanopi: add missing sdmmc cd pinctrl
` [PATCH 05/12] arm64: dts: rockchip: rk3588s-nanopi: remove pull up on rtc int pin
` [PATCH 06/12] arm64: dts: rockchip: rk3588s-nanopi: add missing pcie rst pinctrl
` [PATCH 07/12] arm64: dts: rockchip: rk3588s-nanopi: pcie2x1l2: add clkreq
` [PATCH 08/12] arm64: dts: rockchip: rk3588s-nanopi: remove always-on from vdd_npu_s0 reg
` [PATCH 09/12] arm64: dts: rockchip: rk3588s-nanopi: remove useless vcc_3v3_pcie20
` [PATCH 10/12] arm64: dts: rockchip: rk3588s-nanopi: add gmac1 add phy-supply
` [PATCH 11/12] arm64: dts: rockchip: rk3588s-nanopi: remove bogus vcc5v0_usb regulator
` [PATCH 12/12] arm64: dts: rockchip: add support for NanoPi M6 board

[PATCH v5] drm/rockchip: Remove dependency on DRM simple helpers
 2026-07-04  9:12 UTC 

[PATCH v2] media: rockchip: rga: quiesce IRQ before releasing m2m state
 2026-07-04  8:46 UTC 

[PATCH v3] drm/rockchip: Remove dependency on DRM simple helpers
 2026-07-04  8:45 UTC  (5+ messages)
` [PATCH RESEND "
  ` [PATCH v4] "

[PATCH] media: rockchip: rga: quiesce IRQ before releasing m2m state
 2026-07-04  2:28 UTC 

[PATCH v10 00/36] phy: rockchip: usbdp: Clean up the mess
 2026-07-03 18:13 UTC  (37+ messages)
` [PATCH v10 01/36] dt-bindings: phy: rockchip-usbdp: add improved ports scheme
` [PATCH v10 02/36] phy: rockchip: usbdp: Update mode_change after error handling
` [PATCH v10 03/36] phy: rockchip: usbdp: Do not lose USB3 PHY status
` [PATCH v10 04/36] phy: rockchip: usbdp: Fix devm_clk_bulk_get_all check
` [PATCH v10 05/36] phy: rockchip: usbdp: Handle missing clock-names DT property gracefully
` [PATCH v10 06/36] phy: rockchip: usbdp: Drop seamless DP takeover
` [PATCH v10 07/36] phy: rockchip: usbdp: Keep clocks running on PHY re-init
` [PATCH v10 08/36] phy: rockchip: usbdp: Amend SSC modulation deviation
` [PATCH v10 09/36] phy: rockchip: usbdp: Fix LFPS detect threshold control
` [PATCH v10 10/36] phy: rockchip: usbdp: Add missing mode_change update
` [PATCH v10 11/36] phy: rockchip: usbdp: Support single-lane DP
` [PATCH v10 12/36] phy: rockchip: usbdp: Limit DP lane count to muxed lanes
` [PATCH v10 13/36] phy: rockchip: usbdp: Rename DP lane functions
` [PATCH v10 14/36] phy: rockchip: usbdp: Use FIELD_PREP_WM16_CONST
` [PATCH v10 15/36] phy: rockchip: usbdp: Cleanup DP lane selection function
` [PATCH v10 16/36] phy: rockchip: usbdp: Register DP aux bridge
` [PATCH v10 17/36] phy: rockchip: usbdp: Drop DP HPD handling
` [PATCH v10 18/36] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit
` [PATCH v10 19/36] phy: rockchip: usbdp: Re-init the PHY on orientation change
` [PATCH v10 20/36] phy: rockchip: usbdp: Factor out lane_mux_sel setup
` [PATCH v10 21/36] phy: rockchip: usbdp: Properly handle TYPEC_STATE_SAFE and TYPEC_STATE_USB
` [PATCH v10 22/36] phy: rockchip: usbdp: Use guard functions for mutex
` [PATCH v10 23/36] phy: rockchip: usbdp: Clear USB status on PHY exit
` [PATCH v10 24/36] phy: rockchip: usbdp: Hold mutex in DP PHY configure
` [PATCH v10 25/36] phy: rockchip: usbdp: Add some extra debug messages
` [PATCH v10 26/36] phy: rockchip: usbdp: Avoid xHCI SErrors
` [PATCH v10 27/36] phy: rockchip: usbdp: Handle rk_udphy_reset_deassert errors
` [PATCH v10 28/36] phy: rockchip: usbdp: Only enable USB3 when not in high-speed mode
` [PATCH v10 29/36] phy: core: add notifier infrastructure
` [PATCH v10 30/36] usb: dwc3: core: support PHY reset notifications
` [PATCH v10 31/36] phy: rockchip: usbdp: Add phy reset notification support
` [PATCH v10 32/36] phy: rockchip: usbdp: Drop -EPROBE_DEFER hack
` [PATCH v10 33/36] phy: rockchip: usbdp: Rename mode to hw_mode
` [PATCH v10 34/36] phy: rockchip: usbdp: Simplify power state handling
` [PATCH v10 35/36] phy: rockchip: usbdp: Re-init PHY on mux change
` [PATCH v10 36/36] phy: rockchip: usbdp: Add USB-C state without DP enabled

[PATCH] Revert "arm64: dts: rockchip: Further describe the WiFi for the Pinephone Pro"
 2026-07-03 20:10 UTC  (3+ messages)
` [PATCH v2] "

[PATCH v2] MAINTAINERS: Track dw-hdmi-qp under Rockchip DRM drivers
 2026-07-03 18:33 UTC  (2+ messages)

Fwd: Re: [PATCH 12/12] arm64: dts: rockchip: add support for NanoPi M6 board
 2026-07-03 17:42 UTC 

[PATCH v4 1/4] dt-bindings: can: rockchip: add rk3588 CAN-FD compatible
 2026-07-03 14:53 UTC  (8+ messages)
` [PATCH v4 2/4] can: rockchip: add RK3588 CAN support
` [PATCH v4 3/4] arm64: dts: rockchip: add CAN-FD nodes for RK3588
` [PATCH v4 4/4] arm64: dts: rockchip: Enable CAN controller on RK3588-Tiger-Haikou

[PATCH net-next v11 0/7] net: stmmac: qcom-ethqos: add support for SCMI power domains
 2026-07-03 10:21 UTC  (12+ messages)
` [PATCH net-next v11 1/7] dt-bindings: phy: document the serdes PHY on sa8255p

[PATCH] arm: dts: rk3288-tinker: add eeprom node
 2026-07-03  8:44 UTC 

[PATCH v4 0/4] can: rockchip: add RK3588 CAN support
 2026-07-03  8:01 UTC 

[GIT PULL] Split <linux/mod_devicetable.h> in per subsystem headers
 2026-07-03  7:37 UTC  (2+ messages)

[PATCH v3 1/4] dt-bindings: can: rockchip: add rk3588 CAN-FD compatible
 2026-07-03  6:49 UTC  (6+ messages)
` [PATCH v3 2/4] can: rockchip: add RK3588 CAN support
` [PATCH v3 3/4] arm64: dts: rockchip: add CAN-FD nodes for RK3588
` [PATCH v3 4/4] arm64: dts: rockchip: Enable CAN controller on RK3588-Tiger-Haikou

[PATCH 2/3] can: rockchip: add RK3588 CAN-FD support
 2026-07-03  5:41 UTC  (2+ messages)

[PATCH] arm64: dts: rockchip: Fix rk3588s-roc-pc audio description
 2026-07-03  2:56 UTC 

[PATCH v3 0/4] can: rockchip: add RK3588 CAN support
 2026-07-03  2:35 UTC 

[PATCH v5 0/3] Add devicetree for the Graperain G3568 v2
 2026-07-02 21:08 UTC  (5+ messages)
` [PATCH v5 1/3] dt-bindings: vendor-prefixes: Add graperain
` [PATCH v5 2/3] dt-bindings: arm: rockchip: Add Graperain G3568 series
` [PATCH v5 3/3] arm64: dts: rockchip: Add devicetree for the Graperain G3568 v2

[PATCH] rockchip: arm64: dts: rockchip: Fix incorrect interrupt for the 9Tripod X3568 v4
 2026-07-02 20:24 UTC 

[PATCH v4 0/3] Add devicetree for the Graperain G3568 v2
 2026-07-02 19:35 UTC  (4+ messages)
` [PATCH v4 1/3] dt-bindings: vendor-prefixes: Add graperain
` [PATCH v4 2/3] dt-bindings: arm: rockchip: Add Graperain G3568 series
` [PATCH v4 3/3] arm64: dts: rockchip: Add devicetree for the Graperain G3568 v2

[PATCH 0/3] arm64: dts: rockchip: Add Youyeetoo YY3588
 2026-07-02 19:04 UTC  (2+ messages)

[PATCH v11 0/3] Add eDP support for RK3576
 2026-07-02 19:04 UTC  (2+ messages)

[PATCH v2 0/2] arm64: dts: rockchip: Add HINLINK H28K
 2026-07-02 19:04 UTC  (2+ messages)

[PATCH] arm64: dts: rockchip: fix regulator names on NanoPC-T6
 2026-07-02 19:04 UTC  (2+ messages)

[PATCH] arm64: dts: rockchip: fix eMMC reset polarity on PX30 Ringneck
 2026-07-02 19:04 UTC  (2+ messages)

[PATCH v7 0/2] arm64: dts: rockchip: add Vicharak Axon board support
 2026-07-02 19:04 UTC  (2+ messages)

[PATCH v2 0/2] arm64: dts: rockchip: Add Vicharak Vaaman2 board support
 2026-07-02 19:04 UTC  (2+ messages)

[PATCH 1/2] arm64: dts: rockchip: Add AP6275S support for 9Tripod X3568 v4
 2026-07-02 19:04 UTC  (2+ messages)

[PATCH v2 0/2] rockchip: Fix devices suspend freeze on RK3568/RK3566
 2026-07-02 18:00 UTC  (2+ messages)

[PATCH] media: rkvdec: Propagate platform_get_irq() errors
 2026-07-02 17:57 UTC  (2+ messages)

[PATCH v2 1/4] dt-bindings: can: rockchip: add rk3588 CAN-FD compatible
 2026-07-02 16:42 UTC  (13+ messages)
` [PATCH v2 2/4] can: rockchip: add RK3588 CAN support
` [PATCH v2 3/4] arm64: dts: rockchip: add CAN-FD nodes for RK3588
` [PATCH v2 4/4] arm64: dts: rockchip: Enable CAN controller on RK3588-Tiger-Haikou

[PATCH v2 0/4] can: rockchip: add RK3588 CAN support
 2026-07-02 14:06 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox