From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-pf0-f180.google.com ([209.85.192.180]:32806 "EHLO mail-pf0-f180.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932306AbdGSVXd (ORCPT ); Wed, 19 Jul 2017 17:23:33 -0400 Received: by mail-pf0-f180.google.com with SMTP id s70so4537191pfs.0 for ; Wed, 19 Jul 2017 14:23:33 -0700 (PDT) Subject: Re: [PATCH v2 3/4] PM: Print wall time at suspend & hibernate entry and exit To: "Rafael J. Wysocki" Cc: Linux Kernel Mailing List , "Rafael J. Wysocki" , Len Brown , Pavel Machek , Linux PM , Alessandro Zummo , Alexandre Belloni , linux-rtc@vger.kernel.org References: <20170719194600.29210-1-salyzyn@android.com> From: Mark Salyzyn Message-ID: <507dec5d-3beb-4dd8-0d5f-90f22fccccd2@android.com> Date: Wed, 19 Jul 2017 14:23:31 -0700 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8; format=flowed Sender: linux-rtc-owner@vger.kernel.org List-ID: On 07/19/2017 01:40 PM, Rafael J. Wysocki wrote: > On Wed, Jul 19, 2017 at 9:45 PM, Mark Salyzyn wrote: >> Permits power state and battery life diagnosis. >> >> Since one is not guaranteed to have a persistent hardware clock to >> report Suspended for in milliseconds, we report at a higher level >> at just the entry and exit points for suspend and hibernate. >> >> Feature activated by CONFIG_RTC_SHOW_TIME_* >> >> Signed-off-by: Mark Salyzyn >> >> v2: >> - merge suspend and hibernate into a single patch > So now I guess you realize that this conflicts with > https://patchwork.kernel.org/patch/9850217/ and it actually would make > sense for it to go on top of that? > > Thanks, > Rafael I see. It would make sense to merge the concepts a bit since the prints are at the same locations. Optimization idea: rtc_show_time() in my patch series should be able to support varargs, never be _disabled_ (CONFIG_RTC_SHOW_TIME_NONE idea is dropped) and the function would be a drop-in replacement for pr_info, but add the specified timestamp before the newline. Change it's name to pr_info_show_time() instead to reflect this adjustment. I would also prefer that the base messages in patch/980217 be "PM: suspend entry" and "PM: suspend exit", only because I believe 1.6billion Linux devices would not need to be retooled, and besides these messages are shorter/sweeter. Anyone disagree with some more over-engineering (pr_info_show_time() and varargs) -- Mark