Linux s390 Architecture development
 help / color / mirror / Atom feed
[PATCH v4 00/27] KVM: s390: Introduce arm64 KVM
 2026-07-10  8:54 UTC  (4+ messages)
` [PATCH v4 05/27] KVM: Remove KVM_MMIO as config option

[PATCH 0/2] s390: Remove PIF_GUEST_FAULT and add PER trap flag
 2026-07-10  8:40 UTC  (5+ messages)
` [PATCH 1/2] s390/traps: Remove PIF_GUEST_FAULT
` [PATCH 2/2] s390/syscalls: Use define instead of '1' to indicate PER trap

[PATCH v5 0/8] futex: Use runtime constants for futex_hash computation
 2026-07-10  8:17 UTC  (12+ messages)
` [PATCH v5 2/8] arm64/runtime-const: Use aarch64_insn_patch_text_nosync() for patching
` [PATCH v5 3/8] arm64/runtime-const: Introduce runtime_const_mask_32()
` [PATCH v5 5/8] riscv/runtime-const: "
` [PATCH v5 7/8] asm-generic/runtime-const: Add dummy runtime_const_mask_32()
` [PATCH v5 8/8] futex: Use runtime constants for __futex_hash() hot path

[PATCH 0/2] s390/vdso: Fix GNU_EH_FRAME PHDR
 2026-07-10  7:46 UTC  (2+ messages)

[PATCH v7 00/22] dma-mapping: Track shared DMA state through direct, pool and swiotlb paths
 2026-07-10  5:22 UTC  (7+ messages)
` [PATCH v7 16/22] dma-direct: make dma_direct_map_phys() honor DMA_ATTR_CC_SHARED

[PATCH rdma-next 00/13] RDMA: Make device names unique per net namespace
 2026-07-10  4:24 UTC  (17+ messages)
` [PATCH rdma-next 01/13] RDMA/core: Pass the net namespace to the device name lookups
` [PATCH rdma-next 02/13] RDMA/core: Handle device name conflicts when changing net namespace
` [PATCH rdma-next 03/13] RDMA/core: Support renaming a device when changing its "
` [PATCH rdma-next 04/13] RDMA/nldev: Report net namespace move errors through extack
` [PATCH rdma-next 05/13] RDMA/nldev: Allow setting the device name while changing net namespace
` [PATCH rdma-next 06/13] net/smc: Look up the pnetid ib device within the "
` [PATCH rdma-next 07/13] RDMA/srp: Make the SRP sysfs class net namespace aware
` [PATCH rdma-next 08/13] RDMA/cgroup: Scope rdma cgroup device visibility to the net namespace
` [PATCH rdma-next 09/13] RDMA/cma: Document that CM configfs cannot be net namespace scoped
` [PATCH rdma-next 10/13] RDMA/core: Document the SELinux ibendport net namespace limitation
` [PATCH rdma-next 11/13] RDMA/core: Make device names unique per net namespace
` [PATCH rdma-next 12/13] RDMA/rxe: Implement disassociate_ucontext callback
` [PATCH rdma-next 13/13] RDMA/selftests: Add rxe_netns_names test

[PATCH net-next v3 0/3] net/smc: transition to RDMA core CQ pooling
 2026-07-10  3:33 UTC  (4+ messages)
` [PATCH net-next v3 1/3] net/smc: clear the correct v2 slot and buffer in smc_wr_tx_put_slot()
` [PATCH net-next v3 2/3] net/smc: transition to RDMA core CQ pooling
` [PATCH net-next v3 3/3] net/smc: reduce TX slot contention with exclusive wait

[patch 00/18] entry: Consolidate and rework syscall entry handling
 2026-07-09 20:16 UTC  (82+ messages)
` [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
` [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
` [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
` [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
` [patch 05/18] powerpc/syscall: "
` [patch 06/18] riscv/syscall: "
` [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
` [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
` [patch 09/18] entry: Remove syscall_enter_from_user_mode()
` [patch 10/18] entry: Use syscall number instead of rereading it
` [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
` [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
` [patch 13/18] entry: Make trace_syscall_enter() return type bool
` [patch 14/18] entry: Make return type of syscall_trace_enter() bool
` [patch 15/18] x86/entry: Make syscall functions static
` [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
` [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution

[PATCH v3 00/11] dma-buf: heaps: Add support for Tegra VPR
 2026-07-09 19:58 UTC  (22+ messages)
` [PATCH v3 01/11] dt-bindings: reserved-memory: Document "
` [PATCH v3 04/11] arm64/mm: Add set_memory_device() and set_memory_normal()
` [PATCH v3 06/11] mm/cma: Allow dynamically creating CMA areas

[PATCH net] net/af_iucv: fix NULL deref in afiucv_hs_callback_syn()
 2026-07-09 19:17 UTC 

[PATCH net] net/iucv: take a reference on the socket found in afiucv_hs_rcv()
 2026-07-09 17:17 UTC  (5+ messages)

[PATCH 00/21] KVM: s390: vsie: Add VSIE SIGP Interpretation (vsie_sigpi)
 2026-07-09 15:47 UTC  (37+ messages)
` [PATCH 01/21] KVM: s390: Remove double 64bscao feature check
` [PATCH 02/21] KVM: s390: vsie: Remove duplicate assertion
` [PATCH 03/21] KVM: s390: vsie: Convert shift to phys_to_pfn()
` [PATCH 04/21] KVM: s390: vsie: Add SCAO read and write helpers
` [PATCH 05/21] KVM: s390: vsie: Move SCAO validation into a function
` [PATCH 06/21] KVM: s390: vsie: Add vsie_sigpif detection
` [PATCH 07/21] KVM: s390: vsie: Add ssca_block and ssca_entry structs for vsie_ie
` [PATCH 08/21] KVM: s390: vsie: Move pin/unpin_scb methods
` [PATCH 09/21] KVM: s390: vsie: Move pin/unpin guest page
` [PATCH 10/21] KVM: s390: vsie: Move release/acquire gmap shadow
` [PATCH 11/21] KVM: s390: vsie: Create helpers to alloc and free vsie_pages
` [PATCH 12/21] KVM: s390: vsie: Replace radix_tree with xarray addr_to_page
` [PATCH 13/21] KVM: s390: vsie: Add helper to pin multiple guest pages
` [PATCH 14/21] KVM: s390: vsie: Add helper to release gmap shadow
` [PATCH 15/21] KVM: s390: vsie: Add struct vsie_sca with pin and unpin
` [PATCH 16/21] KVM: s390: vsie: Shadow VSIE SCA in guest-1
` [PATCH 17/21] KVM: s390: vsie: Allow guest-3 cpu add and remove with vsie sigpif
` [PATCH 18/21] KVM: s390: vsie: Add VSIE max shadow configuration
` [PATCH 19/21] KVM: s390: vsie: Add VSIE shadow stat counters
` [PATCH 20/21] KVM: s390: vsie: Create minimal scb shadows for not running g3 blocks
` [PATCH 21/21] KVM: s390: vsie: Enable VSIE SIGPI

[PATCH] KVM: s390: pci: Fix handling of AIF enable without AISB
 2026-07-09 14:23 UTC  (3+ messages)

[PATCH] s390/checksum: Fix csum_partial() without vector facility
 2026-07-09 10:49 UTC  (3+ messages)

[PATCH] s390/uapi: Remove obsolete unistd_32.h from Kbuild file
 2026-07-09 10:42 UTC  (6+ messages)

[PATCH v3 0/1] Improve zcrypt reply message verification checks
 2026-07-09  9:37 UTC  (3+ messages)
` [PATCH v3 1/1] s390/zcrypt: "

[PATCH 00/10] mm: remove CONFIG_HAVE_BOOTMEM_INFO_NODE (Part 2)
 2026-07-09  9:36 UTC  (27+ messages)
` [PATCH 01/10] x86/mm: drop order parameter from free_pagetable()
` [PATCH 02/10] mm: provide free_reserved_pages(), removing x86 variant
` [PATCH 03/10] s390/mm: use free_reserved_pages() in vmem_free_pages()
` [PATCH 04/10] mm/bootmem_info: allow calling free_bootmem_page() on pages without a bootmem_type
` [PATCH 05/10] x86/mm: stop marking vmemmap as SECTION_INFO
` [PATCH 06/10] x86/mm: stop marking page tables as MIX_SECTION_INFO
` [PATCH 07/10] x86/mm: remove CONFIG_HAVE_BOOTMEM_INFO_NODE
` [PATCH 08/10] mm/hugetlb_vmemmap: remove bootmem_info leftovers
` [PATCH 09/10] mm/sparse: remove bootmem_info.h include
` [PATCH 10/10] mm/bootmem_info: remove CONFIG_HAVE_BOOTMEM_INFO_NODE

[PATCH v11 00/21] target/s390x: Extend qemu CPACF support
 2026-07-09  9:28 UTC  (6+ messages)
` [PATCH v11 18/21] crypto: Add aes-helpers file to support some AES modes
` [PATCH v11 19/21] target/s390x: Use generic AES helper functions

[PATCH v3] perf test: perftool-testsuite-report fails on s390
 2026-07-09  9:14 UTC  (2+ messages)

[PATCH v16 00/18] arm64: entry: Convert to Generic Entry
 2026-07-09  8:27 UTC  (10+ messages)
` [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
` [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel

[PATCH v1 0/8] KVM: s390: Misc fixes
 2026-07-09  8:17 UTC  (4+ messages)
` [PATCH v1 4/8] KVM: s390: Fix return value of kvm_s390_set_cmma_bits()

[PATCH] syscall_user_dispatch: Introduce ARCH_SUPPORTS_SYSCALL_USER_DISPATCH
 2026-07-09  7:59 UTC  (4+ messages)

[PATCH v2] perf test: perftool-testsuite-report fails on s390
 2026-07-09  7:42 UTC  (2+ messages)

[PATCH v4 0/1] Use mutex_lock_killable() in ap_bus_force_rescan()
 2026-07-09  7:25 UTC  (2+ messages)
` [PATCH v4 1/1] s390/ap: "

[PATCH] perf test: perftool-testsuite-report fails on s390
 2026-07-09  6:36 UTC  (2+ messages)

[PATCH v10 00/21] target/s390x: Extend qemu CPACF support
 2026-07-08 17:10 UTC  (8+ messages)
` [PATCH v10 10/21] target/s390x: Base support for cpacf protected keys


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox