From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Message-ID: Date: Wed, 13 Aug 2008 07:50:14 -0700 From: "Tim Hockin" Subject: Re: [patch 1/3] kmsg: Kernel message catalog macros. In-Reply-To: <20080813071323.GA6298@elf.ucw.cz> MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Content-Disposition: inline References: <20080730165656.118280544@de.ibm.com> <20080730171156.824640459@de.ibm.com> <200808131433.02966.rusty@rustcorp.com.au> <20080813071323.GA6298@elf.ucw.cz> Sender: linux-kernel-owner@vger.kernel.org List-Archive: List-Post: To: Pavel Machek Cc: Rusty Russell , Martin Schwidefsky , linux-kernel@vger.kernel.org, linux-s390@vger.kernel.org, lf_kernel_messages@lists.linux-foundation.org, Andrew Morton , Michael Holzheu , Gerrit Huizenga , Greg Kroah-Hartman , Randy Dunlap , Jan Kara , Sam Ravnborg , Joe Perches , =?UTF-8?Q?Jochen_Vo=C3=9F?= , Kunai Takashi , Tim Bird List-ID: On Wed, Aug 13, 2008 at 12:13 AM, Pavel Machek wrote: > Hi! > >> But there are a number of places that have different strings for the >> same meaning: "Can't" vs "can't" vs "can not" vs "failed to", etc. > > Do you have examples? > > That wastes space in bzImage (and hints of duplicated code), so we may > want to fix it anyway. I can look for the specific examples. I just saw the regexes we use this week and was taken aback at how they have been loosened for these sorts of cases.