From: "Tamseel Shams" <m.shams@samsung.com>
To: "'Krzysztof Kozlowski'" <krzysztof.kozlowski@linaro.org>,
<alim.akhtar@samsung.com>, <krzysztof.kozlowski+dt@linaro.org>,
<gregkh@linuxfoundation.org>, <jirislaby@kernel.org>
Cc: <linux-arm-kernel@lists.infradead.org>,
<linux-samsung-soc@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <linux-serial@vger.kernel.org>
Subject: RE: [PATCH v2] serial: samsung: honor fifosize from dts at first
Date: Tue, 6 Feb 2024 17:03:56 +0530 [thread overview]
Message-ID: <006b01da58f0$601316b0$20394410$@samsung.com> (raw)
In-Reply-To: <0a2604e7-8b30-4cf9-9099-ba3681bc5538@linaro.org>
Hi Krzysztof,
> -----Original Message-----
> From: Krzysztof Kozlowski [mailto:krzysztof.kozlowski@linaro.org]
> Sent: 06 February 2024 15:42
> To: Tamseel Shams <m.shams@samsung.com>; alim.akhtar@samsung.com;
> krzysztof.kozlowski+dt@linaro.org; gregkh@linuxfoundation.org;
> jirislaby@kernel.org
> Cc: linux-arm-kernel@lists.infradead.org; linux-samsung-
> soc@vger.kernel.org; linux-kernel@vger.kernel.org; linux-
> serial@vger.kernel.org
> Subject: Re: [PATCH v2] serial: samsung: honor fifosize from dts at first
>
> On 05/02/2024 09:24, Tamseel Shams wrote:
> > Currently for platforms which passes UART fifosize from DT gets
> > override by local driver structure "s3c24xx_serial_drv_data", which is
> > not intended. Change the code to honor fifosize from device tree at
> > first.
> >
> > Signed-off-by: Tamseel Shams <m.shams@samsung.com>
> > ---
> > Change Log:
> > v1 -> v2:
> > Acknowledged Krzysztof's comments
> > Initialized "ret" variable
> >
> > drivers/tty/serial/samsung_tty.c | 16 +++++++++-------
> > 1 file changed, 9 insertions(+), 7 deletions(-)
> >
> > diff --git a/drivers/tty/serial/samsung_tty.c
> > b/drivers/tty/serial/samsung_tty.c
> > index 71d17d804fda..e5dc2c32b1bd 100644
> > --- a/drivers/tty/serial/samsung_tty.c
> > +++ b/drivers/tty/serial/samsung_tty.c
> > @@ -1952,7 +1952,7 @@ static int s3c24xx_serial_probe(struct
> platform_device *pdev)
> > struct device_node *np = pdev->dev.of_node;
> > struct s3c24xx_uart_port *ourport;
> > int index = probe_index;
> > - int ret, prop = 0;
> > + int ret = 1, prop = 0;
>
> I am sorry, but return of probe function cannot be positive.
>
Thanks for the review.
I am reusing the "ret" variable to check whether fifosize property
is present in DT or not. It will be overwritten at later stage in probe
function before returning. Also, "ret" variable is used to return from
probe function only in case of failure i.e. "ret" is negative.
Currently, probe function always returns 0 in case of success.
For better readability, I am thinking of introducing a new variable for
checking the return value from function "of_property_read_u32" while
getting "samsung,uart-fifosize" property.
What are your thoughts on that?
> >
> > if (np) {
> > ret = of_alias_get_id(np, "serial"); @@ -1990,8 +1990,7 @@
> static
> > int s3c24xx_serial_probe(struct platform_device *pdev)
> > }
> >
> > if (np) {
> > - of_property_read_u32(np,
> > - "samsung,uart-fifosize", &ourport->port.fifosize);
> > + ret = of_property_read_u32(np, "samsung,uart-fifosize",
> > +&ourport->port.fifosize);
> >
> > if (of_property_read_u32(np, "reg-io-width", &prop) == 0) {
> > switch (prop) {
> > @@ -2009,10 +2008,13 @@ static int s3c24xx_serial_probe(struct
> platform_device *pdev)
> > }
> > }
> >
> > - if (ourport->drv_data->fifosize[index])
> > - ourport->port.fifosize = ourport->drv_data->fifosize[index];
> > - else if (ourport->info->fifosize)
> > - ourport->port.fifosize = ourport->info->fifosize;
> > + if (ret) {
>
> Are you sure that you are checking correct ret?
Explanation same as above.
Thanks & Regards,
Tamseel Shams
prev parent reply other threads:[~2024-02-07 2:31 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <CGME20240205082441epcas5p1e904f4f95852de3fd8663742ed5131df@epcas5p1.samsung.com>
2024-02-05 8:24 ` [PATCH v2] serial: samsung: honor fifosize from dts at first Tamseel Shams
2024-02-06 10:12 ` Krzysztof Kozlowski
2024-02-06 11:33 ` Tamseel Shams [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='006b01da58f0$601316b0$20394410$@samsung.com' \
--to=m.shams@samsung.com \
--cc=alim.akhtar@samsung.com \
--cc=gregkh@linuxfoundation.org \
--cc=jirislaby@kernel.org \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=krzysztof.kozlowski@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-samsung-soc@vger.kernel.org \
--cc=linux-serial@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox