Linux SCSI subsystem development
 help / color / mirror / Atom feed
From: Zorro Lang <zlang@kernel.org>
To: Christoph Hellwig <hch@lst.de>
Cc: fstests@vger.kernel.org,
	 "Martin K. Petersen" <martin.petersen@oracle.com>,
	Kanchan Joshi <joshi.k@samsung.com>,
	 Anuj Gupta <anuj20.g@samsung.com>,
	linux-scsi@vger.kernel.org
Subject: Re: [PATCH 1/4] common/scsi_debug: don't slow down I/O
Date: Sun, 2 Aug 2026 18:35:57 +0800	[thread overview]
Message-ID: <am8Yg5NMbLuIOfBd@zlang-mailbox> (raw)
In-Reply-To: <20260723142856.108193-2-hch@lst.de>

On Thu, Jul 23, 2026 at 04:28:44PM +0200, Christoph Hellwig wrote:
> scsi_debug by defaults delays I/O and doesn't support multi-page I/O.
> Flipping these defaults speed up each test using scsi_debug by more than
> an order of magnitute on my test systems.
> 
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  common/scsi_debug | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/common/scsi_debug b/common/scsi_debug
> index c3fe7be623fa..91665547bc0c 100644
> --- a/common/scsi_debug
> +++ b/common/scsi_debug
> @@ -59,7 +59,9 @@ _get_scsi_debug_dev()
>  		let physical=physical/2
>  		let phys_exp=phys_exp+1
>  	done
> -	opts="sector_size=$logical physblk_exp=$phys_exp lowest_aligned=$unaligned dev_size_mb=$size $@"
> +	opts="sector_size=$logical physblk_exp=$phys_exp"
> +	opts="${opts} lowest_aligned=$unaligned dev_size_mb=$size"
> +	opts="${opts} delay=0 clustering=1 $@"
>  	echo "scsi_debug options $opts" >> $seqres.full
>  	modprobe scsi_debug $opts

While this is syntactically correct, especially when leaving $opts unquoted.
But as this patch is trying to to improve code readability, so how about:

local opts=(
    "sector_size=$logical"
    "physblk_exp=$phys_exp"
    "lowest_aligned=$unaligned"
    "dev_size_mb=$size"
    "delay=0"
    "clustering=1"
)
opts+=("$@")
echo "scsi_debug options ${opts[*]}" >> $seqres.full
modprobe scsi_debug "${opts[@]}"

Thanks,
Zorro

>  	[ $? -eq 0 ] || _fail "scsi_debug modprobe failed"
> -- 
> 2.53.0
> 

  reply	other threads:[~2026-08-02 10:36 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-23 14:28 add tests for file system on devices using protection information Christoph Hellwig
2026-07-23 14:28 ` [PATCH 1/4] common/scsi_debug: don't slow down I/O Christoph Hellwig
2026-08-02 10:35   ` Zorro Lang [this message]
2026-07-23 14:28 ` [PATCH 2/4] common: add a _sysfs_block_integrity_path helper Christoph Hellwig
2026-07-23 14:28 ` [PATCH 3/4] generic: test I/O on devices with T10 protection information Christoph Hellwig
2026-07-23 14:28 ` [PATCH 4/4] generic: test corruption detection using " Christoph Hellwig
2026-08-02 11:57   ` Zorro Lang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=am8Yg5NMbLuIOfBd@zlang-mailbox \
    --to=zlang@kernel.org \
    --cc=anuj20.g@samsung.com \
    --cc=fstests@vger.kernel.org \
    --cc=hch@lst.de \
    --cc=joshi.k@samsung.com \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox