Linux Serial subsystem development
 help / color / mirror / Atom feed
From: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>
To: Marc Zyngier <marc.zyngier@arm.com>
Cc: olof@lixom.net, arnd@arndb.de, robh+dt@kernel.org,
	tglx@linutronix.de, jason@lakedaemon.net,
	daniel.lezcano@linaro.org, gregkh@linuxfoundation.org,
	jslaby@suse.com, afaerber@suse.de,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
	linux-serial@vger.kernel.org, amit.kucheria@linaro.org,
	linus.walleij@linaro.org, zhao_steven@263.net,
	overseas.sales@unisoc.com
Subject: Re: [PATCH v2 08/15] irqchip: Add RDA8810PL interrupt driver
Date: Wed, 21 Nov 2018 23:11:02 +0530	[thread overview]
Message-ID: <20181121174017.GA4411@Mani-XPS-13-9360> (raw)
In-Reply-To: <83f70f64-79f1-c6e5-0328-09cc567f2686@arm.com>

Hi Marc,

On Wed, Nov 21, 2018 at 08:41:25AM +0000, Marc Zyngier wrote:
> On 21/11/2018 03:36, Manivannan Sadhasivam wrote:
> > Add interrupt driver for RDA Micro RDA8810PL SoC.
> > 
> > Signed-off-by: Andreas Färber <afaerber@suse.de>
> > Signed-off-by: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>
> > ---
> >  arch/arm/mach-rda/Kconfig      |   1 +
> >  drivers/irqchip/Kconfig        |   4 ++
> >  drivers/irqchip/Makefile       |   1 +
> >  drivers/irqchip/irq-rda-intc.c | 113 +++++++++++++++++++++++++++++++++
> >  4 files changed, 119 insertions(+)
> >  create mode 100644 drivers/irqchip/irq-rda-intc.c
> > 
> > diff --git a/arch/arm/mach-rda/Kconfig b/arch/arm/mach-rda/Kconfig
> > index dafab78d7aab..29012bc68ca4 100644
> > --- a/arch/arm/mach-rda/Kconfig
> > +++ b/arch/arm/mach-rda/Kconfig
> > @@ -3,5 +3,6 @@ menuconfig ARCH_RDA
> >  	depends on ARCH_MULTI_V7
> >  	select COMMON_CLK
> >  	select GENERIC_IRQ_CHIP
> > +	select RDA_INTC
> >  	help
> >  	  This enables support for the RDA Micro 8810PL SoC family.
> > diff --git a/drivers/irqchip/Kconfig b/drivers/irqchip/Kconfig
> > index 51a5ef0e96ed..9d54645870ad 100644
> > --- a/drivers/irqchip/Kconfig
> > +++ b/drivers/irqchip/Kconfig
> > @@ -195,6 +195,10 @@ config JCORE_AIC
> >  	help
> >  	  Support for the J-Core integrated AIC.
> >  
> > +config RDA_INTC
> > +	bool
> > +	select IRQ_DOMAIN
> > +
> >  config RENESAS_INTC_IRQPIN
> >  	bool
> >  	select IRQ_DOMAIN
> > diff --git a/drivers/irqchip/Makefile b/drivers/irqchip/Makefile
> > index 794c13d3ac3d..417108027e40 100644
> > --- a/drivers/irqchip/Makefile
> > +++ b/drivers/irqchip/Makefile
> > @@ -43,6 +43,7 @@ obj-$(CONFIG_IMGPDC_IRQ)		+= irq-imgpdc.o
> >  obj-$(CONFIG_IRQ_MIPS_CPU)		+= irq-mips-cpu.o
> >  obj-$(CONFIG_SIRF_IRQ)			+= irq-sirfsoc.o
> >  obj-$(CONFIG_JCORE_AIC)			+= irq-jcore-aic.o
> > +obj-$(CONFIG_RDA_INTC)			+= irq-rda-intc.o
> >  obj-$(CONFIG_RENESAS_INTC_IRQPIN)	+= irq-renesas-intc-irqpin.o
> >  obj-$(CONFIG_RENESAS_IRQC)		+= irq-renesas-irqc.o
> >  obj-$(CONFIG_VERSATILE_FPGA_IRQ)	+= irq-versatile-fpga.o
> > diff --git a/drivers/irqchip/irq-rda-intc.c b/drivers/irqchip/irq-rda-intc.c
> > new file mode 100644
> > index 000000000000..1b372bdb23bc
> > --- /dev/null
> > +++ b/drivers/irqchip/irq-rda-intc.c
> > @@ -0,0 +1,113 @@
> > +// SPDX-License-Identifier: GPL-2.0+
> > +/*
> > + * RDA8810PL SoC irqchip driver
> > + *
> > + * Copyright RDA Microelectronics Company Limited
> > + * Copyright (c) 2017 Andreas Färber
> > + * Copyright (c) 2018 Manivannan Sadhasivam
> > + */
> > +
> > +#include <linux/init.h>
> > +#include <linux/interrupt.h>
> > +#include <linux/irq.h>
> > +#include <linux/irqchip.h>
> > +#include <linux/irqdomain.h>
> > +#include <linux/of_address.h>
> > +
> > +#include <asm/irq.h>
> 
> You shouldn't need to include this.
> 

Ack.

> > +#include <asm/exception.h>
> > +
> > +#define RDA_INTC_FINALSTATUS	0x00
> > +#define RDA_INTC_STATUS		0x04
> > +#define RDA_INTC_MASK_SET	0x08
> > +#define RDA_INTC_MASK_CLR	0x0c
> > +#define RDA_INTC_WAKEUP_MASK	0x18
> > +#define RDA_INTC_CPU_SLEEP	0x1c
> 
> Half of these constants are unused. Do we really need them?
> 

Usually I tend to define all registers to provide overall reg map. But
I have no issues to remove the not used ones.

> > +
> > +#define RDA_IRQ_MASK_ALL	0xFFFFFFFF
> > +
> > +#define RDA_NR_IRQS 32
> 
> Surely the mask can be derived from the number of interrupts?
> 

Why not? Since each bit corresponds to a single interrupt, 0xFFFFFFFF
can cover all 32 bits which is equal to the total number of interrupts
supported by the controller. Am I missing anything here?

> > +
> > +static void __iomem *base;
> 
> Everything in this driver is prefixed with rda_. It would seem valuable
> to  do the same here, as "base" is a bit too generic.
> 

Ack.

> > +
> > +static void rda_intc_mask_irq(struct irq_data *d)
> > +{
> > +	writel_relaxed(BIT(d->hwirq), base + RDA_INTC_MASK_CLR);
> > +}
> > +
> > +static void rda_intc_unmask_irq(struct irq_data *d)
> > +{
> > +	writel_relaxed(BIT(d->hwirq), base + RDA_INTC_MASK_SET);
> 
> Are the names MASK_CLR and MASK_SET from the datasheet? They seem to be
> backward (you set the mask to unmask...), and seem to behave like an
> enable instead. That's not a big issue, just curious.
> 

Yes, this naming convention comes from the datasheet and it is a bit
wierd as you said ;-)

> > +}
> > +
> > +static int rda_intc_set_type(struct irq_data *data, unsigned int flow_type)
> > +{
> > +	/* Hardware supports only level triggered interrupts */
> > +	if (flow_type & (IRQF_TRIGGER_HIGH | IRQF_TRIGGER_LOW))
> > +		irq_set_handler(data->irq, handle_level_irq);
> 
> Why do you need to do this? You've already configured it at map time,
> and it is not changing under your feet. This should be written as:
> 
> if ((flow_type & (IRQF_TRIGGER_HIGH | IRQF_TRIGGER_LOW)) == flow_type)
> 	return 0;
> 
> return -EINVAL;
> 

Okay.

> > +	else
> > +		return -EINVAL;
> > +
> > +	return 0;
> > +}
> > +
> > +static struct irq_domain *rda_irq_domain;
> 
> Please move this to the top of the file, next to "base".
> 

Ack.

> > +
> > +static void __exception_irq_entry rda_handle_irq(struct pt_regs *regs)
> > +{
> > +	u32 stat = readl_relaxed(base + RDA_INTC_FINALSTATUS);
> > +	u32 hwirq;
> > +
> > +	while (stat) {
> > +		hwirq = __fls(stat);
> > +		handle_domain_irq(rda_irq_domain, hwirq, regs);
> > +		stat &= ~(1 << hwirq);
> > +	}
> > +}
> > +
> > +static struct irq_chip rda_irq_chip = {
> > +	.name		= "rda-intc",
> > +	.irq_mask	= rda_intc_mask_irq,
> > +	.irq_unmask	= rda_intc_unmask_irq,
> > +	.irq_set_type	= rda_intc_set_type,
> > +};
> > +
> > +static int rda_irq_map(struct irq_domain *d,
> > +		       unsigned int virq, irq_hw_number_t hw)
> > +{
> > +	irq_set_status_flags(virq, IRQ_LEVEL);
> > +	irq_set_chip_and_handler(virq, &rda_irq_chip, handle_level_irq);
> > +	irq_set_chip_data(virq, d->host_data);
> > +	irq_set_probe(virq);
> > +
> > +	return 0;
> > +}
> > +
> > +static const struct irq_domain_ops rda_irq_domain_ops = {
> > +	.map = rda_irq_map,
> > +	.xlate = irq_domain_xlate_onecell,
> > +};
> > +
> > +static int __init rda8810_intc_init(struct device_node *node,
> > +				    struct device_node *parent)
> > +{
> > +	base = of_io_request_and_map(node, 0, "rda-intc");
> > +	if (!base)
> > +		return -ENXIO;
> > +
> > +	/* Mask, and invalidate all interrupt sources */
> 
> What does "invalidate" mean here?
> 

Mean to say "disable" but yeah not appropriate. Will remove it.

> > +	writel_relaxed(RDA_IRQ_MASK_ALL, base + RDA_INTC_MASK_CLR);
> > +
> > +	rda_irq_domain = irq_domain_create_linear(&node->fwnode, RDA_NR_IRQS,
> > +						  &rda_irq_domain_ops, base);
> > +	if (WARN_ON(!rda_irq_domain)) {
> > +		iounmap(base);
> > +		return -ENODEV;
> 
> Why ENODEV? ENOMEM seems more appropriate. The WARN_ON is a bit
> superfluous, as the failing probe should be noisy enough.
> 

Ack. ENOMEM comes from your suggestion in previous review.

> > +	}
> > +
> > +	set_handle_irq(rda_handle_irq);
> > +
> > +	return 0;
> > +}
> > +
> > +IRQCHIP_DECLARE(rda_intc, "rda,8810pl-intc", rda8810_intc_init);
> > 
> 
> You've already posted two versions in 3 days, please allow for a week
> between versions.
> 

Sorry for that. I thought the other way, allowing too much delay would
hinder the review process. Will post the next revision after few more days.

Thanks,
Mani

> Thanks,
> 
> 	M.
> -- 
> Jazz is not dead. It just smells funny...

  reply	other threads:[~2018-11-21 17:41 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-21  3:36 [PATCH v2 00/15] Add initial RDA8810PL SoC and Orange Pi boards support Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 01/15] dt-bindings: Add RDA Micro vendor prefix Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 02/15] dt-bindings: arm: Document RDA8810PL and reference boards Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 03/15] ARM: Prepare RDA8810PL SoC Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 04/15] dt-bindings: interrupt-controller: Document RDA8810PL intc Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 05/15] arm: dts: Add devicetree for RDA8810PL SoC Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 06/15] arm: dts: Add devicetree for OrangePi 2G IoT board Manivannan Sadhasivam
2018-11-21  8:55   ` Arnd Bergmann
2018-12-03 15:53   ` Rob Herring
2018-12-03 17:11     ` Olof Johansson
2018-12-03 17:21       ` Rob Herring
2018-12-03 17:53         ` Olof Johansson
2018-11-21  3:36 ` [PATCH v2 07/15] arm: dts: Add devicetree for OrangePi i96 board Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 08/15] irqchip: Add RDA8810PL interrupt driver Manivannan Sadhasivam
2018-11-21  8:41   ` Marc Zyngier
2018-11-21 17:41     ` Manivannan Sadhasivam [this message]
2018-11-21  3:36 ` [PATCH v2 09/15] dt-bindings: timer: Document RDA8810PL SoC timer Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 10/15] arm: dts: rda8810pl: Add timer support Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 11/15] clocksource: Add clock driver for RDA8810PL SoC Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 12/15] dt-bindings: serial: Document RDA Micro UART Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 13/15] arm: dts: rda8810pl: Add interrupt support for UART Manivannan Sadhasivam
2018-11-21  3:36 ` [PATCH v2 14/15] tty: serial: Add RDA8810PL UART driver Manivannan Sadhasivam
2018-11-22 10:09   ` Greg KH
2018-11-21  3:36 ` [PATCH v2 15/15] MAINTAINERS: Add entry for RDA Micro SoC architecture Manivannan Sadhasivam
2018-11-24  8:30   ` kbuild test robot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181121174017.GA4411@Mani-XPS-13-9360 \
    --to=manivannan.sadhasivam@linaro.org \
    --cc=afaerber@suse.de \
    --cc=amit.kucheria@linaro.org \
    --cc=arnd@arndb.de \
    --cc=daniel.lezcano@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jason@lakedaemon.net \
    --cc=jslaby@suse.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    --cc=marc.zyngier@arm.com \
    --cc=olof@lixom.net \
    --cc=overseas.sales@unisoc.com \
    --cc=robh+dt@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=zhao_steven@263.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox