messages from 2026-07-10 20:18:41 to 2026-07-14 10:17:47 UTC [more...]
[PATCH v2 00/33] mm: make VMA page offset handling more consistent
2026-07-14 10:17 UTC (57+ messages)
` [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
` [PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
` [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
` [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
` [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
` [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
` [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
` [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
` [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
` [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
` [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
` [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
` [PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
` [PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
` [PATCH v2 17/33] mm: introduce and use linear_page_delta()
` [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
` [PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
` [PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
` [PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
` [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
` [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
` [PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
` [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
` [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
` [PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
` [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
` [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
` [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
` [PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()
` [PATCH v2 32/33] tools/testing/vma: default VMA, mm flag bits to 64-bit
` [PATCH v2 33/33] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
[PATCH 0/3] x86/sgx: Remove unused definitions and reuse launch token size
2026-07-14 0:24 UTC (10+ messages)
` [PATCH 1/3] x86/sgx: Remove unused TCS definitions
` [PATCH 2/3] x86/sgx: Remove unused size and count definitions
` [PATCH 3/3] x86/sgx: Use SGX_LAUNCH_TOKEN_SIZE in __sgx_virt_einit()
[PATCH 00/30] mm: make VMA page offset handling more consistent
2026-07-11 6:26 UTC (12+ messages)
` [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
` [PATCH 29/30] tools/testing/vma: default VMA flag bits to 64-bit
` [PATCH 30/30] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
page: | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox