SUPERH platform development
 help / color / mirror / Atom feed
From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: linux-sh@vger.kernel.org
Subject: Re: [PATCH 01/37] sh-pfc: r8a7740: Add SCIF pin groups and functions
Date: Tue, 23 Apr 2013 10:51:09 +0000	[thread overview]
Message-ID: <15021318.76Wlbse3Yt@avalon> (raw)
In-Reply-To: <1366671618-8796-2-git-send-email-laurent.pinchart+renesas@ideasonboard.com>

Hi Morimoto-san,

On Monday 22 April 2013 18:25:22 Kuninori Morimoto wrote:
> Hi Laurent
> 
> Thank you for your hard work
> 
> > +/* - SCIFA0
> > ----------------------------------------------------------------- */
> > +static const unsigned int scifa0_data_pins[] = {
> > +	/* RXD, TXD */
> > +	197, 198,
> > +};
> 
> I guess these numbers mean PORT197, PORT198,
> but,this kind of "direct numbering" is difficult to read/understand
> for non-expert people IMO.
> But, it is easy to understand that it is "GPIO PORT something" if there is
> ...
> 
> #define SH_GPIO_PORT(nr)	(nr)
> 
> This is just my opinion, and I'm not sure other people.

On R-Car platforms with banked GPIOs I totally agreed that the RCAR_GP_PIN() 
macro improved readability. In this particular case were the datasheet uses 
port numbers directly I don't think there's a need for a macro, as developers 
who touch this code are expected to at least know what a port number is :-)

-- 
Regards,

Laurent Pinchart


      parent reply	other threads:[~2013-04-23 10:51 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-22 22:59 [PATCH 01/37] sh-pfc: r8a7740: Add SCIF pin groups and functions Laurent Pinchart
2013-04-23  1:25 ` Kuninori Morimoto
2013-04-23 10:51 ` Laurent Pinchart [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=15021318.76Wlbse3Yt@avalon \
    --to=laurent.pinchart@ideasonboard.com \
    --cc=linux-sh@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox