From mboxrd@z Thu Jan 1 00:00:00 1970 From: Matthew Wilcox Date: Wed, 16 Jan 2019 12:30:18 +0000 Subject: Re: [PATCH V2] mm: Introduce GFP_PGTABLE Message-Id: <20190116123018.GF6310@bombadil.infradead.org> List-Id: References: <1547619692-7946-1-git-send-email-anshuman.khandual@arm.com> <20190116065703.GE24149@dhcp22.suse.cz> In-Reply-To: <20190116065703.GE24149@dhcp22.suse.cz> MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: Michal Hocko Cc: Anshuman Khandual , linux-mm@kvack.org, akpm@linux-foundation.org, linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org, linux-arm-kernel@lists.infradead.org, linux-sh@vger.kernel.org, kvmarm@lists.cs.columbia.edu, linux-riscv@lists.infradead.org, linux@armlinux.org.uk, catalin.marinas@arm.com, will.deacon@arm.com, mpe@ellerman.id.au, tglx@linutronix.de, mingo@redhat.com, dave.hansen@linux.intel.com, peterz@infradead.org, christoffer.dall@arm.com, marc.zyngier@arm.com, kirill@shutemov.name, rppt@linux.vnet.ibm.com, ard.biesheuvel@linaro.org, mark.rutland@arm.com, steve.capper@arm.com, james.morse@arm.com, robin.murphy@arm.com, aneesh.kumar@linux.ibm.com, vbabka@suse.cz, shakeelb@google.com, rientjes@google.com, palmer@sifive.com On Wed, Jan 16, 2019 at 07:57:03AM +0100, Michal Hocko wrote: > On Wed 16-01-19 11:51:32, Anshuman Khandual wrote: > > All architectures have been defining their own PGALLOC_GFP as (GFP_KERNEL | > > __GFP_ZERO) and using it for allocating page table pages. This causes some > > code duplication which can be easily avoided. GFP_KERNEL allocated and > > cleared out pages (__GFP_ZERO) are required for page tables on any given > > architecture. This creates a new generic GFP flag flag which can be used > > for any page table page allocation. Does not cause any functional change. > > > > GFP_PGTABLE is being added into include/asm-generic/pgtable.h which is the > > generic page tabe header just to prevent it's potential misuse as a general > > allocation flag if included in include/linux/gfp.h. > > I haven't reviewed the patch yet but I am wondering whether this is > really worth it without going all the way down to unify the common code > and remove much more code duplication. Or is this not possible for some > reason? Exactly what I suggested doing in response to v1. Also, the approach taken here is crazy. x86 has a feature that no other architecture has bothered to implement yet -- accounting page tables to the process. Yet instead of spreading that goodness to all other architectures, Anshuman has gone to more effort to avoid doing that.