From mboxrd@z Thu Jan 1 00:00:00 1970 From: Andrew Morton Date: Tue, 25 Jun 2019 19:37:57 +0000 Subject: Re: [PATCH 14/16] mm: move the powerpc hugepd code to mm/gup.c Message-Id: <20190625123757.ec7e886747bb5a9bc364107d@linux-foundation.org> List-Id: References: <20190625143715.1689-1-hch@lst.de> <20190625143715.1689-15-hch@lst.de> In-Reply-To: <20190625143715.1689-15-hch@lst.de> MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: Christoph Hellwig Cc: Linus Torvalds , Paul Burton , James Hogan , Yoshinori Sato , Rich Felker , "David S. Miller" , Nicholas Piggin , Khalid Aziz , Andrey Konovalov , Benjamin Herrenschmidt , Paul Mackerras , Michael Ellerman , linux-mips@vger.kernel.org, linux-sh@vger.kernel.org, sparclinux@vger.kernel.org, linuxppc-dev@lists.ozlabs.org, linux-mm@kvack.org, x86@kernel.org, linux-kernel@vger.kernel.org On Tue, 25 Jun 2019 16:37:13 +0200 Christoph Hellwig wrote: > +static int gup_huge_pd(hugepd_t hugepd Naming nitlet: we have hugepd and we also have huge_pd. We have hugepte and we also have huge_pte. It make things a bit hard to remember and it would be nice to make it all consistent sometime. We're consistent with huge_pud and almost consistent with huge_pmd. To be fully consistent I guess we should make all of them have the underscore. Or not have it.