From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: linux-sh@vger.kernel.org
Subject: Re: [PATCH v2 1/8] dmaengine: sh: Rework Kconfig and Makefile
Date: Mon, 04 Aug 2014 15:38:27 +0000 [thread overview]
Message-ID: <7434411.teHIrKfERp@avalon> (raw)
In-Reply-To: <1405727425-6237-2-git-send-email-laurent.pinchart+renesas@ideasonboard.com>
Hi Geert,
Thank you for the review.
On Monday 04 August 2014 11:09:06 Geert Uytterhoeven wrote:
> On Sat, Jul 19, 2014 at 1:50 AM, Laurent Pinchart wrote:
> > Separate helpers and drivers in the Kconfig and Makefile to improve
> > readability and move the CONFIG_OF dependency from the Makefile to
> > Kconfig.
> >
> > Signed-off-by: Laurent Pinchart
> > <laurent.pinchart+renesas@ideasonboard.com>
> >
> > ---
> >
> > Changes since v1:
> >
> > - Replace CONFIG_OF with OF in Kconfig
> > ---
> >
> > drivers/dma/sh/Kconfig | 24 +++++++++++++++++++-----
> > drivers/dma/sh/Makefile | 14 +++++++++++---
> > 2 files changed, 30 insertions(+), 8 deletions(-)
> >
> > diff --git a/drivers/dma/sh/Kconfig b/drivers/dma/sh/Kconfig
> > index 0f71981..0349125 100644
> > --- a/drivers/dma/sh/Kconfig
> > +++ b/drivers/dma/sh/Kconfig
> > @@ -2,21 +2,39 @@
> > # DMA engine configuration for sh
> > #
> >
> > +#
> > +# DMA Engine Helpers
> > +#
> > +
> > config SH_DMAE_BASE
> > bool "Renesas SuperH DMA Engine support"
> > - depends on (SUPERH && SH_DMA) || ARCH_SHMOBILE || COMPILE_TEST
> > + depends on SUPERH || ARCH_SHMOBILE || COMPILE_TEST
> > + depends on !SUPERH || SH_DMA
> > depends on !SH_DMA_API
> > default y
> > select DMA_ENGINE
> > help
> > Enable support for the Renesas SuperH DMA controllers.
> >
> > +#
> > +# DMA Controllers
> > +#
> > +
> > config SH_DMAE
> > tristate "Renesas SuperH DMAC support"
> > depends on SH_DMAE_BASE
> > help
> > Enable support for the Renesas SuperH DMA controllers.
> >
> > +if SH_DMAE
> > +
> > +config SH_DMAE_R8A73A4
> > + def_bool y
> > + depends on ARCH_R8A73A4
> > + depends on OF
> > +
> > +endif
>
> What's the rationale behind putting this inside an "if/endif" block, instead
> of using "depends on"?
In my opinion it shows more clearly that the SH_DMAE_R8A73A4 option is a sub-
driver of SH_DMAE. It might just be a matter of personal taste though.
> BTW, I'm still puzzled by the difference between SH_DMAE_BASE and SH_DMAE,
> which have identical help texts.
SH_DMAE_BASE is a helper layer that aims at handling tasks required by the DMA
engine API but not specific to drivers in a central location. There's nothing
really SH-specific in there, it should be turned in more generic helpers and
moved to the DMA engine core.
SH_DMAE is the SYS-DMAC driver itself. The Kconfig symbol is badly named given
that we now have different DMA engine drivers for "sh" (in the sense SuperH +
ARM).
> > +
> > config SUDMAC
> > tristate "Renesas SUDMAC support"
> > depends on SH_DMAE_BASE
> > @@ -34,7 +52,3 @@ config RCAR_AUDMAC_PP
> > depends on SH_DMAE_BASE
> > help
> > Enable support for the Renesas R-Car Audio DMAC Peripheral
> > Peripheral controllers.>
> > -
> > -config SHDMA_R8A73A4
> > - def_bool y
> > - depends on ARCH_R8A73A4 && SH_DMAE != n
--
Regards,
Laurent Pinchart
prev parent reply other threads:[~2014-08-04 15:38 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-07-18 23:50 [PATCH v2 1/8] dmaengine: sh: Rework Kconfig and Makefile Laurent Pinchart
2014-08-04 9:09 ` Geert Uytterhoeven
2014-08-04 15:38 ` Laurent Pinchart [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7434411.teHIrKfERp@avalon \
--to=laurent.pinchart@ideasonboard.com \
--cc=linux-sh@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox