Linux SNPS ARC Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Ira Weiny <ira.weiny@intel.com>
To: Christoph Hellwig <hch@infradead.org>
Cc: Peter Zijlstra <peterz@infradead.org>,
	Dave Hansen <dave.hansen@linux.intel.com>,
	dri-devel@lists.freedesktop.org, linux-mips@vger.kernel.org,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	Max Filippov <jcmvbkbc@gmail.com>, Huang Rui <ray.huang@amd.com>,
	Paul Mackerras <paulus@samba.org>,
	"H. Peter Anvin" <hpa@zytor.com>,
	sparclinux@vger.kernel.org,
	Dan Williams <dan.j.williams@intel.com>,
	Helge Deller <deller@gmx.de>,
	x86@kernel.org, linux-csky@vger.kernel.org,
	Ingo Molnar <mingo@redhat.com>,
	linux-snps-arc@lists.infradead.org,
	linux-xtensa@linux-xtensa.org, Borislav Petkov <bp@alien8.de>,
	Andy Lutomirski <luto@kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	linux-arm-kernel@lists.infradead.org,
	Chris Zankel <chris@zankel.net>,
	Thomas Bogendoerfer <tsbogend@alpha.franken.de>,
	linux-parisc@vger.kernel.org, linux-kernel@vger.kernel.org,
	"David S. Miller" <davem@davemloft.net>,
	Andrew Morton <akpm@linux-foundation.org>,
	linuxppc-dev@lists.ozlabs.org,
	Christian Koenig <christian.koenig@amd.com>
Subject: Re: sparc-related comment, to Re: [PATCH V1 07/10] arch/kmap: Ensure kmap_prot visibility
Date: Fri, 1 May 2020 08:35:52 -0700	[thread overview]
Message-ID: <20200501153551.GA673107@iweiny-DESK2.sc.intel.com> (raw)
In-Reply-To: <20200501084446.GG27858@infradead.org>

On Fri, May 01, 2020 at 01:44:46AM -0700, Christoph Hellwig wrote:
> > --- a/arch/sparc/mm/highmem.c
> > +++ b/arch/sparc/mm/highmem.c
> > @@ -33,6 +33,7 @@
> >  #include <asm/vaddrs.h>
> >  
> >  pgprot_t kmap_prot;
> > +EXPORT_SYMBOL(kmap_prot);
> 
> Btw, I don't see why sparc needs this as a variable, as there is just
> a single assignment to it.

Because sparc uses non-standard defines which I'm not familiar with.

        kmap_prot = __pgprot(SRMMU_ET_PTE | SRMMU_PRIV | SRMMU_CACHE);

SRMMU_ET_PTE and friends are defined in 

arch/sparc/include/asm/pgtsrmmu.h

Since I can't readily test sparc this was easier to put out than let 0-day
crank on the entire series checking if including that header in the common
header chain would be an issue.

> 
> If sparc is sorted out we can always make it a define, and use a define
> for kmap_prot that defaults to PAGE_KERNEL, avoiding a little
> more duplication.

Agreed.  But it seems easier as a follow up (for me with 0-day).  Perhaps
someone from sparc can weigh in on the specifics of those defines and why they
are different from the normal ones?  Or even provide a follow on patch?

Ira


_______________________________________________
linux-snps-arc mailing list
linux-snps-arc@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-snps-arc

  reply	other threads:[~2020-05-01 15:36 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-30 20:38 [PATCH V1 00/10] Remove duplicated kmap code ira.weiny
2020-04-30 20:38 ` [PATCH V1 01/10] arch/kmap: Remove BUG_ON() ira.weiny
2020-05-01  8:35   ` Christoph Hellwig
2020-04-30 20:38 ` [PATCH V1 02/10] arch/xtensa: Move kmap build bug out of the way ira.weiny
2020-05-01  8:36   ` Christoph Hellwig
2020-04-30 20:38 ` [PATCH V1 03/10] arch/kmap: Remove redundant arch specific kmaps ira.weiny
2020-05-01  8:37   ` Christoph Hellwig
2020-04-30 20:38 ` [PATCH V1 04/10] arch/kunmap: Remove duplicate kunmap implementations ira.weiny
2020-05-01  8:38   ` Christoph Hellwig
2020-04-30 20:38 ` [PATCH V1 05/10] arch/kmap_atomic: Consolidate duplicate code ira.weiny
2020-05-01  2:09   ` Al Viro
2020-05-01  8:39   ` Christoph Hellwig
2020-04-30 20:38 ` [PATCH V1 06/10] arch/kunmap_atomic: " ira.weiny
2020-05-01  8:39   ` Christoph Hellwig
2020-04-30 20:38 ` [PATCH V1 07/10] arch/kmap: Ensure kmap_prot visibility ira.weiny
2020-05-01  8:44   ` sparc-related comment, to " Christoph Hellwig
2020-05-01 15:35     ` Ira Weiny [this message]
2020-04-30 20:38 ` [PATCH V1 08/10] arch/kmap: Don't hard code kmap_prot values ira.weiny
2020-05-01  2:16   ` Al Viro
2020-05-01  8:47   ` Christoph Hellwig
2020-04-30 20:38 ` [PATCH V1 09/10] arch/kmap: Define kmap_atomic_prot() for all arch's ira.weiny
2020-05-01  2:37   ` Al Viro
2020-05-01  3:20     ` Al Viro
2020-05-03  3:11       ` Ira Weiny
2020-05-01  8:48   ` Christoph Hellwig
2020-04-30 20:38 ` [PATCH V1 10/10] drm: Remove drm specific kmap_atomic code ira.weiny
2020-05-01  7:23   ` Christian König
2020-05-01  8:49   ` Christoph Hellwig
2020-05-01  2:29 ` [PATCH V1 00/10] Remove duplicated kmap code Michael Ellerman
2020-05-01  8:54 ` Christoph Hellwig
2020-05-01 17:18   ` Ira Weiny

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200501153551.GA673107@iweiny-DESK2.sc.intel.com \
    --to=ira.weiny@intel.com \
    --cc=James.Bottomley@hansenpartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=bp@alien8.de \
    --cc=chris@zankel.net \
    --cc=christian.koenig@amd.com \
    --cc=dan.j.williams@intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=davem@davemloft.net \
    --cc=deller@gmx.de \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=hch@infradead.org \
    --cc=hpa@zytor.com \
    --cc=jcmvbkbc@gmail.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-csky@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mips@vger.kernel.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linux-snps-arc@lists.infradead.org \
    --cc=linux-xtensa@linux-xtensa.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=luto@kernel.org \
    --cc=mingo@redhat.com \
    --cc=paulus@samba.org \
    --cc=peterz@infradead.org \
    --cc=ray.huang@amd.com \
    --cc=sparclinux@vger.kernel.org \
    --cc=tglx@linutronix.de \
    --cc=tsbogend@alpha.franken.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox