From mboxrd@z Thu Jan 1 00:00:00 1970 From: Borislav Petkov Subject: Re: [PATCH v4 9/9] bug.h: Convert BUILD_BUG{,_ON} to use BUILD_BUG_ON_MSG Date: Tue, 30 Oct 2012 20:19:05 +0100 Message-ID: <20121030191905.GG28499@liondog.tnic> References: <1351457648-7453-1-git-send-email-daniel.santos@pobox.com> <1351457835-7553-9-git-send-email-daniel.santos@pobox.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Return-path: Content-Disposition: inline In-Reply-To: <1351457835-7553-9-git-send-email-daniel.santos@pobox.com> Sender: linux-kernel-owner@vger.kernel.org Cc: LKML , Andi Kleen , Andrea Arcangeli , Andrew Morton , Christopher Li , Daniel Santos , David Daney , David Howells , Joe Perches , Josh Triplett , Konstantin Khlebnikov , linux-sparse@vger.kernel.org, Michel Lespinasse , Paul Gortmaker , Pavel Pisa , Peter Zijlstra , Steven Rostedt , David Rientjes List-Id: linux-sparse@vger.kernel.org On Sun, Oct 28, 2012 at 03:57:15PM -0500, danielfsantos@att.net wrote: > Remove duplicate code by converting BUILD_BUG and BUILD_BUG_ON to just > call BUILD_BUG_ON_MSG. This not only reduces source code bloat, but > also prevents the possibility of code being changed for one macro and > not for the other (which was previously the case for BUILD_BUG and > BUILD_BUG_ON). > > Signed-off-by: Daniel Santos > --- > include/linux/bug.h | 17 +++-------------- > 1 files changed, 3 insertions(+), 14 deletions(-) > > diff --git a/include/linux/bug.h b/include/linux/bug.h > index 3bc1ddf..b58ba51 100644 > --- a/include/linux/bug.h > +++ b/include/linux/bug.h > @@ -81,14 +81,8 @@ struct pt_regs; > #ifndef __OPTIMIZE__ > #define BUILD_BUG_ON(condition) __compiletime_error_fallback(condition) > #else > -#define BUILD_BUG_ON(condition) \ > - do { \ > - extern void __build_bug_on_failed(void) \ > - __compiletime_error("BUILD_BUG_ON failed"); \ > - __compiletime_error_fallback(condition); \ > - if (condition) \ > - __build_bug_on_failed(); \ > - } while(0) > +#define BUILD_BUG_ON(condition) \ > + BUILD_BUG_ON_MSG(condition, "BUILD_BUG_ON failed: " #condition) Concatenating "condition" might not be very informative in all cases. For example: BUILD_BUG_ON(1); Having __LINE__ is good enough IMHO. Thanks. -- Regards/Gruss, Boris.