From: Luc Van Oostenryck <luc.vanoostenryck@gmail.com>
To: linux-sparse@vger.kernel.org
Cc: Luc Van Oostenryck <luc.vanoostenryck@gmail.com>
Subject: [PATCH 5/9] use has_users() in dead_insn() too
Date: Mon, 12 Feb 2018 23:02:42 +0100 [thread overview]
Message-ID: <20180212220246.17750-6-luc.vanoostenryck@gmail.com> (raw)
In-Reply-To: <20180212220246.17750-1-luc.vanoostenryck@gmail.com>
The same functionality was open-coded here.
Change this by calling the new helper: has_users().
Signed-off-by: Luc Van Oostenryck <luc.vanoostenryck@gmail.com>
---
simplify.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/simplify.c b/simplify.c
index 971f8ca91..5a90b9c6a 100644
--- a/simplify.c
+++ b/simplify.c
@@ -308,11 +308,8 @@ void kill_insn(struct instruction *insn, int force)
*/
static int dead_insn(struct instruction *insn, pseudo_t *src1, pseudo_t *src2, pseudo_t *src3)
{
- struct pseudo_user *pu;
- FOR_EACH_PTR(insn->target->users, pu) {
- if (*pu->userp != VOID)
- return 0;
- } END_FOR_EACH_PTR(pu);
+ if (has_users(insn->target))
+ return 0;
insn->bb = NULL;
kill_use(src1);
--
2.16.0
next prev parent reply other threads:[~2018-02-12 22:03 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-02-12 22:02 [PATCH 0/9] fix usage when killing loads & stores Luc Van Oostenryck
2018-02-12 22:02 ` [PATCH 1/9] add testcases for converted loads Luc Van Oostenryck
2018-02-12 22:02 ` [PATCH 2/9] fix killing of " Luc Van Oostenryck
2018-02-12 22:02 ` [PATCH 3/9] fix usage of deadborn loads Luc Van Oostenryck
2018-02-12 22:02 ` [PATCH 4/9] add helpers for pseudo's user-list's size Luc Van Oostenryck
2018-02-12 22:11 ` Linus Torvalds
2018-02-12 22:28 ` Luc Van Oostenryck
2018-02-12 23:25 ` Luc Van Oostenryck
2018-02-12 22:02 ` Luc Van Oostenryck [this message]
2018-02-12 22:02 ` [PATCH 6/9] let kill_instruction() report if changes were made Luc Van Oostenryck
2018-02-12 22:02 ` [PATCH 7/9] kill dead loads Luc Van Oostenryck
2018-02-12 22:02 ` [PATCH 8/9] add testcase for bad killing of dominated stores Luc Van Oostenryck
2018-02-12 22:02 ` [PATCH 9/9] kill dead stores when simplifying symbols Luc Van Oostenryck
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180212220246.17750-6-luc.vanoostenryck@gmail.com \
--to=luc.vanoostenryck@gmail.com \
--cc=linux-sparse@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox