From: Mukesh Savaliya <mukesh.savaliya@oss.qualcomm.com>
To: Abel Vesa <abel.vesa@oss.qualcomm.com>
Cc: Viken Dadhaniya <viken.dadhaniya@oss.qualcomm.com>,
Mark Brown <broonie@kernel.org>,
linux-arm-msm@vger.kernel.org, linux-spi@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] spi: qcom-geni: rename setup_fifo_params() to setup_spi_params() and make it void
Date: Tue, 25 Aug 2026 18:42:09 +0530 [thread overview]
Message-ID: <62ebdf78-85fd-4209-92fe-acda654a2e6f@oss.qualcomm.com> (raw)
In-Reply-To: <lxif5gsyfq24aq3vsiing7xufwdmhllmn3gzdm4sqopz2ttele@myvffcz72jqq>
On 8/25/2026 3:39 PM, Abel Vesa wrote:
> On 26-08-25 14:01:10, Mukesh Savaliya wrote:
>>
>>
>> On 8/24/2026 3:43 PM, Viken Dadhaniya wrote:
>>> The function always returned 0 and had no error paths, so change its
>>> return type to void. Drop the now-dead ret variable and error check
>>> in spi_geni_prepare_message().
>>>
>>> setup_fifo_params() is called for both GENI_SE_FIFO and GENI_SE_DMA
>>> modes, so the "fifo" in the name is misleading. Rename it to
>>> setup_spi_params() to better reflect its purpose of configuring SPI
>>> mode parameters (CS, CPHA, CPOL, loopback, LSB-first).
>>>
>>> No functional change.
>>>
>>> Signed-off-by: Viken Dadhaniya <viken.dadhaniya@oss.qualcomm.com>
>>> ---Reviewed-by: Mukesh Kumar Savaliya <mukesh.savaliya@oss.qualcomm.com>
>
> FYI, there is a chance these might not be picked up by b4, when
> applying.
>
> Make sure when you reply with tags, they are actually part of the new
> message.
Thanks Abel for pointing this ! i realized line got mixed.
next prev parent reply other threads:[~2026-08-25 13:12 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-24 10:13 [PATCH] spi: qcom-geni: rename setup_fifo_params() to setup_spi_params() and make it void Viken Dadhaniya
2026-08-24 12:55 ` Konrad Dybcio
2026-08-25 8:31 ` Mukesh Savaliya
2026-08-25 10:09 ` Abel Vesa
2026-08-25 13:00 ` Mark Brown
2026-08-25 13:12 ` Mukesh Savaliya [this message]
2026-08-25 12:58 ` Mukesh Savaliya
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=62ebdf78-85fd-4209-92fe-acda654a2e6f@oss.qualcomm.com \
--to=mukesh.savaliya@oss.qualcomm.com \
--cc=abel.vesa@oss.qualcomm.com \
--cc=broonie@kernel.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-spi@vger.kernel.org \
--cc=viken.dadhaniya@oss.qualcomm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).