From: Michael Harris <michaelharriscode@gmail.com>
To: Lars-Peter Clausen <lars@metafoo.de>,
Michael Hennerich <Michael.Hennerich@analog.com>,
Jonathan Cameron <jic23@kernel.org>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: "David Lechner" <dlechner@baylibre.com>,
"Nuno Sá" <nuno.sa@analog.com>,
"Andy Shevchenko" <andy@kernel.org>,
linux-iio@vger.kernel.org, linux-staging@lists.linux.dev,
linux-kernel@vger.kernel.org,
"Michael Harris" <michaelharriscode@gmail.com>
Subject: [PATCH v2 0/4] correct macro issues
Date: Thu, 05 Mar 2026 23:16:57 -0800 [thread overview]
Message-ID: <20260305-adt7316-correct-macros-v2-0-3702e3841c42@gmail.com> (raw)
This patch series fixes various issues with the macros definitions, such
as:
- Config macro names that don't indicate which config it's for
- Magic numbers
- Mask values being before the mask itself
Additionally, some macros are outright removed due to having better
modern standards:
- Offset/shift macros are replaced with the use of FIELD_GET(),
FIELD_PREP(), or FIELD_FIT()
- Macros used for custom sign manipulation are replaced with
sign_extend32()
---
Changes in v2:
- Delete "remove unused macros" patch
- Add a patch that fixes manual temperature calculation and deletes the
associated macros
- Add a patch that removes offset/shift macros
- Add a patch that adds the associated config to
macro names and adjusts ordering so that mask values are below the
mask itself
- Use GENMASK_U32() and BIT_U32() instead of GENMASK() and BIT(), to
prevent sysfs_emit() from expecting unsigned long (thanks to David
Laight for this suggestion)
- Corrected macros that were incorrectly using BIT() or GENMASK()
- Change the cover letter description to better fit all the new patches
- Link to v1: https://lore.kernel.org/r/20260130-adt7316-correct-macros-v1-0-8a71df1e42f1@gmail.com
---
Michael Harris (4):
staging: iio: adt7316: refactor temperature calculation logic
staging: iio: adt7316: remove shift/offset macros
staging: iio: adt7316: add config names to registers and reorder
staging: iio: adt7316: convert magic numbers to BIT_U32() or GENMASK_U32()
drivers/staging/iio/addac/adt7316.c | 384 +++++++++++++++++++-----------------
1 file changed, 203 insertions(+), 181 deletions(-)
---
base-commit: 5d2905f2c6acdd1c553f9b022dee730ab2cced71
change-id: 20260130-adt7316-correct-macros-b6801b4ae1b1
Best regards,
--
Michael Harris <michaelharriscode@gmail.com>
next reply other threads:[~2026-03-06 7:17 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-06 7:16 Michael Harris [this message]
2026-03-06 7:16 ` [PATCH v2 1/4] staging: iio: adt7316: refactor temperature calculation logic Michael Harris
2026-03-06 14:51 ` Andy Shevchenko
2026-03-07 11:33 ` Jonathan Cameron
2026-03-06 7:16 ` [PATCH v2 2/4] staging: iio: adt7316: remove shift/offset macros Michael Harris
2026-03-06 14:53 ` Andy Shevchenko
2026-03-10 1:32 ` Michael Harris
2026-03-10 11:29 ` Andy Shevchenko
2026-03-07 11:30 ` Jonathan Cameron
2026-03-06 7:17 ` [PATCH v2 3/4] staging: iio: adt7316: add config names to registers and reorder Michael Harris
2026-03-06 15:04 ` Andy Shevchenko
2026-03-06 7:17 ` [PATCH v2 4/4] staging: iio: adt7316: convert magic numbers to BIT_U32() or GENMASK_U32() Michael Harris
2026-03-06 15:05 ` Andy Shevchenko
2026-03-07 11:33 ` Jonathan Cameron
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260305-adt7316-correct-macros-v2-0-3702e3841c42@gmail.com \
--to=michaelharriscode@gmail.com \
--cc=Michael.Hennerich@analog.com \
--cc=andy@kernel.org \
--cc=dlechner@baylibre.com \
--cc=gregkh@linuxfoundation.org \
--cc=jic23@kernel.org \
--cc=lars@metafoo.de \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=nuno.sa@analog.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox