From: "André Moreira" <andrem.33333@gmail.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: "Sudip Mukherjee" <sudipm.mukherjee@gmail.com>,
"Teddy Wang" <teddy.wang@siliconmotion.com>,
linux-fbdev@vger.kernel.org, linux-staging@lists.linux.dev,
linux-kernel@vger.kernel.org,
"André Moreira" <andrem.33333@gmail.com>
Subject: [PATCH v4] staging: sm750fb: rename variables to comply with kernel style
Date: Tue, 7 Jul 2026 10:15:28 -0300 [thread overview]
Message-ID: <20260707131529.38340-1-andrem.33333@gmail.com> (raw)
In-Reply-To: <2026070710-exact-unveiling-e321@gregkh>
Rename 'setAllEngOff' to 'set_all_eng_off' within the 'init_status'
struct to avoid CamelCase and comply with the Linux kernel coding style.
Signed-off-by: André Moreira <andrem.33333@gmail.com>
---
v4:
- Drop register renames 'pvReg' to 'regs' as they were merged via another upstream patch.
- Keep only the 'init_status' CamelCase cleanup.
drivers/staging/sm750fb/sm750.h | 9 +++++++++
1 file changed, 9 insertions(+)
diff --git a/drivers/staging/sm750fb/sm750.h b/drivers/staging/sm750fb/sm750.h
index 0324778768cbc..3a1bd38ab347a 100644
--- a/drivers/staging/sm750fb/sm750.h
+++ b/drivers/staging/sm750fb/sm750.h
@@ -39,6 +39,15 @@ enum sm750_path {
sm750_pnc = 3, /* panel and crt */
};
+struct init_status {
+ ushort power_mode;
+ /* below three clocks are in unit of MHZ*/
+ ushort chip_clk;
+ ushort mem_clk;
+ ushort master_clk;
+ ushort set_all_eng_off;
+ ushort reset_memory;
+};
struct lynx_accel {
/* base virtual address of DPR registers */
--
2.43.0
next prev parent reply other threads:[~2026-07-07 13:17 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-23 22:06 [PATCH] staging: sm750fb: rename variables to avoid CamelCase André Moreira
2026-07-07 9:11 ` Greg KH
2026-07-07 10:27 ` [PATCH v2] staging: sm750fb: rename variables to comply with kernel style André Moreira
2026-07-07 10:56 ` Greg Kroah-Hartman
2026-07-07 11:43 ` [PATCH v3] " André Moreira
2026-07-07 11:49 ` Greg Kroah-Hartman
2026-07-07 13:15 ` André Moreira [this message]
2026-07-07 13:28 ` [PATCH v4] " Andre Moreira
2026-07-07 14:17 ` Greg Kroah-Hartman
2026-07-07 20:15 ` [PATCH v5] " André Moreira
2026-07-08 5:03 ` Greg Kroah-Hartman
2026-07-08 6:03 ` [PATCH v6] staging: sm750fb: Remove unused variable 'setAllEngOff' André Moreira
2026-07-08 11:59 ` Greg Kroah-Hartman
2026-07-08 13:09 ` Andre Moreira
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260707131529.38340-1-andrem.33333@gmail.com \
--to=andrem.33333@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=sudipm.mukherjee@gmail.com \
--cc=teddy.wang@siliconmotion.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox