From: Akhmad <akhmad100913@gmail.com>
To: gregkh@linuxfoundation.org
Cc: linux-staging@lists.linux.dev, Akhmad <Akhmad100913@gmail.com>
Subject: [PATCH] staging: rtl8723bs: coding style cleanup in rtw_mlme.c
Date: Sat, 25 Jul 2026 16:57:55 +0300 [thread overview]
Message-ID: <20260725135755.39512-1-Akhmad100913@gmail.com> (raw)
Fix multiple coding style issues to improve code readability:
- Break a 140-character line to comply with the kernel coding
style guideline of maximum 100 characters per line
- Move comment before the code for better readability
- Fix typo in comment (varable -> variable)
- Remove dead code: empty if block with only a TODO comment
These changes improve code quality and compliance with kernel
coding style guidelines.
Signed-off-by: Akhmad <Akhmad100913@gmail.com>
---
drivers/staging/rtl8723bs/core/rtw_mlme.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme.c b/drivers/staging/rtl8723bs/core/rtw_mlme.c
index 1196ec011..a29ab63f7 100644
--- a/drivers/staging/rtl8723bs/core/rtw_mlme.c
+++ b/drivers/staging/rtl8723bs/core/rtw_mlme.c
@@ -52,7 +52,10 @@ int rtw_init_mlme_priv(struct adapter *padapter)
pmlmepriv->pscanned = NULL;
pmlmepriv->fw_state = WIFI_STATION_STATE; /* Must sync with rtw_wdev_alloc() */
pmlmepriv->cur_network.network.infrastructure_mode = Ndis802_11AutoUnknown;
- pmlmepriv->scan_mode = SCAN_ACTIVE;/* 1: active, 0: passive. Maybe someday we should rename this varable to "active_mode" (Jeff) */
+ /* 1: active, 0: passive.
+ * Maybe someday we should rename this variable to "active_mode" (Jeff)
+ */
+ pmlmepriv->scan_mode = SCAN_ACTIVE;
spin_lock_init(&pmlmepriv->lock);
INIT_LIST_HEAD(&pmlmepriv->free_bss_pool.queue);
@@ -2426,9 +2429,6 @@ void rtw_update_ht_cap(struct adapter *padapter, u8 *pie, uint ie_len, u8 channe
len = 0;
p = rtw_get_ie(pie + sizeof(struct ndis_802_11_fix_ie), WLAN_EID_HT_OPERATION, &len, ie_len - sizeof(struct ndis_802_11_fix_ie));
- if (p && len > 0) {
- /* todo: */
- }
if ((pregistrypriv->bw_mode & 0x0f) > 0)
cbw40_enable = 1;
--
2.37.1 (Apple Git-137.1)
next reply other threads:[~2026-07-25 13:58 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-25 13:57 Akhmad [this message]
2026-07-25 17:28 ` [PATCH] staging: rtl8723bs: coding style cleanup in rtw_mlme.c Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260725135755.39512-1-Akhmad100913@gmail.com \
--to=akhmad100913@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox