From: Greg KH <gregkh@linuxfoundation.org>
To: Dalvin-Ehinoma Noah Aiguobas <fliegbert2@gmail.com>
Cc: linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/3] staging: rtl8723bs: Renaming variables with type prefix
Date: Tue, 28 Jul 2026 09:28:58 +0200 [thread overview]
Message-ID: <2026072832-rehydrate-pulp-540b@gregkh> (raw)
In-Reply-To: <20260719115451.4401-4-fliegbert2@gmail.com>
On Sun, Jul 19, 2026 at 11:54:51AM +0000, Dalvin-Ehinoma Noah Aiguobas wrote:
> Renaming deprecated variable names which use prefixes as type
> indicators to conform to the styleguide and for improved readability.
>
> Signed-off-by: Dalvin-Ehinoma Noah Aiguobas <fliegbert2@gmail.com>
> ---
> drivers/staging/rtl8723bs/core/rtw_mlme.c | 152 +++++++++++-----------
> 1 file changed, 76 insertions(+), 76 deletions(-)
>
> diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme.c b/drivers/staging/rtl8723bs/core/rtw_mlme.c
> index 114deeecc80f..7e3be8cbc829 100644
> --- a/drivers/staging/rtl8723bs/core/rtw_mlme.c
> +++ b/drivers/staging/rtl8723bs/core/rtw_mlme.c
> @@ -675,52 +675,52 @@ void rtw_survey_event_callback(struct adapter *adapter, u8 *pbuf)
> spin_unlock_bh(&pmlmepriv->lock);
> }
>
> -void rtw_surveydone_event_callback(struct adapter *adapter, u8 *pbuf)
> +void rtw_surveydone_event_callback(struct adapter *adapter, u8 *buf)
> {
> - struct mlme_priv *pmlmepriv = &adapter->mlmepriv;
> + struct mlme_priv *mlme_priv = &adapter->mlmepriv;
As you are changing all of the variables, this patch is hard to read and
verify that this is correct. Please only do one variable name at a
time.
thanks,
greg k-h
prev parent reply other threads:[~2026-07-28 7:29 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-19 11:54 [PATCH 0/3] staging: rtl8723bs: Remove whitespaces Dalvin-Ehinoma Noah Aiguobas
2026-07-19 11:54 ` [PATCH 1/3] staging: rtl8723bs: remove unnecessary whitespace Dalvin-Ehinoma Noah Aiguobas
2026-07-19 11:54 ` [PATCH 2/3] staging: rtl8723bs: wrap line over 100 characters Dalvin-Ehinoma Noah Aiguobas
2026-07-19 11:54 ` [PATCH 3/3] staging: rtl8723bs: Renaming variables with type prefix Dalvin-Ehinoma Noah Aiguobas
2026-07-28 7:28 ` Greg KH [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2026072832-rehydrate-pulp-540b@gregkh \
--to=gregkh@linuxfoundation.org \
--cc=fliegbert2@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox