From: Dalvin-Ehinoma Noah Aiguobas <fliegbert2@gmail.com>
To: gregkh@linuxfoundation.org
Cc: linux-kernel@vger.kernel.org, linux-staging@lists.linux.dev,
Dalvin-Ehinoma Noah Aiguobas <fliegbert2@gmail.com>
Subject: [PATCH 08/11] staging: rtl8723bs: renaming variable bHwLDPCSupport in rtw_mlme.c
Date: Fri, 31 Jul 2026 10:41:31 +0000 [thread overview]
Message-ID: <20260731104134.12754-9-fliegbert2@gmail.com> (raw)
In-Reply-To: <20260731104134.12754-1-fliegbert2@gmail.com>
Renaming occurrences of bHwLDPCSupport to hw_ldpc_support since the
prefix b is an old naming convention to indicate a boolean variable.
Signed-off-by: Dalvin-Ehinoma Noah Aiguobas <fliegbert2@gmail.com>
---
drivers/staging/rtl8723bs/core/rtw_mlme.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme.c b/drivers/staging/rtl8723bs/core/rtw_mlme.c
index 0da5515a6be5..6a7b86532d81 100644
--- a/drivers/staging/rtl8723bs/core/rtw_mlme.c
+++ b/drivers/staging/rtl8723bs/core/rtw_mlme.c
@@ -2183,7 +2183,7 @@ void rtw_ht_use_default_setting(struct adapter *adapter)
struct mlme_priv *mlme_priv = &adapter->mlmepriv;
struct ht_priv *ht_priv = &mlme_priv->htpriv;
struct registry_priv *registry_priv = &adapter->registrypriv;
- bool bHwLDPCSupport = false, bHwSTBCSupport = false;
+ bool hw_ldpc_support = false, bHwSTBCSupport = false;
bool bHwSupportBeamformer = false, bHwSupportBeamformee = false;
if (registry_priv->wifi_spec)
@@ -2195,14 +2195,14 @@ void rtw_ht_use_default_setting(struct adapter *adapter)
ht_priv->sgi_20m = TEST_FLAG(registry_priv->short_gi, BIT(0)) ? true : false;
/* LDPC support */
- rtw_hal_get_def_var(adapter, HAL_DEF_RX_LDPC, (u8 *)&bHwLDPCSupport);
+ rtw_hal_get_def_var(adapter, HAL_DEF_RX_LDPC, (u8 *)&hw_ldpc_support);
CLEAR_FLAGS(ht_priv->ldpc_cap);
- if (bHwLDPCSupport) {
+ if (hw_ldpc_support) {
if (TEST_FLAG(registry_priv->ldpc_cap, BIT(4)))
SET_FLAG(ht_priv->ldpc_cap, LDPC_HT_ENABLE_RX);
}
- rtw_hal_get_def_var(adapter, HAL_DEF_TX_LDPC, (u8 *)&bHwLDPCSupport);
- if (bHwLDPCSupport) {
+ rtw_hal_get_def_var(adapter, HAL_DEF_TX_LDPC, (u8 *)&hw_ldpc_support);
+ if (hw_ldpc_support) {
if (TEST_FLAG(registry_priv->ldpc_cap, BIT(5)))
SET_FLAG(ht_priv->ldpc_cap, LDPC_HT_ENABLE_TX);
}
--
2.55.0
next prev parent reply other threads:[~2026-07-31 10:43 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-31 10:41 [PATCH 00/11] Rename variables in rtw_mlme.c Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 01/11] staging: rtl8723bs: renaming variable pbuf " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 02/11] staging: rtl8723bs: renaming variable pmlmepriv " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 03/11] staging: rtl8723bs: renaming variable pdev_network " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 04/11] staging: rtl8723bs: renaming variable pibss " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 05/11] staging: rtl8723bs: renaming variable padapter " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 06/11] staging: rtl8723bs: renaming variable phtpriv " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 07/11] staging: rtl8723bs: renaming variable pregistrypriv " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` Dalvin-Ehinoma Noah Aiguobas [this message]
2026-07-31 10:41 ` [PATCH 09/11] staging: rtl8723bs: renaming variable bHwSTBCSupport " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 10/11] staging: rtl8723bs: renaming variable bHwSupportBeamformer " Dalvin-Ehinoma Noah Aiguobas
2026-07-31 10:41 ` [PATCH 11/11] staging: rtl8723bs: renaming variable bHwSupportBeamformee " Dalvin-Ehinoma Noah Aiguobas
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260731104134.12754-9-fliegbert2@gmail.com \
--to=fliegbert2@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox