From: Frank.Li@oss.nxp.com
To: "Jacky Huang" <ychuang3@nuvoton.com>,
"Shan-Chun Hung" <schung@nuvoton.com>,
"Vinod Koul" <vkoul@kernel.org>, "Frank Li" <Frank.Li@kernel.org>,
"Paul Cercueil" <paul@crapouillou.net>,
"Eugeniy Paltsev" <Eugeniy.Paltsev@synopsys.com>,
"Andy Shevchenko" <andriy.shevchenko@linux.intel.com>,
"Binbin Zhou" <zhoubinbin@loongson.cn>,
"Patrice Chotard" <patrice.chotard@foss.st.com>,
"Amélie Delaunay" <amelie.delaunay@foss.st.com>,
"Maxime Coquelin" <mcoquelin.stm32@gmail.com>,
"Alexandre Torgue" <alexandre.torgue@foss.st.com>,
"Steven Rostedt" <rostedt@goodmis.org>,
"Masami Hiramatsu" <mhiramat@kernel.org>,
"Mathieu Desnoyers" <mathieu.desnoyers@efficios.com>,
"Thierry Reding" <thierry.reding@kernel.org>,
"Jonathan Hunter" <jonathanh@nvidia.com>,
"Ludovic Desroches" <ludovic.desroches@microchip.com>,
"Viresh Kumar" <vireshk@kernel.org>,
"Keguang Zhang" <keguang.zhang@gmail.com>,
"Andreas Färber" <afaerber@suse.de>,
"Manivannan Sadhasivam" <mani@kernel.org>,
"Daniel Mack" <daniel@zonque.org>,
"Haojian Zhuang" <haojian.zhuang@gmail.com>,
"Robert Jarzmik" <robert.jarzmik@free.fr>,
"Chen-Yu Tsai" <wens@kernel.org>,
"Jernej Skrabec" <jernej.skrabec@gmail.com>,
"Samuel Holland" <samuel@sholland.org>,
"Kelvin Cao" <kelvin.cao@microchip.com>,
"Logan Gunthorpe" <logang@deltatee.com>,
"Laxman Dewangan" <ldewangan@nvidia.com>,
"Vignesh Raghavendra" <vigneshr@ti.com>
Cc: linux-arm-kernel@lists.infradead.org, dmaengine@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-mips@vger.kernel.org,
linux-stm32@st-md-mailman.stormreply.com,
linux-trace-kernel@vger.kernel.org, linux-tegra@vger.kernel.org,
linux-actions@lists.infradead.org, linux-sunxi@lists.linux.dev,
imx@lists.linux.dev, Frank Li <Frank.Li@nxp.com>
Subject: [PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
Date: Fri, 04 Sep 2026 17:49:42 -0400 [thread overview]
Message-ID: <20260904-dma-chan_dev-rename-v3-0-685601b0b788@nxp.com> (raw)
The current dma_chan structure contains both "device" and "dev". So
chan->device->dev refers to the DMA engine device.
chan->dev->device refers to the per-channel device instance.
Their similar naming makes the distinction unclear and increases reader
confusion.
Add union dma_chan::chan_dev to make its purpose explicit and clearly
identify it as the per-channel device. After all user switch to chan_dev,
union and dma_chan::dev will be removed.
Update the kernel-doc accordingly. Besides its sysfs usage, the per-channel
device is also used by some DMA engine drivers for IOMMU mapping and
therefore deserves a more accurate description.
1st patch add help vchan_chan_name()
2nd patch use existing helper dma_chan_name() to reduce rename difference.
3rd patch add (dmaengine|vchan)_chan_dev() helper
4th patch add union chan_dev for dma_chan::dev for clarity
Need following patch to clean other dma engineer driver, which is not
in drivers/dma
After complete all rename work, dma_chan::dev can be removed.
Signed-off-by: Frank Li <Frank.Li@nxp.com>
---
Changes in v3:
- add new helper function dmaengine_chan_dev() and vchan_chan_dev() to
make clear.
- some reduntant error message will be addressed by new patches.
- Link to v2: https://patch.msgid.link/20260903-dma-chan_dev-rename-v2-0-0db305b6c716@nxp.com
Changes in v2:
- rebase to dmaengine/next
- add vchan_chan_name() help function for vchan case.
- Link to v1: https://patch.msgid.link/20260812-dma-chan_dev-rename-v1-0-a67131f7d5c2@nxp.com
---
Frank Li (4):
dmaengine: vchan: add vchan_chan_name() to get channel device name
dmaengine: use dma_chan_name() helper to get per-channel device name
dmaengine: add (dmaengine|vchan)_chan_dev() helper
dmaengine: add union chan_dev for dma_chan::dev for clarity
drivers/dma/arm-dma350.c | 2 +-
drivers/dma/at_hdmac.c | 81 ++++++-------
drivers/dma/at_xdmac.c | 159 ++++++++++++-------------
drivers/dma/dma-jz4780.c | 10 +-
drivers/dma/dmaengine.c | 34 +++---
drivers/dma/dw-axi-dmac/dw-axi-dmac-platform.c | 38 +++---
drivers/dma/dw-axi-dmac/dw-axi-dmac.h | 10 --
drivers/dma/dw/core.c | 47 ++++----
drivers/dma/ep93xx_dma.c | 37 +++---
drivers/dma/idma64.c | 9 +-
drivers/dma/loongson/loongson1-apb-dma.c | 23 ++--
drivers/dma/loongson/loongson2-apb-cmc-dma.c | 17 +--
drivers/dma/loongson/loongson2-apb-dma.c | 9 +-
drivers/dma/mmp_pdma.c | 2 +-
drivers/dma/moxart-dma.c | 23 ++--
drivers/dma/nbpfaxi.c | 2 +-
drivers/dma/owl-dma.c | 21 ++--
drivers/dma/pch_dma.c | 41 +++----
drivers/dma/pxa_dma.c | 52 ++++----
drivers/dma/st_fdma.c | 2 +-
drivers/dma/ste_dma40.c | 15 +--
drivers/dma/stm32/stm32-dma.c | 69 +++++------
drivers/dma/stm32/stm32-dma3.c | 99 ++++++++-------
drivers/dma/stm32/stm32-mdma.c | 95 +++++++--------
drivers/dma/sun4i-dma.c | 17 +--
drivers/dma/sun6i-dma.c | 31 ++---
drivers/dma/switchtec_dma.c | 14 +--
drivers/dma/tegra186-gpc-dma.c | 4 +-
drivers/dma/tegra20-apb-dma.c | 2 +-
drivers/dma/ti/k3-udma.c | 6 +-
drivers/dma/timb_dma.c | 63 +++++-----
drivers/dma/txx9dmac.c | 73 ++++++------
drivers/dma/virt-dma.h | 16 +++
include/linux/dmaengine.h | 23 +++-
include/trace/events/tegra_apb_dma.h | 6 +-
35 files changed, 538 insertions(+), 614 deletions(-)
---
base-commit: 5c7962210474adbd9874227bc5096dbc11501d34
change-id: 20260812-dma-chan_dev-rename-66263ac5eac9
Best regards,
--
Frank Li <Frank.Li@nxp.com>
next reply other threads:[~2026-09-04 21:50 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-04 21:49 Frank.Li [this message]
2026-09-04 21:49 ` [PATCH v3 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name Frank.Li
2026-09-04 22:04 ` sashiko-bot
2026-09-04 21:49 ` [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel " Frank.Li
2026-09-04 21:58 ` sashiko-bot
2026-09-05 7:55 ` Andy Shevchenko
2026-09-04 21:49 ` [PATCH v3 3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper Frank.Li
2026-09-04 22:02 ` sashiko-bot
2026-09-04 21:49 ` [PATCH v3 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity Frank.Li
2026-09-04 22:01 ` sashiko-bot
2026-09-05 7:59 ` Andy Shevchenko
2026-09-05 8:00 ` [PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev " Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260904-dma-chan_dev-rename-v3-0-685601b0b788@nxp.com \
--to=frank.li@oss.nxp.com \
--cc=Eugeniy.Paltsev@synopsys.com \
--cc=Frank.Li@kernel.org \
--cc=Frank.Li@nxp.com \
--cc=afaerber@suse.de \
--cc=alexandre.torgue@foss.st.com \
--cc=amelie.delaunay@foss.st.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=daniel@zonque.org \
--cc=dmaengine@vger.kernel.org \
--cc=haojian.zhuang@gmail.com \
--cc=imx@lists.linux.dev \
--cc=jernej.skrabec@gmail.com \
--cc=jonathanh@nvidia.com \
--cc=keguang.zhang@gmail.com \
--cc=kelvin.cao@microchip.com \
--cc=ldewangan@nvidia.com \
--cc=linux-actions@lists.infradead.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mips@vger.kernel.org \
--cc=linux-stm32@st-md-mailman.stormreply.com \
--cc=linux-sunxi@lists.linux.dev \
--cc=linux-tegra@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=logang@deltatee.com \
--cc=ludovic.desroches@microchip.com \
--cc=mani@kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=mcoquelin.stm32@gmail.com \
--cc=mhiramat@kernel.org \
--cc=patrice.chotard@foss.st.com \
--cc=paul@crapouillou.net \
--cc=robert.jarzmik@free.fr \
--cc=rostedt@goodmis.org \
--cc=samuel@sholland.org \
--cc=schung@nuvoton.com \
--cc=thierry.reding@kernel.org \
--cc=vigneshr@ti.com \
--cc=vireshk@kernel.org \
--cc=vkoul@kernel.org \
--cc=wens@kernel.org \
--cc=ychuang3@nuvoton.com \
--cc=zhoubinbin@loongson.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox