Linux Trace Kernel
 help / color / mirror / Atom feed
 messages from 2026-07-08 06:31:33 to 2026-07-10 20:29:07 UTC [more...]

[PATCH v2 00/33] mm: make VMA page offset handling more consistent
 2026-07-10 20:17 UTC  (31+ messages)
` [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
` [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
` [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
` [PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
` [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
` [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
` [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
` [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
` [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
` [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
` [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
` [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
` [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
` [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
` [PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
` [PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
` [PATCH v2 17/33] mm: introduce and use linear_page_delta()
` [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
` [PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
` [PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
` [PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
` [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
` [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
` [PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
` [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
` [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
` [PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
` [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
` [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
` [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion

[PATCH 00/30] mm: make VMA page offset handling more consistent
 2026-07-10 20:25 UTC  (57+ messages)
` [PATCH 02/30] mm: add kdoc comments for vma_start/last_pgoff()
` [PATCH 06/30] mm/rmap: parameterise vma_interval_tree_*() by address_space
` [PATCH 13/30] mm/vma: refactor vmg_adjust_set_range() for clarity
` [PATCH 14/30] mm/vma: minor cleanup of expand_[upwards, downwards]()
` [PATCH 15/30] mm: introduce and use linear_page_delta()
` [PATCH 16/30] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
` [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
` [PATCH 18/30] mm/vma: remove duplicative vma_pgoff_offset() helper
` [PATCH 19/30] mm: use linear_page_[index, delta]() consistently
` [PATCH 20/30] mm/vma: introduce vma_assert_can_modify()
` [PATCH 21/30] mm/vma: add and use vma_[add/sub]_pgoff()
` [PATCH 22/30] mm/vma: move __install_special_mapping() to vma.c
` [PATCH 23/30] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
` [PATCH 24/30] mm/vma: update vma_shrink() to not pass unnecessary pgoff parameter
` [PATCH 25/30] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
` [PATCH 26/30] mm/vma: introduce and use vma_set_pgoff()
` [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
` [PATCH 28/30] mm/vma: use guard clauses in can_vma_merge_[before, after]()
` [PATCH 29/30] tools/testing/vma: default VMA flag bits to 64-bit

[RFC PATCH v4 0/3] trace: stack trace deduplication for ftrace ring buffer
 2026-07-10 19:14 UTC  (3+ messages)

[PATCH v2 0/2] Add trace event support for GENI SE registers dump
 2026-07-10 18:48 UTC  (3+ messages)
` [PATCH v2 1/2] soc: qcom: geni-se: trace: "
` [PATCH v2 2/2] spi: qcom-geni: add GENI SE registers trace event on error paths

[PATCH] tracing: Add "within" filter for call-stack-based event filtering
 2026-07-10 18:14 UTC  (3+ messages)

[PATCH 0/2] Add trace event support for GENI SE registers dump
 2026-07-10 17:59 UTC  (6+ messages)
` [PATCH 1/2] soc: qcom: geni-se: trace: "
` [PATCH 2/2] spi: qcom-geni: add GENI SE registers trace event on error paths

[PATCH v2] selftests/ftrace: fix spelling error in poll test comment
 2026-07-10 17:31 UTC  (3+ messages)

[PATCH v6 0/2] Add tracepoints support for Qualcomm GENI Serial drivers
 2026-07-10 17:12 UTC  (3+ messages)
` [PATCH v6 1/2] serial: qcom-geni: trace: Drop redundant len field from geni_serial_data
` [PATCH v6 2/2] serial: qcom-geni: Add tracepoints for Qualcomm GENI serial driver

[RFC PATCH 0/1] psi: Introduce in-kernel PSI auto monitor feature
 2026-07-10 16:01 UTC  (5+ messages)
` [RFC PATCH 1/1] "

[PATCH 0/2] arm64: ftrace: support DIRECT_CALLS without CALL_OPS
 2026-07-10 15:55 UTC  (3+ messages)

[PATCH v1 00/11] RCU: Enable callbacks to benefit from expedited grace periods
 2026-07-10 13:58 UTC  (15+ messages)
` [PATCH v1 01/11] rcu: Rename struct rcu_gp_oldstate to rcu_gp_seq
` [PATCH v1 02/11] rcu/segcblist: Add SRCU and Tasks RCU wrapper functions
` [PATCH v1 03/11] rcu/segcblist: Factor out rcu_segcblist_advance_compact() helper
` [PATCH v1 04/11] rcu/segcblist: Track segment grace periods with struct rcu_gp_seq
` [PATCH v1 05/11] rcu: Add RCU_GET_STATE_NOT_TRACKED for subsystems without expedited GPs
` [PATCH v1 06/11] rcu: Enable RCU callbacks to benefit from expedited grace periods

[PATCH] rtla/cli: Unify and improve range validation logic
 2026-07-10 13:15 UTC 

[PATCH v5 0/2] Add tracepoints support for Qualcomm GENI Serial drivers
 2026-07-10 12:41 UTC  (3+ messages)
` [PATCH v5 2/2] serial: qcom-geni: Add tracepoints for Qualcomm GENI serial driver

[PATCH v2 0/3] tracing/remotes: Fix leak in trace_remote_alloc_buffer() error path
 2026-07-10 12:37 UTC  (9+ messages)
` [PATCH v2 1/3] "
` [PATCH v2 2/3] tracing/remotes: Fix struct_len in trace_remote_alloc_buffer()
` [PATCH v2 3/3] ring-buffer: Allow sparse CPU masks in ring_buffer_desc()

[PATCH v2 1/2] module/kallsyms: fix nextval for data symbol lookup
 2026-07-10 12:36 UTC  (2+ messages)

[BUG] tracing: Too many tries to read user space
 2026-07-10 12:33 UTC  (6+ messages)

[RFC v3 0/2] rm64: kprobes: Fix single-step fault and reentry handling
 2026-07-10  9:38 UTC  (4+ messages)
` [RFC v3 1/2] arm64: kprobes: Only handle faults originating from XOL slot
` [RFC v3 2/2] arm64: kprobes: Allow reentering kprobes while single-stepping

[PATCH v3 00/17] rv: Add selftests to tools and KUnit tests
 2026-07-10  8:41 UTC  (16+ messages)
` [PATCH v3 06/17] verification/rvgen: Add selftests
` [PATCH v3 13/17] verification/rvgen: Add the rvgen kunit subcommand
` [PATCH v3 14/17] verification/rvgen: Add selftests for rvgen kunit
` [PATCH v3 15/17] selftests/verification: Fix wrong errexit assumption
` [PATCH v3 16/17] selftests/verification: Rearrange the wwnr_printk test

[PATCH 0/3] rv/reactors: fix lockdep warning and add KUnit tests
 2026-07-10  8:27 UTC  (14+ messages)
` [PATCH 1/3] rv/reactors: fix lockdep "Invalid wait context" in rv_react()
` [PATCH 2/3] rv/reactors: add KUnit tests for reactor_printk
` [PATCH 3/3] rv/reactors: add KUnit tests for reactor_panic

[RFC v2 0/3] arm64: kprobes: Fix single-step fault and reentry handling
 2026-07-10  6:13 UTC  (7+ messages)
` [RFC v2 1/3] arm64: kprobes: Only handle faults originating from XOL slot
` [RFC v2 2/3] arm64: kprobes: Allow reentering kprobes while single-stepping
` [RFC v2 3/3] arm64: kprobes: Save and restore saved_irqflag in prev_kprobe

[PATCH v2 0/5] tracing: add ref_trace_final_put tracing
 2026-07-10  5:30 UTC  (6+ messages)
` [PATCH v2 1/5] tracing: add ref_trace_final_put tracepoint
` [PATCH v2 2/5] refcount: "
` [PATCH v2 3/5] percpu-refcount: add ref_trace_final_put trace
` [PATCH v2 4/5] kunit: add test for ref_trace_final_put
` [PATCH v2 5/5] MAINTAINERS: add entries "

[PATCH v3 00/11] dma-buf: heaps: Add support for Tegra VPR
 2026-07-09 19:58 UTC  (24+ messages)
` [PATCH v3 01/11] dt-bindings: reserved-memory: Document "
` [PATCH v3 04/11] arm64/mm: Add set_memory_device() and set_memory_normal()
          ` Reserving memory on ACPI systems (was: [PATCH v3 04/11] arm64/mm: Add set_memory_device() and set_memory_normal())
  ` [PATCH v3 06/11] mm/cma: Allow dynamically creating CMA areas

[PATCH v2 0/4] mm: honour compact_unevictable_allowed in mlock and CMA paths
 2026-07-09 16:10 UTC  (18+ messages)
` [PATCH v2 1/4] mm/migrate: do not migrate folios mapped into VM_LOCKED VMAs under compaction
` [PATCH v2 2/4] mm/mlock: wait for migration to finish when mlocking a folio
` [PATCH v2 4/4] mm/mlock: migrate folios out of CMA when mlocking a range

[PATCH v1] tracing/remotes: Fix leak in trace_remote_alloc_buffer() error path
 2026-07-09 12:18 UTC  (3+ messages)

[PATCH] tracing: fprobe: Remove __packed from generic __fprobe_header
 2026-07-09 12:06 UTC  (5+ messages)

[PATCH] rtla/tests: Test all tracer options in runtime tests
 2026-07-09  9:17 UTC 

[PATCH] selftests/ftrace: Fix reading enabled_functions in add_remove_fprobe_module test
 2026-07-09  5:38 UTC  (2+ messages)

[PATCH] selftests/tracing: Have trigger-hist-poll.tc use sched_process_exit
 2026-07-09  4:58 UTC  (4+ messages)

[PATCH v10 0/6] mm/memory-failure: add panic option for unrecoverable pages
 2026-07-09  3:34 UTC  (5+ messages)
` [PATCH v10 5/6] Documentation: document panic_on_unrecoverable_memory_failure sysctl
` [PATCH v10 6/6] selftests/mm: add hwpoison-panic destructive test

[PATCH v4 0/8] rv/tlob: Add task latency over budget RV monitor
 2026-07-08 15:38 UTC  (9+ messages)
` [PATCH v4 1/8] rv/da: introduce DA_MON_ALLOCATION_STRATEGY
` [PATCH v4 2/8] rv: add generic uprobe infrastructure for RV monitors
` [PATCH v4 3/8] rv/tlob: add tlob model DOT file
` [PATCH v4 4/8] rv/ha: fix ha_invariant_passed_ns silent bypass of invariant check
` [PATCH v4 5/8] rv/ha: make da_monitor_reset_hook and EVENT_NONE_LBL overridable
` [PATCH v4 6/8] rv/tlob: add tlob hybrid automaton monitor
` [PATCH v4 7/8] rv/tlob: add KUnit tests for the tlob monitor
` [PATCH v4 8/8] selftests/verification: add tlob selftests

[RFC 0/2] arm64: kprobes: Fix single-step fault and reentry handling
 2026-07-08 14:12 UTC  (13+ messages)
` [RFC 0/3] "
  ` [RFC 1/3] arm64: kprobes: Do not handle non-XOL faults as kprobe faults
  ` [RFC 2/3] arm64: kprobes: Allow reentering kprobes while single-stepping

[GIT PULL] RTLA fixes for v7.2-rc3
 2026-07-08 11:24 UTC 

[PATCH v2] rtla: Simplify osnoise tracer option setting code
 2026-07-08  8:30 UTC 

[PATCH v4 RESEND 0/7] riscv: Add reliable stack unwinding for livepatch
 2026-07-08  8:21 UTC  (9+ messages)
` [PATCH v4 RESEND 1/7] riscv: stacktrace: Add frame record metadata
` [PATCH v4 RESEND 2/7] riscv: stacktrace: disable KASAN and KCOV instrumentation for stacktrace.o
` [PATCH v4 RESEND 4/7] riscv: stacktrace: introduce stack-bound tracking helpers
` [PATCH v4 RESEND 5/7] riscv: stacktrace: switch to frame-pointer based unwinder

[PATCH v2 0/4] trace_hyp_printk() for pKVM/nVHE hypervisor
 2026-07-08  7:54 UTC  (5+ messages)
` [PATCH v2 1/4] KVM: arm64: Allow early calls to pKVM host_share/unshare_hyp
` [PATCH v2 2/4] KVM: arm64: Move kvm_define_hypevents.h to arch/arm64/kvm/
` [PATCH v2 3/4] tracing/remotes: Add REMOTE_EVENT_CUSTOM_PRINTK() helper
` [PATCH v2 4/4] KVM: arm64: Add hyp_printk event to nVHE/pKVM hyp

[RFC PATCH 0/3] mm/compaction: honour compact_unevictable_allowed in mlock race and alloc_contig path
 2026-07-08  6:35 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox