Linux Trace Kernel
 help / color / mirror / Atom feed
 messages from 2026-09-03 05:50:20 to 2026-09-05 11:38:42 UTC [more...]

[PATCH 0/2] tracing: add ring-buffer memory usage statistics
 2026-09-05 11:38 UTC  (4+ messages)
` [PATCH 1/2] tracing: add ring-buffer memory usage statistics in tracefs
` [PATCH 2/2] tracing: add per-CPU "

[PATCH v3 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
 2026-09-05 11:27 UTC  (12+ messages)
` [PATCH v3 1/2] module: pull out add_taint_module() to be public
` [PATCH v3 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers

[PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
 2026-09-05  8:00 UTC  (12+ messages)
` [PATCH v3 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
` [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel "
` [PATCH v3 3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper
` [PATCH v3 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity

[RFC PATCH 00/20] rv: Add support for BPF monitors
 2026-09-05  4:53 UTC  (18+ messages)

[PATCH v2 0/3] Add telemetry tracepoints for CPU hogs, distress, and BH budget yields
 2026-09-04 19:34 UTC  (4+ messages)
` [PATCH v2 1/3] workqueue: Add workqueue_cpu_intensive tracepoint
` [PATCH v2 2/3] workqueue: Add workqueue_mayday and workqueue_rescued tracepoints
` [PATCH v2 3/3] workqueue: Add workqueue_bh_budget_yield tracepoint

[PATCH] ring-buffer: Use a macro for static buffer bits
 2026-09-04 19:16 UTC 

[PATCH] tracing: Fix comment in tracing_buffers_splice_read()
 2026-09-04 18:49 UTC 

[PATCH v10 0/4] ring-buffer: Fixes for subbuf resizing and persistent buffers
 2026-09-04 18:41 UTC  (12+ messages)
` [PATCH v10 1/4] ring-buffer: Allow splice reads on static buffers
` [PATCH v10 2/4] tracing: Fix subbuf resize races with trace_pipe_raw readers
` [PATCH v10 3/4] ring-buffer: Cap static ring buffer nr_pages
` [PATCH v10 4/4] ring-buffer: Prevent truncation of nr_pages / nr_subbufs

[PATCH v2 0/3] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
 2026-09-04 14:21 UTC  (15+ messages)
` [PATCH v2 1/3] dmaengine: vchan: add vchan_chan_name() to get channel device name
    ` [Linux-stm32] "
` [PATCH v2 2/3] dmaengine: use dma_chan_name() helper to get per-channel "
` [PATCH v2 3/3] dmaengine: add union chan_dev for dma_chan::dev for clarity

[PATCH 0/8] mm: introduce for_each_process_rcu and for_each_thread_rcu
 2026-09-04 14:14 UTC  (5+ messages)
` [PATCH 5/8] kernel: convert process/thread iterators to for_each_*_rcu

[PATCH v9 0/4] ring-buffer: Fixes for subbuf resizing and persistent buffers
 2026-09-04 14:02 UTC  (20+ messages)
` [PATCH v9 1/4] ring-buffer: Allow splice reads on static buffers
` [PATCH v9 2/4] tracing: Fix subbuf resize races with trace_pipe_raw readers
` [PATCH v9 3/4] ring-buffer: Cap static ring buffer nr_pages
` [PATCH v9 4/4] ring-buffer: Prevent truncation of nr_pages / nr_subbufs

[PATCH v2 00/12] I2C - detailed transfer reporting in case of a fault
 2026-09-04 10:53 UTC  (18+ messages)
` [PATCH v2 01/12] i2c: core: add I2C_XFER_V2 - support for detailed transfer reporting
` [PATCH v2 03/12] i2c: nomadik: do not try to retransmit I2C message series on errors
` [PATCH v2 05/12] i2c: nomadik: change print level for fault messages to debug
` [PATCH v2 07/12] i2c: nomadik: add support for I2C_XFER_V2 - detailed fault reporting
` [PATCH v2 09/12] i2c: designware: no SMBUS_READ_BLOCK_DATA without EMPTYFIFO_HOLD_MASTER
` [PATCH v2 11/12] i2c: designware: use separate `i2c_algorithm` for AMD_NAVI_GPU
` [PATCH v2 12/12] i2c: designware: add support for I2C_XFER_V2 - detailed fault reporting

[PATCH RFC 0/8] arm64: ftrace: support CALL_OPS on kernels built with kCFI
 2026-09-04 12:47 UTC  (14+ messages)
` [PATCH RFC 1/8] ftrace: Let ftrace_call_adjust() reject a patch site
` [PATCH RFC 2/8] scripts/sorttable: Make the arm64 before_func offset configurable
` [PATCH RFC 3/8] compiler_types: Let notrace keep the function prefix NOPs
` [PATCH RFC 4/8] arm64: ftrace: Make the CALL_OPS prefix layout configurable
` [PATCH RFC 5/8] arm64: cfi: Use CONFIG_ARM64_FUNCTION_PREFIX_NOPS for the type hash offset
` [PATCH RFC 6/8] arm64: ftrace: Support CALL_OPS on kernels built with kCFI
` [PATCH RFC 7/8] arm64: ftrace: Use five prefix NOPs on ThinLTO kernels with BTI
` [PATCH RFC 8/8] arm64: ftrace: Allow CALL_OPS on kCFI kernels built with Rust

[PATCH] x86/kprobe: Fix crash when probe cs call
 2026-09-04 12:41 UTC 

[PATCH] tracing/user_events: Don't destroy fields when event removal fails
 2026-09-04 12:12 UTC  (5+ messages)
    ` [PATCH v2] "

[PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
 2026-09-04 11:54 UTC  (26+ messages)
` [PATCH v6 01/12] dt-bindings: reserved-memory: Document "
` [PATCH v6 02/12] dt-bindings: display: tegra: Document memory regions
` [PATCH v6 03/12] dt-bindings: gpu: host1x: Document memory-regions for NVDEC
` [PATCH v6 04/12] arm64/mm: Export set_direct_map_*_noflush() APIs
` [PATCH v6 05/12] bitmap: Add bitmap_allocate() function
` [PATCH v6 06/12] of: Export of_node_to_nid()
` [PATCH v6 07/12] mm/cma: Introduce cma_alloc_at() API
` [PATCH v6 08/12] dma-buf: heaps: Add debugfs support
` [PATCH v6 09/12] dma-buf: heaps: Add support for Tegra VPR
` [PATCH v6 10/12] arm64: tegra: Add VPR placeholder node on Tegra234
` [PATCH v6 11/12] arm64: tegra: Hook up VPR to host1x
` [PATCH v6 12/12] arm64: tegra: Add VPR placeholder node on Tegra264

[PATCH] rtla: Simplify osnoise tracer option setting code
 2026-09-04  9:03 UTC  (5+ messages)

[PATCH v3] rtla: Simplify osnoise tracer option setting code
 2026-09-04  8:55 UTC 

[PATCH v5 0/3] Use BTF to trim return values
 2026-09-04  1:34 UTC  (9+ messages)

[PATCH v2] ftrace: Synchronize the initialization of ftrace_ops
 2026-09-04  0:47 UTC  (2+ messages)

[PATCH v3] bootconfig: Skip printing early params to cmdline from bootconfig
 2026-09-04  0:26 UTC  (2+ messages)
` Kernel parameter collision/duplicate behavior (Re: [PATCH v3] bootconfig: Skip printing early params to cmdline from bootconfig)

[PATCH] tracing: Fix to avoid creating trace instances with duplicate names
 2026-09-03 23:25 UTC 

[PATCH] blktrace: always record ftrace events as blk_io_trace2
 2026-09-03 20:29 UTC 

[PATCH] ftrace: Add checking nr_subbufs to persistent ring buffer validation
 2026-09-03 18:25 UTC  (5+ messages)

[PATCH v2] Documentation: trace: histogram-design: fix bracket, improve wording
 2026-09-03 18:14 UTC  (4+ messages)

STABLE REQ: [PATCH v5 06/10] tracing: Fix subbuf resize races with trace_pipe_raw readers
 2026-09-03 16:13 UTC  (6+ messages)
      ` STABLE REQ: [PATCH v5 06/10] tracing: Fix subbuf resize races with trace_pipe_raw readers\

[PATCH v2 00/14] Remove PG_private by using page/folio->private checks instead
 2026-09-03 16:10 UTC  (2+ messages)
` [f2fs-dev] "

[PATCH RFC 00/14] Remove PG_private by using page/folio->private checks instead
 2026-09-03 16:10 UTC  (2+ messages)
` [f2fs-dev] "

[RFC PATCH v6 0/3] trace: stack trace deduplication for ftrace ring buffer
 2026-09-03 13:24 UTC  (4+ messages)
` [RFC PATCH v6 1/3] trace: add lock-free stackmap for stack trace deduplication
` [RFC PATCH v6 2/3] trace: integrate stackmap into ftrace stack recording path
` [RFC PATCH v6 3/3] trace: add documentation, selftest and tooling for stackmap

[RFC PATCH v5 0/3] trace: stack trace deduplication for ftrace ring buffer
 2026-09-03 13:22 UTC  (10+ messages)
` [RFC PATCH v5 1/3] trace: add lock-free stackmap for stack trace deduplication
` [RFC PATCH v5 2/3] trace: integrate stackmap into ftrace stack recording path
` [RFC PATCH v5 3/3] trace: add documentation, selftest and tooling for stackmap

[PATCH v2 0/8] mm: distinguish PTE table storage from PTE values
 2026-09-03 10:48 UTC  (17+ messages)
` [PATCH v2 1/8] mm: introduce hw_pte_t for PTE table storage
` [PATCH v2 2/8] mm: rename pointers to software PTE values as ptentp
` [PATCH v2 3/8] mm: use hw_pte_t for generic PTE table storage
` [PATCH v2 4/8] mm: convert PTE table entries in ptep_get()
` [PATCH v2 5/8] mm: convert PTE table entry to pte
` [PATCH v2 6/8] mm/kasan: use hw_pte_t for the early shadow PTE table
` [PATCH v2 7/8] drm/i915: use hw_pte_t for PTE range callbacks
` [PATCH v2 8/8] xen: "

STABLE REQ: [PATCH v5 06/10] tracing: Fix subbuf resize races with trace_pipe_raw readers
 2026-09-03  8:38 UTC  (11+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox