messages from 2026-09-04 12:46:41 to 2026-09-07 21:55:08 UTC [more...]
[PATCH v2 0/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
2026-09-07 21:54 UTC (38+ messages)
` [PATCH v2 1/8] "
` [PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
` [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
` [PATCH v2 4/8] mm/memory-failure: "
` [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
` [PATCH v2 6/8] fs: "
` [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
` [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
[PATCH 0/2] tracing: hist: two named trigger error paths that free a published trigger
2026-09-07 21:01 UTC (8+ messages)
` [PATCH 1/2] tracing: hist: take the reference before publishing the named trigger
` [PATCH 2/2] tracing: hist: undo the registration when enabling the trigger fails
[PATCH v1 0/2] ring-buffer: Fix and unify size and page calculations
2026-09-07 19:42 UTC (5+ messages)
` [PATCH v1 1/2] tracing/remotes: Account for ring buffer page header in size calculation
` [PATCH v1 2/2] ring-buffer: Unify ring buffer minimum page calculations
[PATCH RFC 0/8] arm64: ftrace: support CALL_OPS on kernels built with kCFI
2026-09-07 19:33 UTC (8+ messages)
` [PATCH RFC 1/8] ftrace: Let ftrace_call_adjust() reject a patch site
` [PATCH RFC 8/8] arm64: ftrace: Allow CALL_OPS on kCFI kernels built with Rust
[RFC PATCH v2 00/24] unwind_user: Implement .eh_frame handling
2026-09-07 19:17 UTC (2+ messages)
[syzbot] [trace?] WARNING in ring_buffer_map_get_reader (3)
2026-09-07 17:57 UTC (2+ messages)
[PATCH] tracing/user_events: Don't destroy fields when event removal fails
2026-09-07 16:45 UTC (3+ messages)
` [PATCH v2] "
[PATCH v2 5.15/6.1/6.6 0/2] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
2026-09-07 16:39 UTC (3+ messages)
` [PATCH v2 5.15/6.1/6.6 1/2] tracing/mmiotrace: Remove reference to unused per CPU data pointer
` [PATCH v2 5.15/6.1/6.6 2/2] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
[PATCH v1] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
2026-09-07 16:39 UTC (5+ messages)
[PATCH 0/2] tracing: fix two histogram stacktrace keys that corrupt memory
2026-09-07 15:50 UTC (3+ messages)
` [PATCH 1/2] tracing: Fix memory corruption from the stacktrace modifier
` [PATCH 2/2] tracing: Fix memory corruption from a "STACKTRACE" histogram key
[PATCH] tracing: hist: keep the entry count when the stats allocation fails
2026-09-07 14:46 UTC (2+ messages)
[PATCH] tracing: hist: set the trace clock before registering the trigger
2026-09-07 12:44 UTC (3+ messages)
[PATCH v2] dma-mapping: don't trace the DMA address when the allocation fails
2026-09-07 12:01 UTC
[PATCH 0/2] tracing: add ring-buffer memory usage statistics
2026-09-07 9:26 UTC (5+ messages)
` [PATCH 1/2] tracing: add ring-buffer memory usage statistics in tracefs
` [PATCH 2/2] tracing: add per-CPU "
[BUG?] tracing: unexpected behavior trying to keep IRQ code away from traces
2026-09-07 9:07 UTC
[PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
2026-09-07 9:01 UTC (15+ messages)
` [PATCH v3 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
` [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel "
` [PATCH v3 3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper
` [PATCH v3 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity
[PATCH 08/14] tracing: fix typo "preceeded" in comment
2026-09-07 6:56 UTC
[PATCH] tracing: fix typo "availabe" in comment
2026-09-07 6:26 UTC
[PATCH] tracing: hist: let values keep the percent and graph modifiers
2026-09-07 6:06 UTC (3+ messages)
[PATCH RFC 0/2] mm/mglru: add tracepoints for aging and isolation
2026-09-07 4:24 UTC (3+ messages)
` [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
` [PATCH RFC 2/2] mm/mglru: add tracepoint for inc_max_seq
[PATCH] tracing: hist: free the field rejected for a bad modifier
2026-09-07 4:20 UTC (3+ messages)
[PATCH v15 00/12] tracing: wprobe: x86: Add wprobe for watchpoint
2026-09-07 4:15 UTC (25+ messages)
` [PATCH v15 01/12] x86/mce: Fix hardware debug register corruption on task migration
` [PATCH v15 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
` [PATCH v15 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
` [PATCH v15 04/12] HWBP: Add modify_local_hw_breakpoint_addr() API
` [PATCH v15 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
` [PATCH v15 06/12] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
` [PATCH v15 07/12] selftests: tracing: Add a basic testcase for wprobe
` [PATCH v15 08/12] selftests: tracing: Add syntax "
` [PATCH v15 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
` [PATCH v15 10/12] selftests: tracing: Add wprobe trigger testcase
` [PATCH v15 11/12] tracing/wprobe: Support BTF typecast in fetchargs
` [PATCH v15 12/12] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
[PATCH v5 0/5] rv/reactors: fix lockdep warning and add tests
2026-09-06 17:23 UTC (9+ messages)
` [PATCH v5 1/5] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
` [PATCH v5 2/5] rv/reactors: propagate rv_register_reactor() error from reactor init
` [PATCH v5 3/5] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
` [PATCH v5 4/5] rv/reactors: add KUnit tests for reactor registration and dispatch
` [PATCH v5 5/5] selftests/verification: Test loadable module-based reactor
[PATCH v14 00/14] tracing: wprobe: x86: Add wprobe for watchpoint
2026-09-06 15:50 UTC (16+ messages)
` [PATCH v14 01/14] x86/mce: Fix hardware debug register corruption on task migration
` [PATCH v14 04/14] x86/hw_breakpoints: Make DR7 updates NMI safe
` [PATCH v14 05/14] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
` [PATCH v14 06/14] HWBP: Add modify_local_hw_breakpoint_addr() API
` [PATCH v14 11/14] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
[PATCH] tracing: hist: free the var ref when its initialization fails
2026-09-06 13:51 UTC (3+ messages)
[PATCH] tracing: hist: free var refs regardless of how often they are referenced
2026-09-06 13:34 UTC (3+ messages)
[PATCH] function_graph: Use the saved entry's size when reprinting it
2026-09-06 6:59 UTC (3+ messages)
[PATCH] fgraph: Remove unused FGRAPH_MAX_INDEX
2026-09-06 2:22 UTC (2+ messages)
[PATCH v2 0/3] Add telemetry tracepoints for CPU hogs, distress, and BH budget yields
2026-09-05 23:05 UTC (6+ messages)
` [PATCH v2 1/3] workqueue: Add workqueue_cpu_intensive tracepoint
` [PATCH v2 2/3] workqueue: Add workqueue_mayday and workqueue_rescued tracepoints
` [PATCH v2 3/3] workqueue: Add workqueue_bh_budget_yield tracepoint
[PATCH] bootconfig: remove unreachable index checks in xbc_verify_tree()
2026-09-05 14:16 UTC
[PATCH] ring-buffer: Use a macro for static buffer bits
2026-09-05 13:06 UTC (2+ messages)
[PATCH] tracing: Fix comment in tracing_buffers_splice_read()
2026-09-05 13:04 UTC (2+ messages)
[PATCH v3 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
2026-09-05 12:51 UTC (8+ messages)
` [PATCH v3 1/2] module: pull out add_taint_module() to be public
[RFC PATCH 00/20] rv: Add support for BPF monitors
2026-09-05 4:53 UTC (17+ messages)
[PATCH v10 0/4] ring-buffer: Fixes for subbuf resizing and persistent buffers
2026-09-04 18:41 UTC (12+ messages)
` [PATCH v10 1/4] ring-buffer: Allow splice reads on static buffers
` [PATCH v10 2/4] tracing: Fix subbuf resize races with trace_pipe_raw readers
` [PATCH v10 3/4] ring-buffer: Cap static ring buffer nr_pages
` [PATCH v10 4/4] ring-buffer: Prevent truncation of nr_pages / nr_subbufs
[PATCH v2 0/3] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
2026-09-04 14:21 UTC (5+ messages)
` [PATCH v2 1/3] dmaengine: vchan: add vchan_chan_name() to get channel device name
` [Linux-stm32] "
[PATCH 0/8] mm: introduce for_each_process_rcu and for_each_thread_rcu
2026-09-04 14:14 UTC (3+ messages)
` [PATCH 5/8] kernel: convert process/thread iterators to for_each_*_rcu
[PATCH v9 0/4] ring-buffer: Fixes for subbuf resizing and persistent buffers
2026-09-04 14:02 UTC (5+ messages)
` [PATCH v9 3/4] ring-buffer: Cap static ring buffer nr_pages
[PATCH v2 00/12] I2C - detailed transfer reporting in case of a fault
2026-09-04 10:53 UTC (4+ messages)
` [PATCH v2 01/12] i2c: core: add I2C_XFER_V2 - support for detailed transfer reporting
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox