messages from 2026-09-06 21:25:05 to 2026-09-08 20:17:13 UTC [more...]
[PATCH 00/39] mm: make VMA flag semantics explicit, eliminate VM_SPECIAL
2026-09-08 20:01 UTC (32+ messages)
` [PATCH 01/39] mm/vma: predicate setting mmap_prepare VMA fields on new vma alloc
` [PATCH 02/39] mm/vma: introduce and use vma_[flags_]can_merge()
` [PATCH 03/39] mm: consistently validate VMA state after mmap[_prepare] hooks
` [PATCH 04/39] mm/vma: ensure mmap_prepare doesn't set actions on a mergeable vma
` [PATCH 05/39] mm: make map_kernel_pages_[prepare,complete] internal and unexported
` [PATCH 06/39] mm/vma: tidy up map kernel pages enum values
` [PATCH 07/39] mm: add mmap action for discontiguous kernel page mapping
` [PATCH 08/39] docs: filesystems: update mmap_prepare docs for discontig kernel pgs
` [PATCH 09/39] drivers/usb/mon: update to use mmap_prepare + map kernel pages
` [PATCH 10/39] infiniband: update hfi1 to use remap_vmalloc_range()
` [PATCH 11/39] selinux: reject writable opens of policy file, drop mmap shared/write check
` [PATCH 12/39] ALSA: pcm: use vm_insert_page() to map PCM status page
` [PATCH 13/39] bpf: arena: mark arena_map_mmap() mappings VM_MIXEDMAP
` [PATCH 14/39] mm/vma: add vma[_flags]_is_kernel_owned() predicates
` [PATCH 15/39] mm/vma: only allow mmap to clear VMA_MAYWRITE_BIT if kernel-owned
` [PATCH 16/39] mm/vma: add and use vma_[flags]_is_fixed_mapping
` [PATCH 17/39] scsi: sg: convert mmap hook to mmap_prepare and rework
` [PATCH 18/39] fbdev: defio: assert FBINFO_VIRTFB, drop VM_IO, add VM_MIXEDMAP
` [PATCH 19/39] HSI: cmt_speech: convert mmap hook to mmap_prepare, refactor
` [PATCH 20/39] mm/gup: error out early on !VMA_MAYREAD_BIT VMAs
` [PATCH 21/39] uprobes: remove VM_IO, set VM_MIXEDMAP for mapped kernel pages
` [PATCH 22/39] mm/mlock: clear VMA_LOCKED_MASK over mmap callback
` [PATCH 23/39] mm/mlock: eliminate weird VMA_IO_BIT abuse and simplify
` [PATCH 24/39] mm/vma: enforce that only kernel-owned mappings may set VMA_IO_BIT
` [PATCH 25/39] mm: remove VMA_IO_BIT check in vma[_flags]_is_kernel_owned()
` [PATCH 26/39] mm: remove hugetlb_inline.h
` [PATCH 27/39] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
` [PATCH 28/39] mm: drop some redundant checks around hugetlb VMAs
` [PATCH 29/39] mm/madvise: update is_valid_guard_vma() to use vma_can_merge()
` [PATCH 30/39] mm/vma: introduce vma[_flags]_is_persistent()
` [PATCH 31/39] mm/uffd: use predicates for userfaultfd checks
[PATCH v3 00/14] Remove PG_private by using page/folio->private checks instead
2026-09-08 17:22 UTC (7+ messages)
` [PATCH v3 09/14] mm/page-flags: check page/folio->private instead of PG_private
` [PATCH v3 10/14] mm/page-flags: introduce folio_test_fs_private()
` [PATCH v3 14/14] mm/page-flags: remove PG_private
[PATCH] bootconfig: merge _xbc_exit() into xbc_exit()
2026-09-08 16:57 UTC
[BUG?] tracing: unexpected behavior trying to keep IRQ code away from traces
2026-09-08 16:05 UTC (2+ messages)
[PATCH] bootconfig: remove unreachable index checks in xbc_verify_tree()
2026-09-08 15:34 UTC (3+ messages)
[PATCH v2] kprobes: use DEFINE_DEBUGFS_ATTRIBUTE for the enabled knob
2026-09-08 15:19 UTC (8+ messages)
[PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
2026-09-08 14:59 UTC (13+ messages)
` [PATCH v6 06/12] of: Export of_node_to_nid()
` [PATCH v6 09/12] dma-buf: heaps: Add support for Tegra VPR
` [PATCH v6 07/12] mm/cma: Introduce cma_alloc_at() API
[PATCH RFC 0/8] arm64: ftrace: support CALL_OPS on kernels built with kCFI
2026-09-08 13:52 UTC (9+ messages)
` [PATCH RFC 1/8] ftrace: Let ftrace_call_adjust() reject a patch site
` [PATCH RFC 8/8] arm64: ftrace: Allow CALL_OPS on kCFI kernels built with Rust
[PATCH] ring-buffer: Add a MAINTAINERS category specific for the tracing ring-buffer
2026-09-08 13:40 UTC
[PATCH 0/2] ftrace/selftests: Fix registering kprobe on non-unique symbol
2026-09-08 12:46 UTC (2+ messages)
[PATCH v2] dma-mapping: don't trace the DMA address when the allocation fails
2026-09-08 11:54 UTC (2+ messages)
[PATCH v2 0/3] tracing: Rename to "capacity"
2026-09-08 9:09 UTC (4+ messages)
` [PATCH v2 1/3] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
` [PATCH v2 2/3] tracing: Rename trace_array::entries to capacity
` [PATCH v2 3/3] tracing: Rename tracing_entries_fops to tracing_capacity_fops
[syzbot] [trace?] WARNING in trace_rb_cpu_prepare
2026-09-08 7:56 UTC (2+ messages)
[PATCH v2 0/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
2026-09-08 7:51 UTC (45+ messages)
` [PATCH v2 1/8] "
` [PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
` [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
` [PATCH v2 4/8] mm/memory-failure: "
` [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
` [PATCH v2 6/8] fs: "
` [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
` [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
[PATCH v2 0/7] tracing: Parse filter from boot event string
2026-09-08 6:35 UTC (9+ messages)
` [PATCH v2 1/7] tracing: Restore :mod: trailer after parsing in ftrace_set_clr_event()
` [PATCH v2 2/7] tracing: Remove duplicate declaration of ftrace_set_clr_event()
` [PATCH v2 3/7] tracing: Stop modifying the input buffer in ftrace_set_clr_event()
` [PATCH v2 4/7] tracing: Split the event string parsing logic into a dedicated function
` [PATCH v2 5/7] tracing: Add a test for ftrace_parse_event_string()
` [PATCH v2 6/7] tracing: Add a filter argument to __ftrace_set_clr_event()
` [PATCH v2 7/7] tracing: Parse filter from boot event string
[PATCH v2] tracing: export live module tracepoint strings in printk_formats
2026-09-08 5:18 UTC (3+ messages)
` [PATCH v3] tracing: Export "
[RFC PATCH v6 0/3] trace: stack trace deduplication for ftrace ring buffer
2026-09-08 3:09 UTC (9+ messages)
` [RFC PATCH v6 1/3] trace: add lock-free stackmap for stack trace deduplication
` [RFC PATCH v6 3/3] trace: add documentation, selftest and tooling for stackmap
[PATCH v2 5.15/6.1/6.6 0/2] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
2026-09-08 0:53 UTC (4+ messages)
` [PATCH v2 5.15/6.1/6.6 1/2] tracing/mmiotrace: Remove reference to unused per CPU data pointer
` [PATCH v2 5.15/6.1/6.6 2/2] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
[PATCH 0/2] tracing: hist: two named trigger error paths that free a published trigger
2026-09-07 21:01 UTC (8+ messages)
` [PATCH 1/2] tracing: hist: take the reference before publishing the named trigger
` [PATCH 2/2] tracing: hist: undo the registration when enabling the trigger fails
[PATCH v1 0/2] ring-buffer: Fix and unify size and page calculations
2026-09-07 19:42 UTC (5+ messages)
` [PATCH v1 1/2] tracing/remotes: Account for ring buffer page header in size calculation
` [PATCH v1 2/2] ring-buffer: Unify ring buffer minimum page calculations
[RFC PATCH v2 00/24] unwind_user: Implement .eh_frame handling
2026-09-07 19:17 UTC (2+ messages)
[syzbot] [trace?] WARNING in ring_buffer_map_get_reader (3)
2026-09-07 17:57 UTC (2+ messages)
[PATCH] tracing/user_events: Don't destroy fields when event removal fails
2026-09-07 16:45 UTC (3+ messages)
` [PATCH v2] "
[PATCH v1] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
2026-09-07 16:39 UTC (5+ messages)
[PATCH 0/2] tracing: fix two histogram stacktrace keys that corrupt memory
2026-09-07 15:50 UTC (3+ messages)
` [PATCH 1/2] tracing: Fix memory corruption from the stacktrace modifier
` [PATCH 2/2] tracing: Fix memory corruption from a "STACKTRACE" histogram key
[PATCH] tracing: hist: keep the entry count when the stats allocation fails
2026-09-07 14:46 UTC (2+ messages)
[PATCH] tracing: hist: set the trace clock before registering the trigger
2026-09-07 12:44 UTC (3+ messages)
[PATCH 0/2] tracing: add ring-buffer memory usage statistics
2026-09-07 9:26 UTC (3+ messages)
` [PATCH 1/2] tracing: add ring-buffer memory usage statistics in tracefs
[PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
2026-09-07 9:01 UTC (7+ messages)
` [PATCH v3 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
` [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel "
` [PATCH v3 3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper
[PATCH 08/14] tracing: fix typo "preceeded" in comment
2026-09-07 6:56 UTC
[PATCH] tracing: fix typo "availabe" in comment
2026-09-07 6:26 UTC
[PATCH] tracing: hist: let values keep the percent and graph modifiers
2026-09-07 6:06 UTC (3+ messages)
[PATCH RFC 0/2] mm/mglru: add tracepoints for aging and isolation
2026-09-07 4:24 UTC (3+ messages)
` [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
` [PATCH RFC 2/2] mm/mglru: add tracepoint for inc_max_seq
[PATCH] tracing: hist: free the field rejected for a bad modifier
2026-09-07 4:20 UTC (3+ messages)
[PATCH v15 00/12] tracing: wprobe: x86: Add wprobe for watchpoint
2026-09-07 4:15 UTC (25+ messages)
` [PATCH v15 01/12] x86/mce: Fix hardware debug register corruption on task migration
` [PATCH v15 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
` [PATCH v15 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
` [PATCH v15 04/12] HWBP: Add modify_local_hw_breakpoint_addr() API
` [PATCH v15 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
` [PATCH v15 06/12] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
` [PATCH v15 07/12] selftests: tracing: Add a basic testcase for wprobe
` [PATCH v15 08/12] selftests: tracing: Add syntax "
` [PATCH v15 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
` [PATCH v15 10/12] selftests: tracing: Add wprobe trigger testcase
` [PATCH v15 11/12] tracing/wprobe: Support BTF typecast in fetchargs
` [PATCH v15 12/12] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox