linux-um.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Blaisorblade <blaisorblade@yahoo.it>
To: user-mode-linux-devel@lists.sourceforge.net
Cc: Al Viro <viro@ftp.linux.org.uk>,
	Antoine Martin <antoine@nagafix.co.uk>,
	Al Viro <viro@zeniv.linux.org.uk>, Jeff Dike <jdike@addtoit.com>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [uml-devel] Re: [PATCH 12/12] HPPFS: fix nameidata handling
Date: Wed, 21 Sep 2005 18:34:11 +0200	[thread overview]
Message-ID: <200509211834.12345.blaisorblade@yahoo.it> (raw)
In-Reply-To: <20050921035455.GY7992@ftp.linux.org.uk>

On Wednesday 21 September 2005 05:54, Al Viro wrote:
> On Sun, Sep 18, 2005 at 04:10:09PM +0200, Paolo 'Blaisorblade' Giarrusso 
wrote:
> > From: Paolo 'Blaisorblade' Giarrusso <blaisorblade@yahoo.it>

> > In follow_link, we call the underlying method with the same nameidata we
> > got - it will then call path_release() and then dput()/mntput() on hppfs
> > dentries / vfsmount rather than his own, which could be problematic (I'm
> > not really sure, however).

> Don't bother with that, procfs doesn't and will not care anyway.  It _is_
> legal to pass NULL as nd,
Where? At least not in proc_follow_link, I don't know for the rest. 

I'm now seeing lookup_one_len doing exactly that. But still, could these 
conventions be documented, as they're surely untrivial to guess?

> so you've actually introduced breakage here. 
> Just pass NULL and be done with that.

> > @@ -213,11 +240,20 @@ static struct dentry *hppfs_lookup(struc
> >  	} else {
> >  		up(&parent->d_inode->i_sem);
> >  		if (proc_dentry->d_op && proc_dentry->d_op->d_revalidate) {
> > -			if (!proc_dentry->d_op->d_revalidate(proc_dentry, NULL) &&
> > +			sav_dentry = nd->dentry;
> > +			sav_mnt = nd->mnt;
> > +
> > +			nd->dentry = dget(proc_dentry);
> > +			nd->mnt = mntget(proc_submnt);
> > +			if (!proc_dentry->d_op->d_revalidate(proc_dentry, nd) &&
> >  					!d_invalidate(proc_dentry)) {
> >  				dput(proc_dentry);
> >  				proc_dentry = ERR_PTR(-ENOENT);
> >  			}
> > +			path_release(nd);
> > +
> > +			nd->dentry = sav_dentry;
> > +			nd->mnt = sav_mnt;
> >  		}
> >  	}

> Shouldn't be there at all (use lookup_one_len() instead of open-coding it)


> >  static struct inode_operations hppfs_file_iops = {
> > @@ -794,6 +846,9 @@ static int hppfs_readlink(struct dentry
> >
> >  static void* hppfs_follow_link(struct dentry *dentry, struct nameidata
> > *nd) {
> > +	struct dentry *sav_dentry;
> > +	struct vfsmount *sav_mnt;
> > +
[...]
> And this is absolutely bogus.  The whole point of ->follow_link() is to
> move where your nameidata points to.  So no, you do _not_ want to flip
> nameidata, you do not want to drop it and you certainly do not want
> to flip it back.  Just call the underlying one.
But wouldn't the callee expect that nd->dentry is the same thing which I pass?

Yes, nameidata has other fields too, but is ->dentry meant to be unused here?
Not surely.

And especially, how would proc_pid_follow_link()'s path_release() call handle 
that?

I've been suspicious that, indeed, recursive lookup holds a ref on each 
pathname component dentry, and that proc, in that case, knows it can do 
without.

-- 
Inform me of my mistakes, so I can keep imitating Homer Simpson's "Doh!".
Paolo Giarrusso, aka Blaisorblade (Skype ID "PaoloGiarrusso", ICQ 215621894)
http://www.user-mode-linux.org/~blaisorblade

	

	
		
___________________________________ 
Yahoo! Mail: gratis 1GB per i messaggi e allegati da 10MB 
http://mail.yahoo.it



-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
User-mode-linux-devel mailing list
User-mode-linux-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/user-mode-linux-devel

  reply	other threads:[~2005-09-21 16:35 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-09-18 14:10 [uml-devel] [PATCH 12/12] HPPFS: fix nameidata handling Paolo 'Blaisorblade' Giarrusso
2005-09-21  3:54 ` [uml-devel] " Al Viro
2005-09-21 16:34   ` Blaisorblade [this message]
2005-09-21 17:23     ` Al Viro

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200509211834.12345.blaisorblade@yahoo.it \
    --to=blaisorblade@yahoo.it \
    --cc=antoine@nagafix.co.uk \
    --cc=jdike@addtoit.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=user-mode-linux-devel@lists.sourceforge.net \
    --cc=viro@ftp.linux.org.uk \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).