From: Jeff Dike <jdike@addtoit.com>
To: user-mode-linux-devel@lists.sourceforge.net
Subject: [uml-devel] Re: Why uml-add-tls-support-debug-check-never-works is needed
Date: Fri, 24 Mar 2006 22:18:38 -0500 [thread overview]
Message-ID: <20060325031838.GA8539@ccure.user-mode-linux.org> (raw)
On Sat, Mar 25, 2006 at 12:28:09AM +0100, Blaisorblade wrote:
> BUT, this context switch at the thread born is special: the thread being
> switched away switches to a new thread not in the body of the new thread's
> call to switch_to_skas->switch_threads(), but in the body of thread_wait()!
> At that point, we lose the call to arch_switch_to_skas()!
Yuck yuck yuck. Nice spotting.
There's an obvious one-line fix for this, but I wonder if we ought to
try some restructuring to avoid this sort of thing in the future.
> Questions and notes:
>
> *) Why does arch/um/os-Linux/skas/process.c has still one siglongjmp() call
> and sigjmp_buf vars, and that has no comments?
I'm tempted to say that I just missed the call somehow. I see no
reason for that to be different, especially since it's preceded by a
UML_SIGSETJMP. As for the sigjmp_buf variables, I don't get your
point. Those haven't changed.
> *) Also, why thread_wait and thread_switch are almost identical, yet they're
> two different functions?
switch_threads? In order to merge them, you'd have to pass in the 1
and the INIT_JMP_REMOVE_SIGSTACK, which I have conceptual problems
with. First, that makes the callers know things that they probably
shouldn't. Second, the 1 and the INIT_JMP_REMOVE_SIGSTACK have
completely different meanings. One is a message to the initial thread
that it has to do something. The 1 is a message to setjmp that is has
been longjmp-ed to.
> *) Btw, the naming sucks - if I find better names for new_thread,
> new_thread_proc and such, would they be accepted?
Sure, good names are always appreciated.
Jeff
-------------------------------------------------------
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=110944&bid=241720&dat=121642
_______________________________________________
User-mode-linux-devel mailing list
User-mode-linux-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/user-mode-linux-devel
reply other threads:[~2006-03-25 3:17 UTC|newest]
Thread overview: [no followups] expand[flat|nested] mbox.gz Atom feed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20060325031838.GA8539@ccure.user-mode-linux.org \
--to=jdike@addtoit.com \
--cc=user-mode-linux-devel@lists.sourceforge.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox