linux-um archives
 help / color / mirror / Atom feed
From: Blaisorblade <blaisorblade@yahoo.it>
To: user-mode-linux-devel@lists.sourceforge.net
Cc: Jeff Dike <jdike@addtoit.com>, linux-kernel@vger.kernel.org
Subject: Re: [uml-devel] [PATCH 1/3] UML - Change sigjmp_buf to jmp_buf
Date: Wed, 19 Apr 2006 11:51:52 +0200	[thread overview]
Message-ID: <200604191151.53281.blaisorblade@yahoo.it> (raw)
In-Reply-To: <200604102337.k3ANb659006843@ccure.user-mode-linux.org>

On Tuesday 11 April 2006 01:37, Jeff Dike wrote:
> Clean up the jmpbuf code.  Since softints, we no longer use sig_setjmp, so
> the UML_SIGSETJMP wrapper now has a misleading name.  Also, I forgot to
> change the buffers from sigjmp_buf to jmp_buf.

> Signed-off-by: Jeff Dike <jdike@addtoit.com>

Can I request (additionally) a look at remaining calls to {sig,}setjmp() and 
sigprocmask(), like the below one and the one in (IIRC) thread_wait()?

I think that probably some of them are valid because signal handlers modify 
the signal mask, so we may still need to play with it, but:

* I don't remember (I may be wrong) mention of this in the changelog of the 
softints patch,

* you had IIRC doubts on the current code (when I noted thread_wait())

* an analysis of what is correct should end up in a comment somewhere 
describing the results.

I won't have the time to work on this soon, at least not this week, and I 
didn't write the code.

When I'll get time, I'll work on merging RemapFilePages in -mm (I'm reasonably 
near to resend it, but I can't until I've made sure all changelogs are 
up-to-date and clear enough).

> Index: linux-2.6.16-mm/arch/um/os-Linux/util.c
> ===================================================================

>  int setjmp_wrapper(void (*proc)(void *, void *), ...)
>  {
>  	va_list args;
> -	sigjmp_buf buf;
> +	jmp_buf buf;
>  	int n;
>
>  	n = sigsetjmp(buf, 1);

-- 
Inform me of my mistakes, so I can keep imitating Homer Simpson's "Doh!".
Paolo Giarrusso, aka Blaisorblade (Skype ID "PaoloGiarrusso", ICQ 215621894)
http://www.user-mode-linux.org/~blaisorblade


		
___________________________________ 
Yahoo! Messenger with Voice: chiama da PC a telefono a tariffe esclusive 
http://it.messenger.yahoo.com



-------------------------------------------------------
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=110944&bid=241720&dat=121642
_______________________________________________
User-mode-linux-devel mailing list
User-mode-linux-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/user-mode-linux-devel

      reply	other threads:[~2006-04-19  9:49 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-04-10 23:37 [uml-devel] [PATCH 1/3] UML - Change sigjmp_buf to jmp_buf Jeff Dike
2006-04-19  9:51 ` Blaisorblade [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200604191151.53281.blaisorblade@yahoo.it \
    --to=blaisorblade@yahoo.it \
    --cc=jdike@addtoit.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=user-mode-linux-devel@lists.sourceforge.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox