linux-um archives
 help / color / mirror / Atom feed
 messages from 2026-07-09 18:41:30 to 2026-07-14 15:19:52 UTC [more...]

[PATCH 00/22] Simplify special kernel page table handling
 2026-07-14 15:19 UTC  (28+ messages)
` [PATCH 01/22] mm: drop unused __mm_flags_set_mask_bits_word()
` [PATCH 02/22] mm: move mm_flags helpers to mm_types.h
` [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
` [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
` [PATCH 05/22] arm64: mm: use mm_is_kernel() for kernel mm checks
` [PATCH 06/22] loongarch: mm: use mm_is_kernel() in switch_mm_irqs_off()
` [PATCH 07/22] parisc: mm: use mm_is_kernel() for kernel mm checks
` [PATCH 08/22] powerpc: "
` [PATCH 09/22] s390: "
` [PATCH 10/22] sparc: "
` [PATCH 11/22] um: mm: use mm_is_kernel() in TLB sync
` [PATCH 12/22] x86/mm: use mm_is_kernel() for kernel mm checks
` [PATCH 13/22] mm: account page table pages when allocated
` [PATCH 14/22] mm: set page table page type "
` [PATCH 15/22] mm: only initialise pt_share_count for user pgtables
` [PATCH 16/22] efi: mark efi_mm as a kernel mm
` [PATCH 17/22] mm: pagewalk: drop redundant address check for kernel mm walks
` [PATCH 18/22] arm64: mm: drop explicit mm_is_efi() check in contpte
` [PATCH 19/22] x86/tboot: mark tboot_mm as a kernel mm
` [PATCH 20/22] arm64: mm: drop ctor/dtor calls for kernel page tables
` [PATCH 21/22] arm: mm: drop ctor call "
` [PATCH 22/22] riscv: mm: drop ctor/dtor calls "

[patch 00/18] entry: Consolidate and rework syscall entry handling
 2026-07-13  7:06 UTC  (39+ messages)
` [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
` [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
` [patch 06/18] riscv/syscall: "
` [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
` [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
` [patch 09/18] entry: Remove syscall_enter_from_user_mode()
` [patch 10/18] entry: Use syscall number instead of rereading it
` [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
` [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
` [patch 13/18] entry: Make trace_syscall_enter() return type bool
` [patch 14/18] entry: Make return type of syscall_trace_enter() bool
` [patch 15/18] x86/entry: Make syscall functions static
` [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution

[PATCH v16 00/18] arm64: entry: Convert to Generic Entry
 2026-07-03  7:51 UTC  (3+ messages)
` [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean

[RFC PATCH 0/6] um: introduce pidfd_mmap()/pidfd_munmap() syscalls
 2026-07-10 20:53 UTC  (7+ messages)
` [RFC PATCH 1/6] pidfd: add "
` [RFC PATCH 2/6] um: acquire a stub pidfd via CLONE_PIDFD in seccomp mode
` [RFC PATCH 3/6] um: install guest mappings via pidfd_mmap() "
` [RFC PATCH 4/6] um: forbid mmap/munmap in the stub seccomp filter
` [RFC PATCH 5/6] um: install guest mappings via pidfd_mmap() in both modes
` [RFC PATCH 6/6] selftests/pidfd: add pidfd_mmap()/pidfd_munmap() tests


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox