messages from 2026-07-10 20:54:02 to 2026-07-20 22:01:25 UTC [more...]
[patch 00/18] entry: Consolidate and rework syscall entry handling
2026-07-20 22:01 UTC (19+ messages)
` [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
` [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
` [patch 13/18] entry: Make trace_syscall_enter() return type bool
[RFC PATCH 0/9] simplified UML/NOMMU approach
2026-07-20 19:10 UTC (12+ messages)
` [RFC PATCH 1/9] x86/um: nommu: elf loader for fdpic
` [RFC PATCH 2/9] um: decouple MMU specific code from the common part
` [RFC PATCH 3/9] um: nommu: memory handling
` [RFC PATCH 4/9] um: change machine name for uname output
` [RFC PATCH 5/9] x86/um/vdso: nommu: vdso memory update
` [RFC PATCH 6/9] um: further decouple MMU related code
` [RFC PATCH 7/9] um: nommu: add SMP futex operations
` [RFC PATCH 8/9] um: nommu: add userspace runner processes
` [RFC PATCH 9/9] um: nommu: plug nommu code into build system
[PATCH 00/22] Simplify special kernel page table handling
2026-07-20 19:05 UTC (34+ messages)
` [PATCH 01/22] mm: drop unused __mm_flags_set_mask_bits_word()
` [PATCH 02/22] mm: move mm_flags helpers to mm_types.h
` [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
` [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
` [PATCH 05/22] arm64: mm: use mm_is_kernel() for kernel mm checks
` [PATCH 06/22] loongarch: mm: use mm_is_kernel() in switch_mm_irqs_off()
` [PATCH 07/22] parisc: mm: use mm_is_kernel() for kernel mm checks
` [PATCH 08/22] powerpc: "
` [PATCH 09/22] s390: "
` [PATCH 10/22] sparc: "
` [PATCH 11/22] um: mm: use mm_is_kernel() in TLB sync
` [PATCH 12/22] x86/mm: use mm_is_kernel() for kernel mm checks
` [PATCH 13/22] mm: account page table pages when allocated
` [PATCH 14/22] mm: set page table page type "
` [PATCH 15/22] mm: only initialise pt_share_count for user pgtables
` [PATCH 16/22] efi: mark efi_mm as a kernel mm
` [PATCH 17/22] mm: pagewalk: drop redundant address check for kernel mm walks
` [PATCH 18/22] arm64: mm: drop explicit mm_is_efi() check in contpte
` [PATCH 19/22] x86/tboot: mark tboot_mm as a kernel mm
` [PATCH 20/22] arm64: mm: drop ctor/dtor calls for kernel page tables
` [PATCH 21/22] arm: mm: drop ctor call "
` [PATCH 22/22] riscv: mm: drop ctor/dtor calls "
[PATCH] um: use ARRAY_SIZE macro in stub_exe.c
2026-07-17 3:03 UTC
[PATCH v16 00/18] arm64: entry: Convert to Generic Entry
2026-07-03 7:51 UTC (3+ messages)
` [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
[RFC PATCH 0/6] um: introduce pidfd_mmap()/pidfd_munmap() syscalls
2026-07-10 20:53 UTC (5+ messages)
` [RFC PATCH 3/6] um: install guest mappings via pidfd_mmap() in seccomp mode
` [RFC PATCH 4/6] um: forbid mmap/munmap in the stub seccomp filter
` [RFC PATCH 5/6] um: install guest mappings via pidfd_mmap() in both modes
` [RFC PATCH 6/6] selftests/pidfd: add pidfd_mmap()/pidfd_munmap() tests
page: | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox