From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id CCC69C43602 for ; Fri, 3 Jul 2026 10:27:33 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20210309; h=Sender:List-Subscribe:List-Help :List-Post:List-Archive:List-Unsubscribe:List-Id:In-Reply-To: Content-Transfer-Encoding:Content-Type:MIME-Version:References:Message-ID: Subject:Cc:To:From:Date:Reply-To:Content-ID:Content-Description:Resent-Date: Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID:List-Owner; bh=vzAgs/BEsj7FHZopxvIm9zgUiYjF8OFUBMNpzRJZrjM=; b=QNRO6wxxriujhDCMlSldLenatJ ltAL0dutI4pKi9196l4rHzXSwUb1+vypq1GpxSCImEowiEBCadu7kJXQ66/OPvcOhn2sbgUZkfL9y tNN1tuqHczDkEinlIo3JsUrWbLN14LMOnmYpPLix1/ZN8eMPfg4qRq/s+zm3V4SYzFPkXC7WUam0W HJnfnDdADk+vOWAUvp9Hnj4k/EqwnHX/Prb92aoMMIO8qHbjK3HBWFlbmayw6geIJhu3eqSshPbcy PjdLE6d4BI6GaA61vPmtDs7KJS3uBBS0mbGXwXqX1TyrsTxeEiPLnocmS0x8PIQ3HzGwthbKXvhBO 4wzlL1Yg==; Received: from localhost ([::1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.99.1 #2 (Red Hat Linux)) id 1wfb7N-00000006bJv-0F2F; Fri, 03 Jul 2026 10:27:33 +0000 Received: from smtp-out1.suse.de ([2a07:de40:b251:101:10:150:64:1]) by bombadil.infradead.org with esmtps (Exim 4.99.1 #2 (Red Hat Linux)) id 1wfb7K-00000006bI7-0gvn for linux-um@lists.infradead.org; Fri, 03 Jul 2026 10:27:32 +0000 Received: from kunlun.suse.cz (unknown [IPv6:2a07:de40:b306:2000::2]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (prime256v1) server-signature RSA-PSS (4096 bits) server-digest SHA256) (No client certificate requested) by smtp-out1.suse.de (Postfix) with ESMTPS id 8F70A74890; Fri, 3 Jul 2026 10:27:27 +0000 (UTC) Authentication-Results: smtp-out1.suse.de; none Date: Fri, 3 Jul 2026 12:27:26 +0200 From: Michal =?iso-8859-1?Q?Such=E1nek?= To: Mark Rutland Cc: Thomas Gleixner , Jinjie Ruan , oleg@redhat.com, richard.henderson@linaro.org, mattst88@gmail.com, linmag7@gmail.com, linux@armlinux.org.uk, catalin.marinas@arm.com, will@kernel.org, kees@kernel.org, guoren@kernel.org, chenhuacai@kernel.org, kernel@xen0n.name, geert@linux-m68k.org, tsbogend@alpha.franken.de, James.Bottomley@hansenpartnership.com, deller@gmx.de, maddy@linux.ibm.com, mpe@ellerman.id.au, npiggin@gmail.com, chleroy@kernel.org, pjw@kernel.org, palmer@dabbelt.com, aou@eecs.berkeley.edu, alex@ghiti.fr, hca@linux.ibm.com, gor@linux.ibm.com, agordeev@linux.ibm.com, borntraeger@linux.ibm.com, svens@linux.ibm.com, ysato@users.sourceforge.jp, dalias@libc.org, glaubitz@physik.fu-berlin.de, richard@nod.at, anton.ivanov@cambridgegreys.com, johannes@sipsolutions.net, luto@kernel.org, mingo@redhat.com, bp@alien8.de, dave.hansen@linux.intel.com, hpa@zytor.com, chris@zankel.net, jcmvbkbc@gmail.com, peterz@infradead.org, wad@chromium.org, thuth@redhat.com, ada.coupriediaz@arm.com, kevin.brodsky@arm.com, linusw@kernel.org, yeoreum.yun@arm.com, song@kernel.org, james.morse@arm.com, anshuman.khandual@arm.com, broonie@kernel.org, liqiang01@kylinos.cn, pengcan@kylinos.cn, ryan.roberts@arm.com, yangtiezhu@loongson.cn, sshegde@linux.ibm.com, mchauras@linux.ibm.com, austin.kim@lge.com, jchrist@linux.ibm.com, arnd@arndb.de, thomas.weissschuh@linutronix.de, sohil.mehta@intel.com, andrew.cooper3@citrix.com, jgross@suse.com, kas@kernel.org, x86@kernel.org, linux-alpha@vger.kernel.org, linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-mm@kvack.org, linux-csky@vger.kernel.org, loongarch@lists.linux.dev, linux-m68k@lists.linux-m68k.org, linux-mips@vger.kernel.org, linux-parisc@vger.kernel.org, linuxppc-dev@lists.ozlabs.org, linux-riscv@lists.infradead.org, linux-s390@vger.kernel.org, linux-sh@vger.kernel.org, linux-um@lists.infradead.org Subject: Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean Message-ID: References: <20260629130616.642022-1-ruanjinjie@huawei.com> <20260629130616.642022-2-ruanjinjie@huawei.com> <87cxx4mmim.ffs@fw13> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: X-Rspamd-Pre-Result: action=no action; module=replies; Message is reply to one we originated X-Rspamd-Queue-Id: 8F70A74890 X-Rspamd-Action: no action X-Rspamd-Server: rspamd1.dmz-prg2.suse.org X-Rspamd-Pre-Result: action=no action; module=replies; Message is reply to one we originated X-Spamd-Result: default: False [-2.00 / 50.00]; REPLY(-4.00)[]; RDNS_NONE(2.00)[]; R_RATELIMIT(0.00)[to_ip_from(RL1f5ktcu9q8c5toc5bju644qd)] X-CRM114-Version: 20100106-BlameMichelson ( TRE 0.9.0 (BSD) ) MR-646709E3 X-CRM114-CacheID: sfid-20260703_032730_355272_5C7C25D3 X-CRM114-Status: GOOD ( 21.50 ) X-BeenThere: linux-um@lists.infradead.org X-Mailman-Version: 2.1.34 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: "linux-um" Errors-To: linux-um-bounces+linux-um=archiver.kernel.org@lists.infradead.org On Fri, Jul 03, 2026 at 11:00:11AM +0100, Mark Rutland wrote: > On Fri, Jul 03, 2026 at 11:48:49AM +0200, Thomas Gleixner wrote: > > On Fri, Jul 03 2026 at 09:51, Michal Suchánek wrote: > > > On Mon, Jun 29, 2026 at 09:05:59PM +0800, Jinjie Ruan wrote: > > >> - if (secure_computing()) > > >> + if (!secure_computing()) > > >> return -1; > > > > > > Hello, > > > > > > I am not fond of this logic inversion. The boolean is meaningless in > > > itself. > > > > > > Previously -1 was used to indicate that the syscall was filtered but you > > > chose to invert the logic choosing true to mean syscall was not filtered. > > > > > > You could choose true to mean that syscall was fitered avoiding this > > > inversion. > > > > That's just wrong. Boolean logic makes more sense with having > > (!condition()). Just because the old 0/-1 nonsense had it the other way > > round does not mean it has to stay that way. > > 100% agreed! > > Bikeshedding below; sorry. > > I think the bigger problem is just that secure_computing() is a terrible > name that does not express the intended semantic -- it's not clear > whether "secure computing" means "seccomp permit the syscall" or > "seccomp is enabled and some special rules now apply" or something else > entirely. > > If we're changing the return type, it might be worth renaming the > function something like: > > seccomp_permits_syscall() Then not only it is clear which way the boolean value should be interpreted, it also pervents the accidental inversion of existing calls. Overall great. Thanks Michal