From: Bin Liu <b-liu@ti.com>
To: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Cc: Paul Elder <paul.elder@ideasonboard.com>,
kieran.bingham@ideasonboard.com, gregkh@linuxfoundation.org,
linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org,
balbi@kernel.org, stern@rowland.harvard.edu, rogerq@ti.com
Subject: [4/6] usb: gadget: add functions to signal udc driver to delay status stage
Date: Thu, 18 Oct 2018 07:46:14 -0500 [thread overview]
Message-ID: <20181018124614.GE8763@uda0271908> (raw)
Laurent,
On Thu, Oct 18, 2018 at 02:45:32AM +0300, Laurent Pinchart wrote:
> Hi Bin,
>
> On Thursday, 11 October 2018 19:10:21 EEST Bin Liu wrote:
> > On Tue, Oct 09, 2018 at 10:49:01PM -0400, Paul Elder wrote:
> > > A usb gadget function driver may or may not want to delay the status
> > > stage of a control OUT request. An instance it might want to is to
> > > asynchronously validate the data of a class-specific request.
> > >
> > > Add a function usb_ep_delay_status to allow function drivers to choose
> > > to delay the status stage in the request completion handler. The UDC
> > > should then check the usb_ep->delayed_status flag and act accordingly to
> > > delay the status stage.
> > >
> > > Also add a function usb_ep_send_response as a wrapper for
> > > usb_ep->ops->send_response, whose prototype is added as well. This
> > > function should be called by function drivers to tell the UDC what to
> > > reply in the status stage that it has requested to be delayed.
> > >
> > > Signed-off-by: Paul Elder <paul.elder@ideasonboard.com>
> > > Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
> > > ---
> > >
> > > drivers/usb/gadget/udc/core.c | 35 +++++++++++++++++++++++++++++++++++
> > > include/linux/usb/gadget.h | 11 +++++++++++
> > > 2 files changed, 46 insertions(+)
> > >
> > > diff --git a/drivers/usb/gadget/udc/core.c b/drivers/usb/gadget/udc/core.c
> > > index af88b48c1cea..1ec5ce6b43cd 100644
> > > --- a/drivers/usb/gadget/udc/core.c
> > > +++ b/drivers/usb/gadget/udc/core.c
> > > @@ -443,6 +443,41 @@ void usb_ep_fifo_flush(struct usb_ep *ep)
> > > }
> > > EXPORT_SYMBOL_GPL(usb_ep_fifo_flush);
> > >
> > > +/**
> > > + * usb_ep_ep_delay_status - set delay_status flag
> > > + * @ep: the endpoint whose delay_status flag is being set
> > > + *
> > > + * This function instructs the UDC to delay the status stage of a control
> > > + * request. It can only be called from the request completion handler of
> > > a
> > > + * control request.
> > > + */
> > > +void usb_ep_delay_status(struct usb_ep *ep)
> > > +{
> > > + ep->delayed_status = true;
> > > +}
> > > +EXPORT_SYMBOL_GPL(usb_ep_delay_status);
> >
> > Is usb_ep_set_delay_status() better? I thought it implies get/return
> > action if a verb is missing in the function name.
>
> For what it's worth, I understand the function name as "delay the status
> stage", with "delay" being a verb. Maybe the short description could be
> updated accordingly.
Okay, maybe it is just my own understanding problem. I thought about
delay as the verb, but then notice the var is called delayed_status,
then I was thinking delay_status in the function name as the flag.
No worries.
Regards,
-Bin.
next reply other threads:[~2018-10-18 12:46 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-10-18 12:46 Bin Liu [this message]
-- strict thread matches above, loose matches on Subject: below --
2018-12-14 15:35 [4/6] usb: gadget: add functions to signal udc driver to delay status stage Alan Stern
2018-12-14 3:47 Paul Elder
2018-11-07 16:23 Alan Stern
2018-11-07 7:00 Felipe Balbi
2018-11-07 6:53 Felipe Balbi
2018-11-06 15:01 Alan Stern
2018-11-06 14:51 Alan Stern
2018-11-06 11:24 Felipe Balbi
2018-11-06 11:17 Felipe Balbi
2018-11-02 19:46 Alan Stern
2018-11-02 17:10 Laurent Pinchart
2018-11-02 16:18 Alan Stern
2018-11-02 14:36 Laurent Pinchart
2018-11-02 12:44 Laurent Pinchart
2018-11-01 23:40 Paul Elder
2018-10-18 14:07 Alan Stern
2018-10-17 23:45 Laurent Pinchart
2018-10-11 16:10 Bin Liu
2018-10-10 2:49 Paul Elder
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20181018124614.GE8763@uda0271908 \
--to=b-liu@ti.com \
--cc=balbi@kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=kieran.bingham@ideasonboard.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=paul.elder@ideasonboard.com \
--cc=rogerq@ti.com \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox