From: Thinh Nguyen <Thinh.Nguyen@synopsys.com>
To: Xu Yang <xu.yang_2@nxp.com>, Randy Dunlap <rdunlap@infradead.org>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Shawn Guo <shawnguo@kernel.org>,
Sascha Hauer <s.hauer@pengutronix.de>,
Pengutronix Kernel Team <kernel@pengutronix.de>,
Fabio Estevam <festevam@gmail.com>, Frank Li <frank.li@nxp.com>,
Li Jun <jun.li@nxp.com>, Thinh Nguyen <Thinh.Nguyen@synopsys.com>,
"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>,
"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
"imx@lists.linux.dev" <imx@lists.linux.dev>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v4 2/3] usb: dwc3: add needs_full_reinit flag
Date: Tue, 3 Mar 2026 01:32:56 +0000 [thread overview]
Message-ID: <20260303013255.ubvrpojawfztyszh@synopsys.com> (raw)
In-Reply-To: <4186c887-fec4-4677-a7b0-e48c52ac5dea@infradead.org>
On Fri, Feb 27, 2026, Randy Dunlap wrote:
> Hi--
>
> On 2/12/26 12:35 AM, Xu Yang wrote:
> > The current design assumes that the controller remains powered when wakeup
> > is enabled. However, some SoCs provide wakeup capability even when the
> > controller itself is powered down, using separate dedicated wakeup logic.
> > This allows additional power savings, but requires the controller to be
> > fully re‑initialized after system resume.
> >
> > To support these SoCs, introduce a flag needs_full_reinit for the purpose.
> > And the glue layer needs to indicate if the controller needs this behavior
> > by setting a same flag needs_full_reinit in dwc3_properties.
> >
> > Reviewed-by: Frank Li <Frank.Li@nxp.com>
> > Signed-off-by: Xu Yang <xu.yang_2@nxp.com>
> > ---
> > Changes in v4:
> > - also rename core_may_lose_power to needs_full_reinit
> > - add R-b tag
> > Changes in v3:
> > - no changes
> > Changes in v2:
> > - put core_may_lose_power into dwc3_properties and check it in
> > dwc3_get_software_properties()
> > - rename may_lose_power to needs_full_reinit
> > ---
> > drivers/usb/dwc3/core.c | 9 +++++++--
> > drivers/usb/dwc3/core.h | 3 +++
> > drivers/usb/dwc3/glue.h | 3 +++
> > 3 files changed, 13 insertions(+), 2 deletions(-)
> >
>
> > diff --git a/drivers/usb/dwc3/core.h b/drivers/usb/dwc3/core.h
> > index a35b3db1f9f3..67bcc8dccc89 100644
> > --- a/drivers/usb/dwc3/core.h
> > +++ b/drivers/usb/dwc3/core.h
> > @@ -1119,6 +1119,8 @@ struct dwc3_glue_ops {
> > * @usb3_lpm_capable: set if hadrware supports Link Power Management
> > * @usb2_lpm_disable: set to disable usb2 lpm for host
> > * @usb2_gadget_lpm_disable: set to disable usb2 lpm for gadget
> > + * @needs_full_reinit: set to indicate the core may lose power and need full
> > + initialization during system pm
>
> The line above should begin with
> *
>
> Please correct it so that kernel-doc doesn't complain:
>
> WARNING: drivers/usb/dwc3/core.h:1122 bad line: initialization during system pm
>
> Thanks.
>
Thanks Randy, I missed this during review.
Hi Xu,
Do you think you can send a fix for this?
Thanks,
Thinh
next prev parent reply other threads:[~2026-03-03 1:33 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-12 8:35 [PATCH v4 0/3] add DWC3 i.MX driver based on flatten devicetree Xu Yang
2026-02-12 8:35 ` [PATCH v4 1/3] dt-bindings: usb: introduce nxp,imx-dwc3 Xu Yang
2026-02-12 8:35 ` [PATCH v4 2/3] usb: dwc3: add needs_full_reinit flag Xu Yang
2026-02-27 17:58 ` Randy Dunlap
2026-03-03 1:32 ` Thinh Nguyen [this message]
2026-03-03 1:49 ` Xu Yang
2026-02-12 8:35 ` [PATCH v4 3/3] usb: dwc3: introduce flatten model driver of i.MX Soc Xu Yang
2026-02-12 9:29 ` [PATCH v4 0/3] add DWC3 i.MX driver based on flatten devicetree Xu Yang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260303013255.ubvrpojawfztyszh@synopsys.com \
--to=thinh.nguyen@synopsys.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=festevam@gmail.com \
--cc=frank.li@nxp.com \
--cc=gregkh@linuxfoundation.org \
--cc=imx@lists.linux.dev \
--cc=jun.li@nxp.com \
--cc=kernel@pengutronix.de \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=rdunlap@infradead.org \
--cc=robh@kernel.org \
--cc=s.hauer@pengutronix.de \
--cc=shawnguo@kernel.org \
--cc=xu.yang_2@nxp.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox