Linux USB
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: Vegom Doster <vegomdoster@gmail.com>
Cc: linux-usb@vger.kernel.org, johan@kernel.org
Subject: Re: [PATCH] usb: serial: ch341: add debugfs interface and clean up
Date: Thu, 6 Aug 2026 06:41:29 +0200	[thread overview]
Message-ID: <2026080655-ludicrous-pyromania-cced@gregkh> (raw)
In-Reply-To: <CACnaG5x8-y7aOWw=d73pqWyQL36MSjQctJDWuk+r96o-BNhgMw@mail.gmail.com>

On Wed, Aug 05, 2026 at 08:31:00PM +0500, Vegom Doster wrote:
> This patch adds a debugfs interface for the CH341 driver, allowing runtime
> inspection of chip version, quirks, and line status. It also adds a 'baud'
> file to test the divisor calculation without hardware.
> 
> The patch also cleans up magic numbers, removes duplicate code, and fixes
> several issues:
> - Replace obsolete usb_control_msg() with usb_control_msg_send/recv
> - Convert version>0x27 hack to proper CH341_QUIRK_INVERTED_BIT7
> - Fix baud_rate update in ch341_set_termios (only on success)
> - Use READ_ONCE/WRITE_ONCE for break_end
> - Fix error handling in ch341_reset_resume
> - Add debugfs interface for diagnostics
> 
> No functional changes are made to the driver's operation.
> 
> Tested on Arch Linux with Arduino Uno (CH340C, 1a86:7523):
> - checkpatch: 0 errors, 0 warnings, 0 checks
> - DTR/RTS (tiocmget/set): PASS
> - Echo at 9600 and 115200 baud: PASS (byte-per-byte)
> - Divisor formula for 15 speeds (300..3000000): PASS (error ≤0.16%)
> - debugfs: tested with custom test script
> 
> Signed-off-by: nerolocker <vegomdoster@gmail.com>

Better, but my bot says:

--------

Hi,

This is the friendly patch-bot of Greg Kroah-Hartman.  You have sent him
a patch that has triggered this response.  He used to manually respond
to these common problems, but in order to save his sanity (he kept
writing the same thing over and over, yet to different people), I was
created.  Hopefully you will not take offence and will fix the problem
in your patch and resubmit it so that it can be accepted into the Linux
kernel tree.

You are receiving this message because of the following common error(s)
as indicated below:

- Your patch did many different things all at once, making it difficult
  to review.  All Linux kernel patches need to only do one thing at a
  time.  If you need to do multiple things (such as clean up all coding
  style issues in a file/driver), do it in a sequence of patches, each
  one doing only one thing.  This will make it easier to review the
  patches to ensure that they are correct, and to help alleviate any
  merge issues that larger patches can cause.

- It looks like you did not use your "real" name for the patch on either
  the Signed-off-by: line, or the From: line (both of which have to
  match).  Please read the kernel file,
  Documentation/process/submitting-patches.rst for how to do this
  correctly.

- This looks like a new version of a previously submitted patch, but you
  did not list below the --- line any changes from the previous version.
  Please read the section entitled "The canonical patch format" in the
  kernel file, Documentation/process/submitting-patches.rst for what
  needs to be done here to properly describe this.

If you wish to discuss this problem further, or you have questions about
how to resolve this issue, please feel free to respond to this email and
Greg will reply once he has dug out from the pending patches received
from other developers.

thanks,

greg k-h's patch email bot

  reply	other threads:[~2026-08-06  4:41 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-05 15:31 [PATCH] usb: serial: ch341: add debugfs interface and clean up Vegom Doster
2026-08-06  4:41 ` Greg KH [this message]
     [not found] <CACnaG5x_EPK+PGqdrRO-OgOQ3go8EKFdV+R14bKuc9mTS5r31w@mail.gmail.com>
2026-08-05 15:28 ` Vegom Doster
2026-08-06  4:40   ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2026080655-ludicrous-pyromania-cced@gregkh \
    --to=gregkh@linuxfoundation.org \
    --cc=johan@kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=vegomdoster@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox