From: Mika Westerberg <mika.westerberg@linux.intel.com>
To: Jean Delvare <jdelvare@suse.de>
Cc: "Rafael J. Wysocki" <rjw@rjwysocki.net>,
Len Brown <lenb@kernel.org>,
linux-acpi@vger.kernel.org,
Wim Van Sebroeck <wim@linux-watchdog.org>,
Guenter Roeck <linux@roeck-us.net>,
linux-watchdog@vger.kernel.org, Tom Abraham <tabraham@suse.com>
Subject: Re: [PATCH 1/3] ACPICA: Introduce ACPI_ACCESS_BIT_WIDTH() macro
Date: Wed, 12 Feb 2020 14:08:36 +0200 [thread overview]
Message-ID: <20200212120836.GB2667@lahna.fi.intel.com> (raw)
In-Reply-To: <20200212125244.2b61202e@endymion>
On Wed, Feb 12, 2020 at 12:52:44PM +0100, Jean Delvare wrote:
> On Wed, 12 Feb 2020 14:05:38 +0300, Mika Westerberg wrote:
> > Sometimes it is useful to find the access_width field value in bytes and
> > not in bits so add a helper that can be used for this purpose.
>
> s/ACPI_ACCESS_BIT_WIDTH/ACPI_ACCESS_BYTE_WIDTH/ in the subject.
Indeed.
> > Suggested-by: Jean Delvare <jdelvare@suse.de>
> > Signed-off-by: Mika Westerberg <mika.westerberg@linux.intel.com>
> > ---
> > include/acpi/actypes.h | 1 +
> > 1 file changed, 1 insertion(+)
> >
> > diff --git a/include/acpi/actypes.h b/include/acpi/actypes.h
> > index a2583c2bc054..77d40b02f62a 100644
> > --- a/include/acpi/actypes.h
> > +++ b/include/acpi/actypes.h
> > @@ -537,6 +537,7 @@ typedef u64 acpi_integer;
> > * struct acpi_resource_generic_register.
> > */
> > #define ACPI_ACCESS_BIT_WIDTH(size) (1 << ((size) + 2))
> > +#define ACPI_ACCESS_BYTE_WIDTH(size) (ACPI_ACCESS_BIT_WIDTH(size) / 8)
>
> One of the points of having this macro being to avoid needless math,
> I'd rather do:
>
> #define ACPI_ACCESS_BYTE_WIDTH(size) (1 << ((size) - 1))
>
> Some compilers might be able to optimize it, but maybe not all, and I
> see little point in giving the compiler more work anyway when it can be
> easily avoided.
>
> You may also want to replace "bit" by "bit or byte in the comment right
> before the macros.
OK, I'll do that.
> >
> > /*******************************************************************************
> > *
>
> Reviewed-by: Jean Delvare <jdelvare@suse.de>
Thanks!
next prev parent reply other threads:[~2020-02-12 12:08 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-02-10 10:16 wdat_wdt: access width inconsistency Jean Delvare
2020-02-10 11:23 ` Mika Westerberg
2020-02-11 13:11 ` Jean Delvare
2020-02-11 13:59 ` Mika Westerberg
2020-02-11 16:25 ` Jean Delvare
2020-02-11 16:37 ` Mika Westerberg
2020-02-11 17:03 ` Jean Delvare
2020-02-12 11:05 ` [PATCH 1/3] ACPICA: Introduce ACPI_ACCESS_BIT_WIDTH() macro Mika Westerberg
2020-02-12 11:05 ` [PATCH 2/3] ACPI / watchdog: Fix gas->access_width usage Mika Westerberg
2020-02-12 11:56 ` Jean Delvare
2020-02-12 12:10 ` Mika Westerberg
2020-02-12 11:05 ` [PATCH 3/3] ACPI / watchdog: Set default timeout in probe Mika Westerberg
2020-02-12 12:07 ` Jean Delvare
2020-02-12 12:13 ` Mika Westerberg
2020-02-12 11:52 ` [PATCH 1/3] ACPICA: Introduce ACPI_ACCESS_BIT_WIDTH() macro Jean Delvare
2020-02-12 12:08 ` Mika Westerberg [this message]
2020-02-11 16:45 ` wdat_wdt: access width inconsistency Guenter Roeck
2020-02-12 10:30 ` Jean Delvare
2020-02-12 10:47 ` Mika Westerberg
2020-02-12 11:05 ` Jean Delvare
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200212120836.GB2667@lahna.fi.intel.com \
--to=mika.westerberg@linux.intel.com \
--cc=jdelvare@suse.de \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-watchdog@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=rjw@rjwysocki.net \
--cc=tabraham@suse.com \
--cc=wim@linux-watchdog.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox