From: Luciano Coelho <coelho@ti.com>
To: Eliad Peller <eliad@wizery.com>
Cc: linux-wireless@vger.kernel.org
Subject: Re: [PATCH 26/40] wl12xx: add wl1271_cmd_role_start_ibss()
Date: Thu, 11 Aug 2011 10:15:16 +0300 [thread overview]
Message-ID: <1313046916.2407.791.camel@cumari> (raw)
In-Reply-To: <1312881233-9366-27-git-send-email-eliad@wizery.com>
On Tue, 2011-08-09 at 12:13 +0300, Eliad Peller wrote:
> Add wl1271_cmd_role_start_ibss() implementation and defintion.
> This function is used in order to start the IBSS role.
>
> Stopping the IBSS is done by using the same api as stop STA,
> so there is no need for a separate function.
Not really important now, but maybe we should find a more generic name
for the wl1271_cmd_role_stop_sta() function then. Or add a nice comment
there saying that it is also used for bss.
> diff --git a/drivers/net/wireless/wl12xx/cmd.c b/drivers/net/wireless/wl12xx/cmd.c
> index 41dee4f..b8d6848 100644
> --- a/drivers/net/wireless/wl12xx/cmd.c
> +++ b/drivers/net/wireless/wl12xx/cmd.c
> @@ -767,12 +767,73 @@ out_free:
> kfree(cmd);
>
> out:
> return ret;
> }
>
> +int wl1271_cmd_role_start_ibss(struct wl1271 *wl)
> +{
> + struct wl1271_cmd_role_start *cmd;
> + struct ieee80211_bss_conf *bss_conf = &wl->vif->bss_conf;
> + int ret;
> +
> + cmd = kzalloc(sizeof(*cmd), GFP_KERNEL);
> + if (!cmd) {
> + ret = -ENOMEM;
> + goto out;
> + }
> +
> + wl1271_debug(DEBUG_CMD, "cmd role start ibss %d", wl->role_id);
> +
> + cmd->role_id = wl->role_id;
> + if (wl->band == IEEE80211_BAND_5GHZ)
> + cmd->band |= WL1271_BAND_5GHZ;
This looks wrong. I didn't see it before, but it was already introduced
in patch 08. The WL1271_BAND_* definitions are an enumeration defined
like this:
enum wl1271_band {
WL1271_BAND_2_4GHZ = 0, /* 2.4 Ghz band */
WL1271_BAND_5GHZ = 1, /* 5 Ghz band */
WL1271_BAND_JAPAN_4_9_GHZ = 2,
WL1271_BAND_DEFAULT = WL1271_BAND_2_4GHZ,
WL1271_BAND_INVALID = 0x7E,
WL1271_BAND_MAX_RADIO = 0x7F,
};
Why are we always ORing the value into cmd->band then? If these commands
can only work in single bands (which is probably the case), then we
should use "cmd->band = WL1271_BAND_5GHZ" instead. If the commands can
manage more than a band at once, then cmd->band should be a bitmask and
the enumeration should be defined using BIT(0), BIT(1) and so on.
--
Cheers,
Luca.
next prev parent reply other threads:[~2011-08-11 7:15 UTC|newest]
Thread overview: 78+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-08-09 9:13 [PATCH 00/40] wl12xx: move to wl12xx-fw-3 Eliad Peller
2011-08-09 9:13 ` [PATCH 01/40] wl12xx: Revert "wl12xx: schedule TX packets according to FW occupancy" Eliad Peller
2011-08-09 11:54 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 02/40] wl12xx: Use a single fw for both STA and AP roles Eliad Peller
2011-08-09 11:59 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 03/40] wl12xx: use 1 spare block in all cases Eliad Peller
2011-08-09 12:03 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 04/40] wl12xx: temporarily disable 11n and advanced ap functions Eliad Peller
2011-08-09 12:49 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 05/40] wl12xx: remove rx filtering stuff Eliad Peller
2011-08-09 13:19 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 06/40] wl12xx: wl12xx-fw-3 - Update fw status struct Eliad Peller
2011-08-09 13:37 ` Luciano Coelho
2011-08-09 19:12 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 07/40] wl12xx: wl12xx-fw-3 - update acx commands Eliad Peller
2011-08-09 19:29 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 08/40] wl12xx: wl12xx-fw-3 - update commands & events Eliad Peller
2011-08-10 9:19 ` Luciano Coelho
2011-08-10 9:53 ` Eliad Peller
2011-08-10 10:26 ` Luciano Coelho
2011-08-10 10:24 ` Eliad Peller
2011-08-10 10:27 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 09/40] wl12xx: enable/disable role on interface add/remove Eliad Peller
2011-08-10 11:32 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 10/40] wl12xx: add device role commands Eliad Peller
2011-08-10 11:54 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 11/40] wl12xx: wl12xx-fw-3 - update scan cmd api Eliad Peller
2011-08-09 9:13 ` [PATCH 12/40] wl12xx: wl12xx-fw-3 - rx/tx changes Eliad Peller
2011-08-09 9:13 ` [PATCH 13/40] wl12xx: wl12xx-fw-3 - change max/default template size Eliad Peller
2011-08-09 9:13 ` [PATCH 14/40] wl12xx: use wl1271_acx_beacon_filter_opt for both sta and ap Eliad Peller
2011-08-09 9:13 ` [PATCH 15/40] wl12xx: add set_rate_mgmt_params acx Eliad Peller
2011-08-10 12:31 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 16/40] wl12xx: add system_hlid Eliad Peller
2011-08-10 12:48 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 17/40] wl12xx: add ROC/CROC commands Eliad Peller
2011-08-10 12:57 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 18/40] wl12xx: replace dummy_join with " Eliad Peller
2011-08-10 14:31 ` Luciano Coelho
2011-08-11 11:03 ` Eliad Peller
2011-08-09 9:13 ` [PATCH 19/40] wl12xx: handle dummy packet event also in ap mode Eliad Peller
2011-08-09 9:13 ` [PATCH 20/40] wl12xx: update BT coex configuration params Eliad Peller
2011-08-10 15:16 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 21/40] wl12xx: fix session counter Eliad Peller
2011-08-10 15:20 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 22/40] wl12xx: use dynamic hlids for AP-mode Eliad Peller
2011-08-10 19:39 ` Luciano Coelho
2011-08-09 9:13 ` [PATCH 23/40] wl12xx: re-enable block ack session support Eliad Peller
2011-08-10 19:54 ` Luciano Coelho
2011-08-15 9:34 ` Levi, Shahar
2011-08-09 9:13 ` [PATCH 24/40] wl12xx: call wl1271_cmd_set_peer_state() in AP mode Eliad Peller
2011-08-09 9:13 ` [PATCH 25/40] wl12xx: don't remove key if hlid was already deleted Eliad Peller
2011-08-09 9:13 ` [PATCH 26/40] wl12xx: add wl1271_cmd_role_start_ibss() Eliad Peller
2011-08-11 7:15 ` Luciano Coelho [this message]
2011-08-09 9:13 ` [PATCH 27/40] wl12xx: support IBSS vif type Eliad Peller
2011-08-09 9:13 ` [PATCH 28/40] wl12xx: AP-mode - set STA HT capabilities when adding a STA Eliad Peller
2011-08-09 9:13 ` [PATCH 29/40] wl12xx: AP-mode - configure STA HT rates on join Eliad Peller
2011-08-09 9:13 ` [PATCH 30/40] wl12xx: AP-mode - configure HT rate support to the FW Eliad Peller
2011-08-10 20:30 ` Luciano Coelho
2011-08-11 4:39 ` Arik Nemtsov
2011-08-09 9:13 ` [PATCH 31/40] wl12xx: use ap_bcast_hlid for recorded keys Eliad Peller
2011-08-09 9:13 ` [PATCH 32/40] wl12xx: don't remove key if hlid was already deleted Eliad Peller
2011-08-09 9:13 ` [PATCH 33/40] wl12xx: track freed packets in FW by AC Eliad Peller
2011-08-11 9:17 ` Luciano Coelho
2011-08-11 9:41 ` Eliad Peller
2011-08-11 16:11 ` Arik Nemtsov
2011-08-09 9:13 ` [PATCH 34/40] wl12xx: schedule TX packets according to FW packet occupancy Eliad Peller
2011-08-11 11:38 ` Luciano Coelho
2011-08-11 20:54 ` Arik Nemtsov
2011-08-09 9:13 ` [PATCH 35/40] wl12xx: handle wrap-around overflow in released Tx blocks FW counter Eliad Peller
2011-08-09 9:13 ` [PATCH 36/40] wl12xx: enable AP advanced functionality Eliad Peller
2011-08-09 9:13 ` [PATCH 37/40] wl12xx: don't wait for disconnection event Eliad Peller
2011-08-11 11:53 ` Luciano Coelho
2011-08-11 12:30 ` Eliad Peller
2011-08-09 9:13 ` [PATCH 38/40] wl12xx: set the AP-started flag only after setting keys Eliad Peller
2011-08-09 9:13 ` [PATCH 39/40] wl12xx: AP-mode - prevent Tx to stale/invalid stations Eliad Peller
2011-08-09 9:13 ` [PATCH 40/40] wl12xx: fix tx_queue_count spurious increment Eliad Peller
2011-08-11 11:57 ` [PATCH 00/40] wl12xx: move to wl12xx-fw-3 Luciano Coelho
2011-08-11 12:31 ` Eliad Peller
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1313046916.2407.791.camel@cumari \
--to=coelho@ti.com \
--cc=eliad@wizery.com \
--cc=linux-wireless@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox