From: Javier Martinez Canillas <javier@osg.samsung.com>
To: linux-kernel@vger.kernel.org
Cc: Javier Martinez Canillas <javier@osg.samsung.com>,
Arnd Bergmann <arnd@arndb.de>,
Sony Chacko <sony.chacko@qlogic.com>,
Giuseppe Cavallaro <peppe.cavallaro@st.com>,
Solarflare linux maintainers <linux-net-drivers@solarflare.com>,
Florian Westphal <fw@strlen.de>,
Bert Kenward <bkenward@solarflare.com>,
Geert Uytterhoeven <geert@linux-m68k.org>,
Edward Cree <ecree@solarflare.com>,
Kalle Valo <kvalo@codeaurora.org>,
Marcin Wojtas <mw@semihalf.com>,
Antonio Quartulli <a@unstable.cc>,
intel-wired-lan@lists.osuosl.org,
Florian Fainelli <f.fainelli@gmail.com>,
Felipe Balbi <felipe.balbi@linux.intel.com>,
Gregory CLEMENT <gregory.clement@free-electrons.com>,
Dept-HSGLinuxNICDev@qlogic.com,
Jeff Kirsher <jeffrey.t.kirsher@intel.com>,
Mugunthan V N <mugunthanvnm@ti.com>, Andrew Lunn <andrew@lunn.ch>,
Steffen Klassert <klassert@mathematik.tu-chemnitz.de>,
Stanislaw Gruszka <sgruszka@redhat.com>,
Denis Kirjanov <kda@linux-powerpc.org>,
Zhao Qiang <qiang.zhao@freescale.com>,
netdev@vger.kernel.org,
Gerlando Falauto <gerlando.falauto@keymile.com>,
linux-wireless@vger.kernel.org, Ion Badulescu <ionut@badula.org>,
"David S. Miller" <davem@davemloft.net>,
Daniele Venzano <venza@brownhat.org>,
Alexandre Torgue <alexandre.torgue@st.com>
Subject: [PATCH 00/15] drivers: net: use IS_ENABLED() instead of checking for built-in or module
Date: Mon, 12 Sep 2016 10:03:31 -0400 [thread overview]
Message-ID: <1473689026-6983-1-git-send-email-javier@osg.samsung.com> (raw)
Hello David,
This trivial series is similar to [0] for net/ that you already merged, but
for drivers/net. The patches replaces the open coding to check for a Kconfig
symbol being built-in or module, with IS_ENABLED() macro that does the same.
Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.
[0]: https://lkml.org/lkml/2016/9/9/323
Best regards,
Javier
Javier Martinez Canillas (15):
3c59x: use IS_ENABLED() instead of checking for built-in or module
starfire: use IS_ENABLED() instead of checking for built-in or module
ethernet: amd: use IS_ENABLED() instead of checking for built-in or
module
bnx2: use IS_ENABLED() instead of checking for built-in or module
sundance: use IS_ENABLED() instead of checking for built-in or module
net/fsl_pq_mdio: use IS_ENABLED() instead of checking for built-in or
module
i825xx: use IS_ENABLED() instead of checking for built-in or module
ixgbe: use IS_ENABLED() instead of checking for built-in or module
net: mvneta: use IS_ENABLED() instead of checking for built-in or
module
natsemi: use IS_ENABLED() instead of checking for built-in or module
sfc: use IS_ENABLED() instead of checking for built-in or module
sis900: use IS_ENABLED() instead of checking for built-in or module
stmmac: use IS_ENABLED() instead of checking for built-in or module
hamradio: use IS_ENABLED() instead of checking for built-in or module
iwlegacy: use IS_ENABLED() instead of checking for built-in or module
drivers/net/ethernet/3com/3c59x.c | 2 +-
drivers/net/ethernet/adaptec/starfire.c | 2 +-
drivers/net/ethernet/amd/7990.c | 6 +++---
drivers/net/ethernet/amd/amd8111e.c | 2 +-
drivers/net/ethernet/broadcom/bnx2.c | 2 +-
drivers/net/ethernet/dlink/sundance.c | 2 +-
drivers/net/ethernet/freescale/fsl_pq_mdio.c | 8 ++++----
drivers/net/ethernet/i825xx/82596.c | 4 ++--
drivers/net/ethernet/intel/ixgbe/ixgbe.h | 4 ++--
drivers/net/ethernet/marvell/mvneta_bm.h | 2 +-
drivers/net/ethernet/natsemi/ns83820.c | 2 +-
drivers/net/ethernet/sfc/falcon_boards.c | 4 ++--
drivers/net/ethernet/sis/sis900.c | 4 ++--
drivers/net/ethernet/sis/sis900.h | 2 +-
drivers/net/ethernet/stmicro/stmmac/common.h | 2 +-
drivers/net/hamradio/bpqether.c | 2 +-
drivers/net/wireless/intel/iwlegacy/common.h | 4 ++--
17 files changed, 27 insertions(+), 27 deletions(-)
--
2.7.4
next reply other threads:[~2016-09-12 14:04 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-09-12 14:03 Javier Martinez Canillas [this message]
2016-09-12 14:03 ` [PATCH 15/15] iwlegacy: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas
2016-09-13 3:28 ` [PATCH 00/15] drivers: net: " David Miller
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1473689026-6983-1-git-send-email-javier@osg.samsung.com \
--to=javier@osg.samsung.com \
--cc=Dept-HSGLinuxNICDev@qlogic.com \
--cc=a@unstable.cc \
--cc=alexandre.torgue@st.com \
--cc=andrew@lunn.ch \
--cc=arnd@arndb.de \
--cc=bkenward@solarflare.com \
--cc=davem@davemloft.net \
--cc=ecree@solarflare.com \
--cc=f.fainelli@gmail.com \
--cc=felipe.balbi@linux.intel.com \
--cc=fw@strlen.de \
--cc=geert@linux-m68k.org \
--cc=gerlando.falauto@keymile.com \
--cc=gregory.clement@free-electrons.com \
--cc=intel-wired-lan@lists.osuosl.org \
--cc=ionut@badula.org \
--cc=jeffrey.t.kirsher@intel.com \
--cc=kda@linux-powerpc.org \
--cc=klassert@mathematik.tu-chemnitz.de \
--cc=kvalo@codeaurora.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-net-drivers@solarflare.com \
--cc=linux-wireless@vger.kernel.org \
--cc=mugunthanvnm@ti.com \
--cc=mw@semihalf.com \
--cc=netdev@vger.kernel.org \
--cc=peppe.cavallaro@st.com \
--cc=qiang.zhao@freescale.com \
--cc=sgruszka@redhat.com \
--cc=sony.chacko@qlogic.com \
--cc=venza@brownhat.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox