From: "Tomas Winkler" <tomasw@gmail.com>
To: "Johannes Berg" <johannes@sipsolutions.net>
Cc: "Ron Rindjunsky" <ron.rindjunsky@intel.com>,
"John Linville" <linville@tuxdriver.com>,
"Ivo van Doorn" <ivdoorn@gmail.com>,
mb@bu3sch.de, dsd@gentoo.org,
linux-wireless <linux-wireless@vger.kernel.org>
Subject: Re: RFC: unified BSS configuration approach
Date: Wed, 30 Jan 2008 17:12:56 +0200 [thread overview]
Message-ID: <1ba2fa240801300712x1a1e10r722cf3cf237c6a99@mail.gmail.com> (raw)
In-Reply-To: <1201696710.4014.14.camel@johannes.berg>
On Jan 30, 2008 2:38 PM, Johannes Berg <johannes@sipsolutions.net> wrote:
>
> > > Hm, true, that could happen. Does it happen in practice though? I can't
> > > see why a low level driver would decide that it should have short
> > > preamble or CTS protection on by default. Maybe we should just document
> > > initial state? Or we can keep the initial call and remove that "don't
> > > call w/o BSS" restriction instead, which seems saner. We should then
> > > probably rename reset_erp_info() to reset_bss_info() though.
> >
> > Yes it happens in practices. I think with short slot.
> > reset_bss_info() sounds good.
>
> Ok so let's rename reset_erp_info() to reset_bss_info() and have it
> handle all the other stuff too.
>
> > > > 1 - change the original intention of bss_info_changed so mac80211 will
> > > > be able to set low-level driver in the "init" or "configure" flows as
> > > > well, not only as BSS is formed or changes
> > > > 2 - maintain original intention, use "bss_info_changed" only when we
> > > > want to deliver BSS configuration when we get associate or during
> > > > association state, and deliver all initial configuration info through
> > > > different ops
> > >
> > > I prefer the first option since that's essentially just a small
> > > documentation change and it makes sense. We just should make sure that
> > > it's called only when the device is started (through ->start()).
> >
> > what about reset_bss_info() ?
>
> Well reset_bss_info() would still call ->bss_info_changed(), no?
Sounds good so far.
> johannes
>
prev parent reply other threads:[~2008-01-30 15:12 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-01-27 11:33 RFC: unified BSS configuration approach Ron Rindjunsky
2008-01-29 16:25 ` Johannes Berg
2008-01-29 23:05 ` Tomas Winkler
2008-01-30 12:38 ` Johannes Berg
2008-01-30 15:12 ` Tomas Winkler [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1ba2fa240801300712x1a1e10r722cf3cf237c6a99@mail.gmail.com \
--to=tomasw@gmail.com \
--cc=dsd@gentoo.org \
--cc=ivdoorn@gmail.com \
--cc=johannes@sipsolutions.net \
--cc=linux-wireless@vger.kernel.org \
--cc=linville@tuxdriver.com \
--cc=mb@bu3sch.de \
--cc=ron.rindjunsky@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox