From: Marcelo Tosatti <marcelo@kvack.org>
To: Christoph Hellwig <hch@infradead.org>
Cc: Marcelo Tosatti <marcelo@kvack.org>,
Jeff Garzik <jeff@garzik.org>,
"John W. Linville" <linville@tuxdriver.com>,
linux-wireless@vger.kernel.org
Subject: Re: Please pull 'libertas' branch of wireless-2.6
Date: Wed, 7 Mar 2007 15:16:38 -0300 [thread overview]
Message-ID: <20070307181638.GA22305@dmt> (raw)
In-Reply-To: <20070305140825.GA9982@infradead.org>
On Mon, Mar 05, 2007 at 02:08:25PM +0000, Christoph Hellwig wrote:
> On Sun, Mar 04, 2007 at 12:36:27PM -0300, Marcelo Tosatti wrote:
> > Hi Christoph,
> >
> > On Sat, Mar 03, 2007 at 05:21:40AM +0000, Christoph Hellwig wrote:
> > > Umm, I can't remember the updated driver ever beeig posted for review.
> >
> > http://lists.openwall.net/netdev/2007/02/10/25
> >
> > > And to be honest I'd be surprised if it's in a good shape already.
> >
> > Constructive comments are welcome... All comments made by Arnd (which
> > were many!) have been addressed.
>
> Comments on that versions from a quick read over it:
>
> - the __le* annotation issue you mentioned in the mail is important.
> We definitvely don't want any new drivers without endianess annotations,
> because there are far too many endianess problems. Even more so
> in a case of a driver like this one that's only tested on LE hardware
> and has LE device endianess.
> - things like 11d.[ch] don't have business of beeing in a driver,
> this should be somewhere in common code.
Most wireless drivers implement 11d internally. We certainly need to
unify the management code, but thats not a merge blocker.
> - there shouldn't be a LICENSE file in individual driver directories,
> especially if it's just plain old GPLv2.
> - please get rid of setting -DFOO flags in the Makefile, just use
> these directly as config symbols.
> - there shouldn't be a README file in the driver directory, this
> should be in Documentation/
> - please don't use wlan_* foo types. a) this should be structs, not
> typedefs, and b) wlan is an utterly generic name for beeing inside
> a driver. Then again most things using this should be inside
> generic code anyway.. (and yeah, all that is because the driver
> copied braindead linux-wlan-ng code that probably needs a major
> revision anyway)
> - there seems to be lots of tabs vs spaces messups
> - please get rid of the ENTER/LEAVE macros
These are useful for debugging. We have removed most of the useless ones
already.
> - there's an awful lot of headers without clear divided responsibilities,
> there should be only a few ones left (internal interfaces and hw
> interface basically)
> - having lowercase names for lots of hw commands is a very bad idea
> for readability
> - please get rid of all your private ioctls and iwpriv stuff
> (should I add !!!! here)
Rationale being? There are a bunch of device private knobs, and iwpriv
is the interface for such configuration. (????)
> - scan.h has very strange almost docbook comments, please convert
> them to real docbook comments and actually run things through
> the tools to make sure it's right.
> - scan.h has vi indentation comment helpers that are contrary to
> linux coding style..
> - the thread.h abstractions are really useless, opencoding them
> would make the code a lot more readable. And make people
> notice it's actually wrong:
> o the return value from kthread_run needs to be checked
> o wlan_deactivate_thread is not needed at all
> o storing and checking the pid should go away
> o there is no need for an additional waitqueue, you can
> just use wake_up_process for kernel threads.
> - most of types.h should not be there but you should be using
> the types from include/linux/*80211*
> - version.h shouldn't exist
> - the radiotap header changes should definitively not be in
> a "add a new driver" diff
Other than this your comments are OK, will address them.
Thanks!
next prev parent reply other threads:[~2007-03-07 18:18 UTC|newest]
Thread overview: 44+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20070227205649.GH5826@tuxdriver.com>
2007-02-28 1:01 ` Please pull 'libertas' branch of wireless-2.6 John W. Linville
2007-03-03 1:29 ` Jeff Garzik
2007-03-03 5:21 ` Christoph Hellwig
2007-03-04 15:36 ` Marcelo Tosatti
2007-03-05 14:08 ` Christoph Hellwig
2007-03-07 18:16 ` Marcelo Tosatti [this message]
2007-03-07 22:24 ` Christoph Hellwig
2007-03-08 2:40 ` Dan Williams
2007-03-08 8:31 ` Christoph Hellwig
2007-03-08 14:06 ` Michael Buesch
2007-05-07 10:41 ` Christoph Hellwig
2007-05-07 12:03 ` Dan Williams
2007-05-07 14:11 ` Please pull 'revert-libertas' branch of wireless-2.6 (was Re: Please pull 'libertas' branch of wireless-2.6) John W. Linville
2007-05-07 15:22 ` Jeff Garzik
2007-05-07 15:38 ` John W. Linville
2007-05-07 15:47 ` Dan Williams
2007-05-07 15:48 ` Jeff Garzik
2007-05-07 16:44 ` John W. Linville
2007-05-08 6:12 ` Matt Mackall
2007-05-08 8:28 ` Nick Piggin
2007-05-08 20:59 ` Jeff Garzik
2007-05-08 23:31 ` Nick Piggin
2007-05-08 9:47 ` Pekka Enberg
2007-05-08 20:27 ` Please pull 'revert-libertas' branch of wireless-2.6 David Miller
2007-05-08 20:55 ` Jeff Garzik
2007-05-08 21:29 ` Dan Williams
2007-05-08 22:40 ` Jeff Garzik
2007-05-08 23:41 ` Marcelo Tosatti
2007-05-09 1:27 ` Dan Williams
2007-05-09 21:25 ` Randy Dunlap
2007-05-09 21:41 ` Dan Williams
2007-05-09 21:41 ` Jeff Garzik
2007-05-10 18:35 ` Dan Williams
2007-05-09 21:46 ` Randy Dunlap
2007-05-10 16:56 ` Dan Williams
2007-05-10 20:48 ` Dan Williams
2007-03-16 21:38 Please pull 'libertas' " John W. Linville
-- strict thread matches above, loose matches on Subject: below --
2007-05-11 19:26 John W. Linville
2007-05-11 20:59 ` Jeff Garzik
[not found] <20070529183347.GD3496@tuxdriver.com>
2007-05-30 14:07 ` Jeff Garzik
2007-05-30 15:28 ` Dan Williams
2007-05-31 21:13 ` Dan Williams
2007-05-31 21:16 ` John W. Linville
2007-06-01 21:48 ` Dan Williams
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070307181638.GA22305@dmt \
--to=marcelo@kvack.org \
--cc=hch@infradead.org \
--cc=jeff@garzik.org \
--cc=linux-wireless@vger.kernel.org \
--cc=linville@tuxdriver.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox