Linux wireless drivers development
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@oracle.com>
To: Andrea Merello <andrea.merello@gmail.com>
Cc: John Linville <linville@tuxdriver.com>,
	Linux Wireless List <linux-wireless@vger.kernel.org>,
	Larry Finger <Larry.Finger@lwfinger.net>,
	Bernhard Schiffner <bernhard@schiffner-limbach.de>
Subject: Re: [PATCH 1/3] rtl818x_pci: make RSSI code more readable
Date: Sun, 1 Jun 2014 08:26:43 +0300	[thread overview]
Message-ID: <20140601052643.GM17724@mwanda> (raw)
In-Reply-To: <CAN8YU5OFqTa0Ywwhgt_MzTA5+5v9YON_YkQyD3L+syCyjO+OKw@mail.gmail.com>

On Sun, Jun 01, 2014 at 02:37:51AM +0200, Andrea Merello wrote:
> IHMO it does not matter.
> 
> The 10 is a stub value for rtl8187se (because of not-implemented-yet
> RSSI calculation), and indeed it is still here, in the rtl8187se case.
> This has the functional role of providing a valid >0 value for reported RSSI.
> This should hopefully go away soon :)
> So, for rtl8187se case, it always reported 10, and it does continue to do this.
> 
> The initialization to 1 has no any functional role, it is just to shut
> up gcc complaints about not initialized variable, but it should be
> always overwritten by one of the three cases, and we should never see
> this value really reported on RSSI measure.
> 
> Indeed they are two random values (chosen >0, just in case it does matter..)..
> 

Ah.  Ok.  Thanks.

regards,
dan carpenter


      reply	other threads:[~2014-06-01  5:27 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-31 16:29 [PATCH 1/3] rtl818x_pci: make RSSI code more readable Andrea Merello
2014-05-31 20:05 ` Dan Carpenter
2014-06-01  0:37   ` Andrea Merello
2014-06-01  5:26     ` Dan Carpenter [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140601052643.GM17724@mwanda \
    --to=dan.carpenter@oracle.com \
    --cc=Larry.Finger@lwfinger.net \
    --cc=andrea.merello@gmail.com \
    --cc=bernhard@schiffner-limbach.de \
    --cc=linux-wireless@vger.kernel.org \
    --cc=linville@tuxdriver.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox