Linux wireless drivers development
 help / color / mirror / Atom feed
From: Felix Fietkau <nbd@nbd.name>
To: Lorenzo Bianconi <lorenzo.bianconi@redhat.com>
Cc: linux-wireless@vger.kernel.org, sgruszka@redhat.com
Subject: Re: [PATCH] mt76: move mt76_tx_queue_mcu in mt76-core module
Date: Wed, 6 Feb 2019 15:49:43 +0100	[thread overview]
Message-ID: <5a00fd0c-3177-e057-de1a-d49c6a3b1af0@nbd.name> (raw)
In-Reply-To: <1d76867dab000720e648c68b4e1b90e81564f366.1549444343.git.lorenzo.bianconi@redhat.com>

On 2019-02-06 10:15, Lorenzo Bianconi wrote:
> Move mt76_tx_queue_mcu routine in dma.c and remove duplicated code.
> mt76_tx_queue_mcu will be reused adding support for mt7603 driver
> 
> Signed-off-by: Lorenzo Bianconi <lorenzo.bianconi@redhat.com>
I think we should rename this function, since it's going to be used for
more than just MCU commands.
Maybe mt76_dma_tx_queue_skb_raw (and add corresponding queue_op instead
of direct calls)?
While you're at it, maybe you could also remove mt76_queue_add_buf and
the corresponding queue op.

- Felix

  reply	other threads:[~2019-02-06 14:49 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <cover.1549444343.git.lorenzo.bianconi@redhat.com>
2019-02-06  9:15 ` [PATCH] mt76: move mt76_tx_queue_mcu in mt76-core module Lorenzo Bianconi
2019-02-06 14:49   ` Felix Fietkau [this message]
2019-02-06 14:59     ` Lorenzo Bianconi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5a00fd0c-3177-e057-de1a-d49c6a3b1af0@nbd.name \
    --to=nbd@nbd.name \
    --cc=linux-wireless@vger.kernel.org \
    --cc=lorenzo.bianconi@redhat.com \
    --cc=sgruszka@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox