Linux wireless drivers development
 help / color / mirror / Atom feed
From: Kalle Valo <kvalo@adurom.com>
To: "John W. Linville" <linville@tuxdriver.com>
Cc: Johannes Berg <johannes@sipsolutions.net>,
	linux-wireless@vger.kernel.org
Subject: Re: [PATCH v2 00/27] mac80211: create mac80211_ prefix
Date: Mon, 20 Jun 2011 22:55:58 +0300	[thread overview]
Message-ID: <8762o01dm9.fsf@purkki.adurom.net> (raw)
In-Reply-To: <20110620192418.GB2251@tuxdriver.com> (John W. Linville's message of "Mon\, 20 Jun 2011 15\:24\:18 -0400")

"John W. Linville" <linville@tuxdriver.com> writes:

> On Fri, Jun 17, 2011 at 02:11:40PM +0300, Kalle Valo wrote:
>
>> What do you suggest here? So that we should rename everything (both
>> mac80211 and 19 drivers) in one go? If we do that, we would have to do
>> everything in one patch to not break bisect, and it would be huge.
>> 
>> With mac80211-compat.h it's possible to break down the patches into
>> small pieces. This makes it easier to create the patches and, most
>> importantly, review them.
>> 
>> I'm willing to work on that huge patch if we so decide, but I'm not
>> sure if that's the correct way.
>> 
>> Ah, while writing this I realised that I could instead rename symbols
>> in mac80211.h one at a time and that way the patches would be smaller.
>> Did you mean that?
>
> Is there going to be another spin of this?

Yes, based on Johannes' feedback I'll drop this patchset and will
rework it. Instead I will send patches which rename mac80211.h symbols
one at a time (both from mac80211 and drivers at the same). Again this
won't happen all in once, instead I will send few patchsets to make it
easier for me. But this way we get to avoid the ugly mac80211-compat.h
file.

> I had trouble applying patch 5 -- maybe this is something that is
> best handled with a pull request?

Sure, if it's easier for you I can do that.

-- 
Kalle Valo

      reply	other threads:[~2011-06-20 19:56 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-06-13 22:34 [PATCH v2 00/27] mac80211: create mac80211_ prefix Kalle Valo
2011-06-13 22:34 ` [PATCH v2 01/27] iwlegacy: fix stop/wake queue hacks Kalle Valo
2011-06-13 22:34 ` [PATCH v2 02/27] iwlwifi: " Kalle Valo
2011-06-13 22:34 ` [PATCH v2 03/27] zd1211rw: include mac80211.h from zd_chip.h Kalle Valo
2011-06-13 22:35 ` [PATCH v2 04/27] rtlwifi: include mac80211.h from core.h Kalle Valo
2011-06-13 22:35 ` [PATCH v2 05/27] mac80211: switch mac80211.h to use mac80211 prefix Kalle Valo
2011-06-13 22:35 ` [PATCH v2 06/27] mac80211: rename ieee80211_i.h to mac80211_i.h Kalle Valo
2011-06-13 22:35 ` [PATCH v2 07/27] mac80211: rename ieee80211_local to mac80211_local Kalle Valo
2011-06-13 22:35 ` [PATCH v2 08/27] mac80211: rename ieee80211_fragment_entry to mac80211_fragment_entry Kalle Valo
2011-06-13 22:35 ` [PATCH v2 09/27] mac80211: rename ieee80211_bss to mac80211_bss Kalle Valo
2011-06-13 22:36 ` [PATCH v2 10/27] mac80211: rename ieee80211_tx_data to mac80211_tx_data Kalle Valo
2011-06-13 22:36 ` [PATCH v2 11/27] mac80211: rename ieee80211_packet_rx_flags to mac80211_packet_rx_flags Kalle Valo
2011-06-13 22:36 ` [PATCH v2 12/27] mac80211: rename ieee80211_rx_flags to mac80211_i_rx_flags Kalle Valo
2011-06-13 22:36 ` [PATCH v2 13/27] mac80211: rename ieee80211_rx_data to mac80211_rx_data Kalle Valo
2011-06-13 22:36 ` [PATCH v2 14/27] mac80211: rename ieee80211_if_ap to mac80211_if_ap Kalle Valo
2011-06-13 22:36 ` [PATCH v2 15/27] mac80211: change ieee80211_if_wds and _vlan to use mac80211 prefix Kalle Valo
2011-06-13 22:37 ` [PATCH v2 16/27] mac80211: rename ieee80211_work_type to mac80211_work_type Kalle Valo
2011-06-13 22:37 ` [PATCH v2 17/27] mac80211: rename ieee80211_work to mac80211_work Kalle Valo
2011-06-13 22:37 ` [PATCH v2 18/27] mac80211: rename ieee80211_sta_flags to mac80211_sta_flags Kalle Valo
2011-06-13 22:37 ` [PATCH v2 19/27] mac80211: rename ieee80211_if_managed to mac80211_if_managed Kalle Valo
2011-06-13 22:37 ` [PATCH v2 20/27] mac80211: rename ieee80211_if_ibss to mac80211_if_ibss Kalle Valo
2011-06-13 22:37 ` [PATCH v2 21/27] mac80211: rename ieee80211_if_mesh to mac80211_if_mesh Kalle Valo
2011-06-13 22:37 ` [PATCH v2 22/27] mac80211: rename ieee80211_sub_if_data_flags to mac80211_sub_if_data_flags Kalle Valo
2011-06-13 22:38 ` [PATCH v2 23/27] mac80211: rename ieee80211_sdata_state_bits to mac80211_sdata_state_bits Kalle Valo
2011-06-13 22:38 ` [PATCH v2 24/27] mac80211: ieee80211_sub_if_data to mac80211_sub_if_data Kalle Valo
2011-06-13 22:38 ` [PATCH v2 25/27] mac80211: use mac80211 prefix with rx and tx msg flags Kalle Valo
2011-06-13 22:38 ` [PATCH v2 26/27] mac80211: change queue stop reasons to use mac80211 prefix Kalle Valo
2011-06-13 22:38 ` [PATCH v2 27/27] mac80211: use mac80211_hw Kalle Valo
2011-06-16 15:34 ` [PATCH v2 00/27] mac80211: create mac80211_ prefix Johannes Berg
2011-06-17 11:11   ` Kalle Valo
2011-06-20 19:24     ` John W. Linville
2011-06-20 19:55       ` Kalle Valo [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8762o01dm9.fsf@purkki.adurom.net \
    --to=kvalo@adurom.com \
    --cc=johannes@sipsolutions.net \
    --cc=linux-wireless@vger.kernel.org \
    --cc=linville@tuxdriver.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox