From: Kalle Valo <kvalo@qca.qualcomm.com>
To: Michal Kazior <michal.kazior@tieto.com>
Cc: Rajkumar Manoharan <rmanohar@qti.qualcomm.com>,
"ath10k@lists.infradead.org" <ath10k@lists.infradead.org>,
linux-wireless <linux-wireless@vger.kernel.org>
Subject: Re: [PATCH] ath10k: fix htt t2h message conflicts among firmware revisions
Date: Thu, 19 Mar 2015 11:32:37 +0200 [thread overview]
Message-ID: <87r3sljpsa.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <CA+BoTQmcdiy3u8cvYYRueSoQxGzYf9Suf4dy8HpLG6UaQzJzZQ@mail.gmail.com> (Michal Kazior's message of "Thu, 19 Mar 2015 09:40:39 +0100")
Michal Kazior <michal.kazior@tieto.com> writes:
>> When I was adding WMI_OP_VERSION, my idea was that we will add similar
>> version for HTT as well once we need it. But I guess this is good enough
>> for now, we can add HTT_OP_VERSION later if more changes are needed.
>
> Maybe it should be renamed to OP_VERSION (drop the WMI_) or BRANCH_ID
> or something else?
>
> It's not like HTT wasn't diverging. It was. However only WMI ABI was
> seeing major breakage that needed taking care of. HTT changes were
> small enough and could be ignored until now.
I'm a bit worried that having one id for everything will be more
difficult to maintain, that's why I created WMI_OP_VERSION in the first
place. IMHO it's lot cleaner codewise to have one id for WMI interface
and one id for HTT (eg. HTT_OP_VERSION). What do you think?
> Perhaps the rename could be accompanied by FW API bump to 5?
Maybe not the rename, but yeah, something should be decided before the
bump up.
--
Kalle Valo
next prev parent reply other threads:[~2015-03-19 9:32 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-03-11 9:33 [PATCH] ath10k: fix htt t2h message conflicts among firmware revisions Rajkumar Manoharan
2015-03-19 8:27 ` Kalle Valo
2015-03-19 8:40 ` Michal Kazior
2015-03-19 9:32 ` Kalle Valo [this message]
2015-03-19 10:14 ` Michal Kazior
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87r3sljpsa.fsf@kamboji.qca.qualcomm.com \
--to=kvalo@qca.qualcomm.com \
--cc=ath10k@lists.infradead.org \
--cc=linux-wireless@vger.kernel.org \
--cc=michal.kazior@tieto.com \
--cc=rmanohar@qti.qualcomm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox