> The 'reserverd' field in struct mt76_connac_gtk_rekey_tlv was unused > and misspelled. Removing it cleans up the structure definition and > improves code readability. > > Signed-off-by: Nick Huang > --- > drivers/net/wireless/mediatek/mt76/mt76_connac_mcu.h | 1 - > 1 file changed, 1 deletion(-) > > diff --git a/drivers/net/wireless/mediatek/mt76/mt76_connac_mcu.h b/drivers/net/wireless/mediatek/mt76/mt76_connac_mcu.h > index 27daf4195..28cf46a5f 100644 > --- a/drivers/net/wireless/mediatek/mt76/mt76_connac_mcu.h > +++ b/drivers/net/wireless/mediatek/mt76/mt76_connac_mcu.h > @@ -1681,7 +1681,6 @@ struct mt76_connac_gtk_rekey_tlv { > __le32 group_cipher; > __le32 key_mgmt; /* NONE-PSK-IEEE802.1X */ > __le32 mgmt_group_cipher; > - u8 reserverd[4]; This field is used to keep the struct size consistent with the fw one so it is expected to not be used. Regards, Lorenzo > } __packed; > > #define MT76_CONNAC_WOW_MASK_MAX_LEN 16 > -- > 2.48.1 >