From: Julia Lawall <julia.lawall@lip6.fr>
To: Arend Van Spriel <arend.vanspriel@broadcom.com>
Cc: Julia Lawall <julia.lawall@lip6.fr>,
Tahia Khan <tahia.khan@gmail.com>,
outreachy-kernel@googlegroups.com, aditya.shankar@microchip.com,
ganesh.krishna@microchip.com, gregkh@linuxfoundation.org,
linux-wireless@vger.kernel.org, devel@driverdev.osusl.org,
linux-kernel@vger.kernel.org
Subject: Re: [Outreachy kernel] Re: [PATCH v2] staging: wilc1000: renames struct tstrRSSI and its members u8Index, u8Full
Date: Thu, 23 Feb 2017 14:38:13 +0100 (CET) [thread overview]
Message-ID: <alpine.DEB.2.20.1702231437150.3073@hadrien> (raw)
In-Reply-To: <1ffdd756-aaa4-5e1e-b72f-3e5d1f2daeb2@broadcom.com>
On Thu, 23 Feb 2017, 'Arend Van Spriel' via outreachy-kernel wrote:
> On 23-2-2017 8:08, Julia Lawall wrote:
> >> Thanks for the feedback Arend, I really appreciate it. I've decided to go with
> >> these changes in my follow-up patch request:
> >>
> >> - rename tstrRSSI to 'rssi_history_buffer' as Aren suggested since it makes the
> >> purpose of the struct clear
> >> - remove Hungarian notation from all tstrRSSI members' names
> >> - change type of u8Full to bool since it's only ever 1 or 0
> >> - change name of as8RSSI to 'samples' since this buffer is only ever used to
> >> compute an average, and the "rssi" prefix is implied by the struct's name
> >> - rename str_rssi to rssi_history in the network_info struct for clarity
> >>
> >> Since my reasoning for these changes deviates from just "renaming to
> >> avoid camel casing" (as in the original checkpatch.pl warning), would it still
> >> make sense to submit all this in a single patch? I know my commit message
> >> needs to change but I wonder if this is too much detail.
> >
> > I would strongly suggest not to do it all in a single patch. Even if these
> > changes are not very complicated conceptually, there is always a chance of
> > doing things wrong. Taking the problems one by one will improve the chance
> > that the result is correct. Also, the results will be easier for you and
> > others to review if each patch only does one thing. And easier to revert
> > if needed later if something goes wrong.
>
> It is all related to cleaning up stuff in a single struct which I
> consider "one thing" here. To me it looks a bit silly if you rename one
> struct member when it is obvious that the other two need to be renamed
> as well. The only somewhat sensible split I see here is: 1) rename the
> struct itself, 2) rename the struct members, and 3) rename str_rssi
> member in struct network_info.
OK. I guess I mainly saw the change of type as being different.
julia
>
> Regards,
> Arend
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/1ffdd756-aaa4-5e1e-b72f-3e5d1f2daeb2%40broadcom.com.
> For more options, visit https://groups.google.com/d/optout.
>
next prev parent reply other threads:[~2017-02-23 13:41 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-02-22 17:14 [PATCH v2] staging: wilc1000: renames struct tstrRSSI and its members u8Index, u8Full Tahia Khan
2017-02-22 19:50 ` Arend Van Spriel
2017-02-23 3:54 ` Tahia Khan
2017-02-23 7:08 ` [Outreachy kernel] " Julia Lawall
2017-02-23 8:56 ` Arend Van Spriel
2017-02-23 13:38 ` Julia Lawall [this message]
2017-02-23 6:24 ` Joe Perches
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.20.1702231437150.3073@hadrien \
--to=julia.lawall@lip6.fr \
--cc=aditya.shankar@microchip.com \
--cc=arend.vanspriel@broadcom.com \
--cc=devel@driverdev.osusl.org \
--cc=ganesh.krishna@microchip.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-wireless@vger.kernel.org \
--cc=outreachy-kernel@googlegroups.com \
--cc=tahia.khan@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox